aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2021-07-07 08:37:53 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2021-07-07 11:27:24 +0000
commitd442eceb42307800a843cd24ec6c3279183e28d2 (patch)
tree15414ef9320933f1352ed02318e085fc2e18171a
parentf3ddc7f01134fcbd4c83c24e905aa3aefbc858c9 (diff)
downloadports-d442eceb42307800a843cd24ec6c3279183e28d2.tar.gz
ports-d442eceb42307800a843cd24ec6c3279183e28d2.zip
x11/x-on-resize: Add new port
x-on-resize is a simple display configuration daemon. It is used to monitor the X display for output configuration changes and/or screen resize events. When these occur, it can call external programs to respond to the new display environment. WWW: https://gitlab.com/0mp/x-on-resize
-rw-r--r--x11/Makefile1
-rw-r--r--x11/x-on-resize/Makefile35
-rw-r--r--x11/x-on-resize/distinfo9
-rw-r--r--x11/x-on-resize/pkg-descr7
4 files changed, 52 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index b0668b0dda1f..6199ad127037 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -393,6 +393,7 @@
SUBDIR += workrave
SUBDIR += wshowkeys
SUBDIR += wtype
+ SUBDIR += x-on-resize
SUBDIR += x11perf
SUBDIR += x3270
SUBDIR += xantfarm
diff --git a/x11/x-on-resize/Makefile b/x11/x-on-resize/Makefile
new file mode 100644
index 000000000000..8d29603a6db8
--- /dev/null
+++ b/x11/x-on-resize/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= x-on-resize
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2
+CATEGORIES= x11
+PATCH_SITES= https://gitlab.com/${GL_ACCOUNT}/${PORTNAME}/-/commit/
+PATCHFILES= 7caa6ceec64ebb313444eabea7d892d8fee99dd9.patch:-p1 \
+ f0490d04c7cb171cd01a91dd51bf15ac4af5addf.patch:-p1 \
+ 617e5ed8bb6441ed85083881d34af8d7cf3ea7e4.patch:-p1
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Daemon for hotplug and screen reconfigure events of X displays
+
+LICENSE= GPLv2
+
+USES= autoreconf pkgconfig xorg
+USE_GITLAB= yes
+GL_ACCOUNT= 0mp
+GL_COMMIT= f59c9247e682b95f4091def7575490466f131131
+
+USE_XORG= x11 xorg-macros xrandr
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/x-on-resize \
+ man/man1/x-on-resize.1.gz
+
+PORTEXAMPLES= xrandr-auto
+
+OPTIONS_DEFINE= EXAMPLES
+
+post-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/x11/x-on-resize/distinfo b/x11/x-on-resize/distinfo
new file mode 100644
index 000000000000..540a893b1954
--- /dev/null
+++ b/x11/x-on-resize/distinfo
@@ -0,0 +1,9 @@
+TIMESTAMP = 1625645774
+SHA256 (0mp-x-on-resize-f59c9247e682b95f4091def7575490466f131131_GL0.tar.gz) = deb654f7dfc716c3c4513402b155956951fbadf8d80b664d5e3c69191d917222
+SIZE (0mp-x-on-resize-f59c9247e682b95f4091def7575490466f131131_GL0.tar.gz) = 4850
+SHA256 (7caa6ceec64ebb313444eabea7d892d8fee99dd9.patch) = 68845ea5e7874a861e7370297ab53ff9322637b76df1da066a6317e4401a210a
+SIZE (7caa6ceec64ebb313444eabea7d892d8fee99dd9.patch) = 14621
+SHA256 (f0490d04c7cb171cd01a91dd51bf15ac4af5addf.patch) = 00526dc87ba1656ea598f5899762d99798d4cb3809571716d4a9d62e895511d5
+SIZE (f0490d04c7cb171cd01a91dd51bf15ac4af5addf.patch) = 2762
+SHA256 (617e5ed8bb6441ed85083881d34af8d7cf3ea7e4.patch) = 864337c121215f9581ee310ba97acccc0251537c85dac7d6292d9399cfc4b2b0
+SIZE (617e5ed8bb6441ed85083881d34af8d7cf3ea7e4.patch) = 9296
diff --git a/x11/x-on-resize/pkg-descr b/x11/x-on-resize/pkg-descr
new file mode 100644
index 000000000000..101f055a5075
--- /dev/null
+++ b/x11/x-on-resize/pkg-descr
@@ -0,0 +1,7 @@
+x-on-resize is a simple display configuration daemon.
+
+It is used to monitor the X display for output configuration
+changes and/or screen resize events. When these occur, it can call
+external programs to respond to the new display environment.
+
+WWW: https://gitlab.com/0mp/x-on-resize