aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2022-03-08 22:47:10 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2022-03-09 10:07:56 +0000
commitd45ce823b33f09815dd6549a1b974e31e6c1d77c (patch)
tree92f75130a03e4068134bd6b65d7e67183decc271
parent426ce352e42c56de7f31e63b868e94fb898fdd8c (diff)
downloadports-d45ce823b33f09815dd6549a1b974e31e6c1d77c.tar.gz
ports-d45ce823b33f09815dd6549a1b974e31e6c1d77c.zip
www/gitlab-ce: Update to 14.8.0
Changelog: https://about.gitlab.com/releases/2022/02/22/gitlab-14-8-released/ GitLab chart improvements (self-managed only): Cloud Native Installation Omnibus improvements (self-managed only): Omnibus Package Invite members and groups by using a modal: Authentication and Authorization Manage Delete groups at the parent group level: Subgroups Support for ecdsa-sk and ed25519-sk SSH keys: Authentication and Authorization Plan Add default issue and merge request templates in a project's repository: Team Planning Create Improved cleanup of gitconfig file: Gitaly Verify View read-only runner details in the Admin Area (self-managed only): GitLab Runner Use the CI Lint API with other branches or tags: Pipeline Authoring Improve pipeline index page layout: Continuous Integration (CI) GitLab Runner 14.8: GitLab Runner Auto-completion of keywords in the Pipeline Editor: Pipeline Authoring Secure Static Analysis analyzer updates: SAST, Secret Detection SAST severities now available for .NET: SAST Release Set custom rate limiting for GitLab Pages: Pages Latest Release badge for the project: Release Orchestration Configure The agent server for Kubernetes is enabled by default (self-managed only): Infrastructure as Code
-rw-r--r--www/gitlab-ce/Makefile37
-rw-r--r--www/gitlab-ce/distinfo6
-rw-r--r--www/gitlab-ce/files/patch-Gemfile8
-rw-r--r--www/gitlab-ce/files/patch-config_gitlab.yml.example14
-rw-r--r--www/gitlab-ce/pkg-message4
5 files changed, 33 insertions, 36 deletions
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index fa749736e832..e2d8efc275d8 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -1,8 +1,8 @@
# Created by: Torsten Zuehlsdorff <tz@FreeBSD.org>
PORTNAME= gitlab-ce
-PORTVERSION= 14.7.3
-PORTREVISION= 2
+PORTVERSION= 14.8.0
+PORTREVISION= 0
CATEGORIES= www devel
MAINTAINER= mfechner@FreeBSD.org
@@ -18,15 +18,15 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
MY_DEPENDS= git>=2.32.0:devel/git \
gitaly>=${PORTVERSION}:devel/gitaly \
gitlab-elasticsearch-indexer>=2.17.0:textproc/gitlab-elasticsearch-indexer \
- gitlab-agent>=14.4.0:net/gitlab-agent \
- gitlab-pages>=1.51.0:www/gitlab-pages \
- gitlab-shell>=13.22.2:devel/gitlab-shell \
+ gitlab-agent>=14.8.1:net/gitlab-agent \
+ gitlab-pages>=1.54.0:www/gitlab-pages \
+ gitlab-shell>=13.23.2:devel/gitlab-shell \
gitlab-workhorse>=${PORTVERSION}:www/gitlab-workhorse \
redis>=6.0.14:databases/redis \
yarn>=1.10.0:www/yarn \
gtar>0:archivers/gtar \
bash>0:shells/bash \
- rubygem-rails61>=6.1.4.4<6.1.5:www/rubygem-rails61 \
+ rubygem-rails61>=6.1.4.6<6.1.5:www/rubygem-rails61 \
rubygem-bootsnap>=1.9.1<1.11:devel/rubygem-bootsnap \
rubygem-responders-rails61>=3.0<4.0:www/rubygem-responders-rails61 \
rubygem-sprockets3>=3.7<3.8:devel/rubygem-sprockets3 \
@@ -75,7 +75,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-attr_encrypted>=3.1.0<3.2.0:security/rubygem-attr_encrypted \
rubygem-u2f0>=0.2.1<0.3.0:net/rubygem-u2f0 \
rubygem-validates_hostname>=1.0.11<1.1.0:dns/rubygem-validates_hostname \
- rubygem-rubyzip20>=2.0.0<2.1.0:archivers/rubygem-rubyzip20 \
+ rubygem-rubyzip>=2.3.2<2.4:archivers/rubygem-rubyzip \
rubygem-acme-client>=2.0.9<3:security/rubygem-acme-client \
rubygem-browser>=4.2<5.0:www/rubygem-browser \
rubygem-ohai>=16.10<17:sysutils/rubygem-ohai \
@@ -140,12 +140,12 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-diff_match_patch>=0.1.0<0.2.0:textproc/rubygem-diff_match_patch \
rubygem-rack>=2.2.3<2.3,3:www/rubygem-rack \
rubygem-rack-timeout>=0.5.1<0.6:www/rubygem-rack-timeout \
- rubygem-puma>=5.5.2<5.6:www/rubygem-puma \
+ rubygem-puma>=5.6.2<5.7:www/rubygem-puma \
rubygem-puma_worker_killer>=0.3.1:www/rubygem-puma_worker_killer \
rubygem-sd_notify>=0.1.0<0.2:devel/rubygem-sd_notify \
rubygem-state_machines-activerecord>=0.8.0<0.9.0:databases/rubygem-state_machines-activerecord \
rubygem-acts-as-taggable-on>=9.0<10:www/rubygem-acts-as-taggable-on \
- rubygem-sidekiq>=6.3<7:devel/rubygem-sidekiq \
+ rubygem-sidekiq>=6.4<7:devel/rubygem-sidekiq \
rubygem-sidekiq-cron>=1.2<2.0:devel/rubygem-sidekiq-cron \
rubygem-redis-namespace>=1.8.1<1.9.0:databases/rubygem-redis-namespace \
rubygem-gitlab-sidekiq-fetcher>=0.8.0<0.9:devel/rubygem-gitlab-sidekiq-fetcher \
@@ -159,7 +159,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-js_regex>=3.7<4.0:textproc/rubygem-js_regex \
rubygem-device_detector>=0:devel/rubygem-device_detector \
rubygem-redis44>=4.4.0<4.5:databases/rubygem-redis44 \
- rubygem-connection_pool>=2.0<3.0:net/rubygem-connection_pool \
+ rubygem-connection_pool>=2.2.5<3.0:net/rubygem-connection_pool \
rubygem-redis-actionpack-rails61>=5.2.0<5.3:databases/rubygem-redis-actionpack-rails61 \
rubygem-discordrb-webhooks>=3.4<4.0:net-im/rubygem-discordrb-webhooks \
rubygem-jira-ruby>=2.1.4<2.2:devel/rubygem-jira-ruby \
@@ -186,14 +186,14 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-addressable>=2.8<3:www/rubygem-addressable \
rubygem-tanuki_emoji>=0.5<1:graphics/rubygem-tanuki_emoji \
rubygem-gon-rails61>=6.4.0<6.5:www/rubygem-gon-rails61 \
- rubygem-request_store>=1.5<2.0:devel/rubygem-request_store \
+ rubygem-request_store>=1.5.1<2.0:devel/rubygem-request_store \
rubygem-base32>=0.3.0<0.4.0:converters/rubygem-base32 \
- rubygem-gitlab-license>=2.0<3:devel/rubygem-gitlab-license \
+ rubygem-gitlab-license>=2.1.0<2.2:devel/rubygem-gitlab-license \
rubygem-rack-attack>=6.3.0<6.4.0:www/rubygem-rack-attack \
rubygem-sentry-raven>=3.1<4.0:devel/rubygem-sentry-raven \
rubygem-pg_query>=2.1<3:databases/rubygem-pg_query \
rubygem-premailer-rails-rails61>=1.10.3<1.11.0:mail/rubygem-premailer-rails-rails61 \
- rubygem-gitlab-labkit>=0.21.3<0.22:devel/rubygem-gitlab-labkit \
+ rubygem-gitlab-labkit>=0.22.0<0.23:devel/rubygem-gitlab-labkit \
rubygem-thrift>=0.14.0:devel/rubygem-thrift \
rubygem-ruby_parser>=3.15<4.0:devel/rubygem-ruby_parser \
rubygem-rails-i18n-rails61>=6.0<7.0:devel/rubygem-rails-i18n-rails61 \
@@ -223,12 +223,9 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-vmstat>=2.3.0<2.4.0:sysutils/rubygem-vmstat \
rubygem-sys-filesystem>=1.4.3<1.5:sysutils/rubygem-sys-filesystem \
rubygem-net-ntp>0:net/rubygem-net-ntp \
- rubygem-net-ssh>=6.0<7,2:security/rubygem-net-ssh \
- rubygem-sshkey>=2.0<3.0:security/rubygem-sshkey \
- rubygem-ed25519>=1.2<2.0:security/rubygem-ed25519 \
- rubygem-bcrypt_pbkdf>=1.1<2.0:security/rubygem-bcrypt_pbkdf \
+ rubygem-ssh_data>=1.2<2:security/rubygem-ssh_data \
rubygem-spamcheck>=0.1.0<0.2:net/rubygem-spamcheck \
- rubygem-gitaly>=14.6.0.pre.rc1<14.7.0:net/rubygem-gitaly \
+ rubygem-gitaly>=14.8.0.pre.rc1<14.9.0:net/rubygem-gitaly \
rubygem-kas-grpc>=0.0.2,1<0.0.3,1:net/rubygem-kas-grpc \
rubygem-grpc142>=1.42.0<1.43:net/rubygem-grpc142 \
rubygem-google-protobuf>=3.19.0<3.20:devel/rubygem-google-protobuf \
@@ -237,7 +234,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-flipper-active_record-rails61>=0.21.0<0.22:databases/rubygem-flipper-active_record-rails61 \
rubygem-flipper-active_support_cache_store-rails61>=0.21.0<0.22:devel/rubygem-flipper-active_support_cache_store-rails61 \
rubygem-unleash>=3.2.2<3.3:devel/rubygem-unleash \
- rubygem-gitlab-experiment>=0.6.5<0.7:devel/rubygem-gitlab-experiment \
+ rubygem-gitlab-experiment>=0.7.0<0.8:devel/rubygem-gitlab-experiment \
rubygem-lograge-rails61>=0.11.2<1.0:www/rubygem-lograge-rails61 \
rubygem-grape_logging>=1.7<2.0:devel/rubygem-grape_logging \
rubygem-gitlab-net-dns>=0.9.1<0.10:dns/rubygem-gitlab-net-dns \
@@ -278,7 +275,7 @@ USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
GL_PROJECT= gitlab-foss
# Find the here: https://gitlab.com/gitlab-org/gitlab-foss/-/tags
-GL_COMMIT= 293f6bb322ba6f3aba63744cea1cc3c9d648aba0
+GL_COMMIT= 3f274363e9dc9a1be75edfcd3dd5adb64b1e8c29
USERS= git
GROUPS= git
diff --git a/www/gitlab-ce/distinfo b/www/gitlab-ce/distinfo
index 03780a6adaa4..cfcf381fbb50 100644
--- a/www/gitlab-ce/distinfo
+++ b/www/gitlab-ce/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1644937608
-SHA256 (gitlab-org-gitlab-foss-293f6bb322ba6f3aba63744cea1cc3c9d648aba0_GL0.tar.gz) = bfa8cfa540b47dd665bce7fb2b7d36d686d238b1d10b974d765b4a25715d0406
-SIZE (gitlab-org-gitlab-foss-293f6bb322ba6f3aba63744cea1cc3c9d648aba0_GL0.tar.gz) = 101617590
+TIMESTAMP = 1645606465
+SHA256 (gitlab-org-gitlab-foss-3f274363e9dc9a1be75edfcd3dd5adb64b1e8c29_GL0.tar.gz) = 8ac2d2bb30f954cc3caa8b29e648d3136bf29a2aa066fc1ce417b9065d5c5b5a
+SIZE (gitlab-org-gitlab-foss-3f274363e9dc9a1be75edfcd3dd5adb64b1e8c29_GL0.tar.gz) = 102523804
diff --git a/www/gitlab-ce/files/patch-Gemfile b/www/gitlab-ce/files/patch-Gemfile
index 5e0004d14ef5..8e0f96a93c6a 100644
--- a/www/gitlab-ce/files/patch-Gemfile
+++ b/www/gitlab-ce/files/patch-Gemfile
@@ -1,8 +1,8 @@
---- Gemfile.orig 2022-01-21 10:23:10 UTC
+--- Gemfile.orig 2022-02-21 12:45:48 UTC
+++ Gemfile
@@ -4,7 +4,7 @@ source 'https://rubygems.org'
- gem 'rails', '~> 6.1.4.4'
+ gem 'rails', '~> 6.1.4.6'
-gem 'bootsnap', '~> 1.9.1', require: false
+gem 'bootsnap', '~> 1.9', require: false
@@ -99,7 +99,7 @@
-end
-
-group :development, :test, :danger do
-- gem 'gitlab-dangerfiles', '~> 2.6.1', require: false
+- gem 'gitlab-dangerfiles', '~> 2.8.0', require: false
-end
-
-group :development, :test, :coverage do
@@ -143,7 +143,7 @@
gem 'octokit', '~> 4.15'
# Updating this gem version here is deprecated. See:
-@@ -542,3 +440,6 @@ gem 'ipaddress', '~> 0.8.3'
+@@ -535,3 +433,6 @@ gem 'ipaddress', '~> 0.8.3'
gem 'parslet', '~> 1.8'
gem 'ipynbdiff', '0.3.8'
diff --git a/www/gitlab-ce/files/patch-config_gitlab.yml.example b/www/gitlab-ce/files/patch-config_gitlab.yml.example
index f0f1142abbb8..2bcd5cf510f6 100644
--- a/www/gitlab-ce/files/patch-config_gitlab.yml.example
+++ b/www/gitlab-ce/files/patch-config_gitlab.yml.example
@@ -1,6 +1,6 @@
---- config/gitlab.yml.example.orig 2022-01-21 10:23:10 UTC
+--- config/gitlab.yml.example.orig 2022-02-21 12:45:48 UTC
+++ config/gitlab.yml.example
-@@ -1139,14 +1139,14 @@ production: &base
+@@ -1156,14 +1156,14 @@ production: &base
# real path not the symlink.
storages: # You must have at least a `default` storage path.
default:
@@ -18,7 +18,7 @@
# archive_permissions: 0640 # Permissions for the resulting backup.tar file (default: 0600)
# keep_time: 604800 # default: 0 (forever) (in seconds)
# pg_schema: public # default: nil, it means that all schemas will be backed up
-@@ -1195,12 +1195,12 @@ production: &base
+@@ -1212,12 +1212,12 @@ production: &base
## GitLab Shell settings
gitlab_shell:
@@ -34,7 +34,7 @@
# Git over HTTP
upload_pack: true
-@@ -1215,13 +1215,13 @@ production: &base
+@@ -1232,13 +1232,13 @@ production: &base
workhorse:
# File that contains the secret key for verifying access for gitlab-workhorse.
# Default is '.gitlab_workhorse_secret' relative to Rails.root (i.e. root of the GitLab app).
@@ -50,7 +50,7 @@
# The URL to the external KAS API (used by the Kubernetes agents)
# external_url: wss://kas.example.com
-@@ -1234,13 +1234,13 @@ production: &base
+@@ -1251,13 +1251,13 @@ production: &base
## GitLab Elasticsearch settings
elasticsearch:
@@ -66,7 +66,7 @@
## Webpack settings
# If enabled, this will tell rails to serve frontend assets from the webpack-dev-server running
-@@ -1261,16 +1261,16 @@ production: &base
+@@ -1278,16 +1278,16 @@ production: &base
# Sidekiq exporter is webserver built in to Sidekiq to expose Prometheus metrics
sidekiq_exporter:
@@ -91,7 +91,7 @@
# Web exporter is a dedicated Rack server running alongside Puma to expose Prometheus metrics
# It runs alongside the `/metrics` endpoints to ease the publish of metrics
-@@ -1488,13 +1488,13 @@ test:
+@@ -1508,13 +1508,13 @@ test:
gitaly_address: unix:tmp/tests/gitaly/praefect.socket
gitaly:
diff --git a/www/gitlab-ce/pkg-message b/www/gitlab-ce/pkg-message
index 6f8456e9722a..075280813c23 100644
--- a/www/gitlab-ce/pkg-message
+++ b/www/gitlab-ce/pkg-message
@@ -6,7 +6,7 @@ Gitlab was installed successfully.
You now need to set up the various components of Gitlab, so please
follow the instructions in the guide at:
-https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/install/14.7-freebsd.md
+https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/install/14.8-freebsd.md
EOM
type: install
}
@@ -20,7 +20,7 @@ EOM
If you just installed an major upgrade of GitLab, for example you
switched from 14.5.x to 14.6.x, please follow the instructions in the guide at:
-https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/update/14.6-14.7-freebsd.md
+https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/update/14.7-14.8-freebsd.md
If you just installed an minor upgrade of GitLab please follow
the instructions in the guide at: