aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRozhuk Ivan <rozhuk.im@gmail.com>2023-11-02 12:03:10 +0000
committerRenato Botelho <garga@FreeBSD.org>2023-11-02 12:04:36 +0000
commitd460a655e8b70d632fddce72e6850495a24a6984 (patch)
tree6958f42839fada03a474f7a6e848fcfb4d447166
parent18211761cddf8089f004a4cdcb5315e7eda33d71 (diff)
downloadports-d460a655e8b70d632fddce72e6850495a24a6984.tar.gz
ports-d460a655e8b70d632fddce72e6850495a24a6984.zip
net/xmlrpc-c: Fix build with openssl from ports
Make the port to always depend of openssl since it's always used when detected. PR: 273969
-rw-r--r--net/xmlrpc-c/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/net/xmlrpc-c/Makefile b/net/xmlrpc-c/Makefile
index b39ccb0ac3cb..41c7820f8c93 100644
--- a/net/xmlrpc-c/Makefile
+++ b/net/xmlrpc-c/Makefile
@@ -1,5 +1,6 @@
PORTNAME= xmlrpc-c
PORTVERSION= 1.54.06
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/Xmlrpc-c%20Super%20Stable/${PORTVERSION}
@@ -9,7 +10,7 @@ WWW= http://xmlrpc-c.sourceforge.net/
LICENSE= BSD3CLAUSE
-USES= gmake pkgconfig tar:tgz
+USES= gmake pkgconfig ssl tar:tgz
USE_CXXSTD= c++11
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -18,7 +19,8 @@ MAKEFILE= GNUmakefile
MAKE_ENV+= INSTALL_SHLIB="${INSTALL_LIB}" \
INSTALL_SCRIPT="${INSTALL_SCRIPT}"
MAKE_JOBS_UNSAFE= yes
-LDFLAGS+= -lm
+CFLAGS= -I${OPENSSLINC}
+LDFLAGS= -L${OPENSSLLIB} -lm
CONFLICTS= xmlrpc-epi-0.*
@@ -34,7 +36,6 @@ CURL_LIB_DEPENDS= libcurl.so:ftp/curl
CURL_CONFIGURE_ENABLE= curl-client
LIBWWW_LIB_DEPENDS= libwwwcore.so:www/libwww \
libexpat.so:textproc/expat2
-LIBWWW_USES= ssl
LIBWWW_CONFIGURE_ENABLE=libwww-client
LIBWWW_CONFIGURE_WITH= libwww-ssl