aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-05 17:07:24 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-05 17:29:38 +0000
commitd4bcc76818c48b91af3dcf5677786768fe9c9330 (patch)
tree86ff01fb11ccd61bb90f0470eaaf8c455d0f3e54
parentdad043a7779798a228bce76d38bb72a3c257bfc0 (diff)
downloadports-d4bcc76818c48b91af3dcf5677786768fe9c9330.tar.gz
ports-d4bcc76818c48b91af3dcf5677786768fe9c9330.zip
devel/py-frictionless-ckan-mapper: Add py-frictionless-ckan-mapper 1.0.9
Frictionless CKAN Mapper is a library for mapping CKAN metadata from/to Frictionless metadata. The library has zero dependencies (not even on Data Package libs). You can use it directly or use it for inspiration. Detailed outline of the algorithm is in the docs or you can read the code.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-frictionless-ckan-mapper/Makefile22
-rw-r--r--devel/py-frictionless-ckan-mapper/distinfo3
-rw-r--r--devel/py-frictionless-ckan-mapper/pkg-descr6
4 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2c3a609f9efd..074a22c6cae0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4620,6 +4620,7 @@
SUBDIR += py-freenas.utils
SUBDIR += py-freezegun
SUBDIR += py-frictionless
+ SUBDIR += py-frictionless-ckan-mapper
SUBDIR += py-frozendict
SUBDIR += py-frozenlist
SUBDIR += py-fs
diff --git a/devel/py-frictionless-ckan-mapper/Makefile b/devel/py-frictionless-ckan-mapper/Makefile
new file mode 100644
index 000000000000..1d567f2c403f
--- /dev/null
+++ b/devel/py-frictionless-ckan-mapper/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= frictionless-ckan-mapper
+PORTVERSION= 1.0.9
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Library for mapping CKAN metadata from/to Frictionless metadata
+WWW= https://github.com/frictionlessdata/frictionless-ckan-mapper
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.9<2.0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}unidecode>=0:converters/py-unidecode@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-frictionless-ckan-mapper/distinfo b/devel/py-frictionless-ckan-mapper/distinfo
new file mode 100644
index 000000000000..aa50f2a7ca2b
--- /dev/null
+++ b/devel/py-frictionless-ckan-mapper/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1679498492
+SHA256 (frictionless-ckan-mapper-1.0.9.tar.gz) = 9972b94f59709bf83928a02f9581a42981364a69c2a150053178427432b37893
+SIZE (frictionless-ckan-mapper-1.0.9.tar.gz) = 16223
diff --git a/devel/py-frictionless-ckan-mapper/pkg-descr b/devel/py-frictionless-ckan-mapper/pkg-descr
new file mode 100644
index 000000000000..c49ff74aab20
--- /dev/null
+++ b/devel/py-frictionless-ckan-mapper/pkg-descr
@@ -0,0 +1,6 @@
+Frictionless CKAN Mapper is a library for mapping CKAN metadata from/to
+Frictionless metadata.
+
+The library has zero dependencies (not even on Data Package libs). You can use
+it directly or use it for inspiration. Detailed outline of the algorithm is in
+the docs or you can read the code.