aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-16 15:12:49 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-16 15:23:46 +0000
commitd4ca6956380f540c2f19ad811a05c28d66b9632c (patch)
tree02174c0eee2b9ce9642da17895ef2422e6a08b08
parent0d58f5fdaaf0441f40dc94dc1d74c5efe831a3e2 (diff)
downloadports-d4ca6956380f540c2f19ad811a05c28d66b9632c.tar.gz
ports-d4ca6956380f540c2f19ad811a05c28d66b9632c.zip
print/py-fontparts: Add py-fontparts 0.9.10
FontParts provides an API for interacting with the parts of fonts during the font development process. FontParts is the replacement for RoboFab. WWW: https://github.com/robotools/fontParts
-rw-r--r--print/Makefile1
-rw-r--r--print/py-fontparts/Makefile28
-rw-r--r--print/py-fontparts/distinfo3
-rw-r--r--print/py-fontparts/files/patch-setup.py11
-rw-r--r--print/py-fontparts/pkg-descr4
5 files changed, 47 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index cea14a49af20..561c6f7bad3a 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -174,6 +174,7 @@
SUBDIR += py-font-v
SUBDIR += py-fontaine
SUBDIR += py-fontbakery
+ SUBDIR += py-fontparts
SUBDIR += py-fonttools
SUBDIR += py-fonttools3
SUBDIR += py-fpdf
diff --git a/print/py-fontparts/Makefile b/print/py-fontparts/Makefile
new file mode 100644
index 000000000000..fe831daf4810
--- /dev/null
+++ b/print/py-fontparts/Makefile
@@ -0,0 +1,28 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= fontparts
+PORTVERSION= 0.9.10
+CATEGORIES= print python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= fontParts-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= API for interacting with the parts of fonts during the font development process
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}booleanOperations>=0.8.2:x11-fonts/py-booleanOperations@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}defcon>=0.6.0:x11-fonts/py-defcon@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fontMath>=0.4.8:x11-fonts/py-fontMath@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fontpens>=0.1.0:print/py-fontpens@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fonttools>=3.32.0:print/py-fonttools@${PY_FLAVOR}
+
+USES= python:3.6+ zip
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/print/py-fontparts/distinfo b/print/py-fontparts/distinfo
new file mode 100644
index 000000000000..4e76a44ad0f7
--- /dev/null
+++ b/print/py-fontparts/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1620928539
+SHA256 (fontParts-0.9.10.zip) = 4898942385e0ea28a721fd8de3232f5db7b6c528840754fa8b703a3617b69243
+SIZE (fontParts-0.9.10.zip) = 495801
diff --git a/print/py-fontparts/files/patch-setup.py b/print/py-fontparts/files/patch-setup.py
new file mode 100644
index 000000000000..5bf06ce825c6
--- /dev/null
+++ b/print/py-fontparts/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2021-03-09 14:24:32 UTC
++++ setup.py
+@@ -28,7 +28,7 @@ setup_params = dict(
+ "FontTools[ufo,lxml,unicode]>=3.32.0",
+ "fontMath>=0.4.8",
+ "defcon[pens]>=0.6.0",
+- "booleanOperations>=0.9.0",
++ "booleanOperations>=0.8.2",
+ ],
+ classifiers=[
+ "Development Status :: 4 - Beta",
diff --git a/print/py-fontparts/pkg-descr b/print/py-fontparts/pkg-descr
new file mode 100644
index 000000000000..7a401baa23ab
--- /dev/null
+++ b/print/py-fontparts/pkg-descr
@@ -0,0 +1,4 @@
+FontParts provides an API for interacting with the parts of fonts during the
+font development process. FontParts is the replacement for RoboFab.
+
+WWW: https://github.com/robotools/fontParts