aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2022-10-11 21:13:08 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2022-10-25 05:44:04 +0000
commitd5bd9f5d05575bda0bf5696f532e57eebea7f618 (patch)
treee45e91b4f4ef8886bf66302a989bb9e5d7d22b9f
parentfa02c1768b5743cac4614bd031c8a2b457df7545 (diff)
downloadports-d5bd9f5d05575bda0bf5696f532e57eebea7f618.tar.gz
ports-d5bd9f5d05575bda0bf5696f532e57eebea7f618.zip
cad/kicad: use wx 32
PR: 265093
-rw-r--r--cad/kicad/Makefile3
-rw-r--r--cad/kicad/files/patch-eeschema_sim_sim__plot__frame.cpp23
2 files changed, 25 insertions, 1 deletions
diff --git a/cad/kicad/Makefile b/cad/kicad/Makefile
index cca7ae65d8e8..839ee8e978a1 100644
--- a/cad/kicad/Makefile
+++ b/cad/kicad/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kicad
PORTVERSION= 6.0.8
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= cad
MASTER_SITES= https://gitlab.com/${PORTNAME}/code/${PORTNAME}/-/archive/${DISTVERSION}/
@@ -30,7 +31,7 @@ SHEBANG_FILES= pcbnew/python/plugins/touch_slider_wizard.py
USE_XORG= ice x11 xext
USE_GL= gl glu glut
-USE_WX= 3.1
+USE_WX= 3.2
WX_COMPS= python:lib wx
USE_GNOME= atk cairo gdkpixbuf2 gtk30 pango
CXXFLAGS+= --std=c++11 -I${WRKSRC}/include -I${LOCALBASE}/include
diff --git a/cad/kicad/files/patch-eeschema_sim_sim__plot__frame.cpp b/cad/kicad/files/patch-eeschema_sim_sim__plot__frame.cpp
new file mode 100644
index 000000000000..a7b40f4b3256
--- /dev/null
+++ b/cad/kicad/files/patch-eeschema_sim_sim__plot__frame.cpp
@@ -0,0 +1,23 @@
+--- eeschema/sim/sim_plot_frame.cpp.orig 2022-09-14 16:35:24 UTC
++++ eeschema/sim/sim_plot_frame.cpp
+@@ -167,15 +167,15 @@ SIM_PLOT_FRAME::SIM_PLOT_FRAME( KIWAY* aKiway, wxWindo
+ Bind( EVT_SIM_CURSOR_UPDATE, &SIM_PLOT_FRAME::onCursorUpdate, this );
+
+ // Toolbar buttons
+- m_toolSimulate = m_toolBar->AddTool( ID_SIM_RUN, _( "Run/Stop Simulation" ),
++ m_toolSimulate = m_toolBar->AddTool( ID_SIM_RUN, wxEmptyString,
+ KiBitmap( BITMAPS::sim_run ), _( "Run Simulation" ), wxITEM_NORMAL );
+- m_toolAddSignals = m_toolBar->AddTool( ID_SIM_ADD_SIGNALS, _( "Add Signals" ),
++ m_toolAddSignals = m_toolBar->AddTool( ID_SIM_ADD_SIGNALS, wxEmptyString,
+ KiBitmap( BITMAPS::sim_add_signal ), _( "Add signals to plot" ), wxITEM_NORMAL );
+- m_toolProbe = m_toolBar->AddTool( ID_SIM_PROBE, _( "Probe" ),
++ m_toolProbe = m_toolBar->AddTool( ID_SIM_PROBE, wxEmptyString,
+ KiBitmap( BITMAPS::sim_probe ), _( "Probe signals on the schematic" ), wxITEM_NORMAL );
+- m_toolTune = m_toolBar->AddTool( ID_SIM_TUNE, _( "Tune" ),
++ m_toolTune = m_toolBar->AddTool( ID_SIM_TUNE, wxEmptyString,
+ KiBitmap( BITMAPS::sim_tune ), _( "Tune component values" ), wxITEM_NORMAL );
+- m_toolSettings = m_toolBar->AddTool( wxID_ANY, _( "Sim Parameters" ),
++ m_toolSettings = m_toolBar->AddTool( wxID_ANY, wxEmptyString,
+ KiBitmap( BITMAPS::config ), _( "Simulation parameters and settings" ), wxITEM_NORMAL );
+
+ // Start all toolbar buttons except settings as disabled