aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWHR <msl0000023508@gmail.com>2022-10-22 19:43:23 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2022-10-22 19:44:26 +0000
commitd5c6e741d8a1bc9b571876fa4d1426167e27e8e8 (patch)
treeed1bb70421e0bfd313b5e2e6bbd4aa57bb937240
parent3cfd8cfeebfbcf34b5c75fa8550d29856b8f737a (diff)
downloadports-d5c6e741d8a1bc9b571876fa4d1426167e27e8e8.tar.gz
ports-d5c6e741d8a1bc9b571876fa4d1426167e27e8e8.zip
Add sysutils/fusefs-nbt: Editing Named Binary Tag (NBT) as using a file system
PR: 263398
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fusefs-nbt/Makefile35
-rw-r--r--sysutils/fusefs-nbt/distinfo3
-rw-r--r--sysutils/fusefs-nbt/pkg-descr11
-rw-r--r--sysutils/fusefs-nbt/pkg-plist15
5 files changed, 65 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 872a0636957d..378cf179681b 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -433,6 +433,7 @@
SUBDIR += fusefs-lkl
SUBDIR += fusefs-mhddfs
SUBDIR += fusefs-mp3fs
+ SUBDIR += fusefs-nbt
SUBDIR += fusefs-ntfs
SUBDIR += fusefs-ntfs-compression
SUBDIR += fusefs-pod
diff --git a/sysutils/fusefs-nbt/Makefile b/sysutils/fusefs-nbt/Makefile
new file mode 100644
index 000000000000..6b602d481d04
--- /dev/null
+++ b/sysutils/fusefs-nbt/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= nbt
+PORTVERSION= ${REVISION_DATE}
+CATEGORIES= sysutils
+MASTER_SITES= SF/nbtfsutils
+PKGNAMEPREFIX= fusefs-
+DISTNAME= nbtfsutils-${REVISION_DATE}-${REVISION_HASH}-src
+
+MAINTAINER= msl0000023508@gmail.com
+COMMENT= Editing Named Binary Tag (NBT) as using a file system
+WWW= https://sourceforge.net/projects/nbtfsutils/
+
+LICENSE= BEERWARE MIT MPL20
+LICENSE_COMB= multi
+LICENSE_NAME_BEERWARE= "THE BEER-WARE LICENSE" (Revision 42)
+LICENSE_TEXT_BEERWARE= Lukas Niederbremer <webmaster@flippeh.de> and Clark Gaebel <cg.wowus.cg@gmail.com> \
+ wrote this file. As long as you retain this notice you can do whatever you \
+ want with this stuff. If we meet some day, and you think this stuff is worth \
+ it, you can buy us a beer in return.
+LICENSE_FILE_MPL20= ${WRKSRC}/MPL-2.0
+LICENSE_PERMS_BEERWARE= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USES= fuse tar:bz2
+
+REVISION_DATE= 20220412
+REVISION_HASH= 09b007a
+
+MAKE_ENV= MANDIR=\${PREFIX}/man
+ALL_TARGET= libnbt.so all
+INSTALL_TARGET= install-commands install-dev
+CFLAGS+= ${CPPFLAGS}
+CPPFLAGS+= -I ${LOCALBASE}/include
+LDFLAGS+= -L ${LOCALBASE}/lib
+NO_WRKSUBDIR= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/fusefs-nbt/distinfo b/sysutils/fusefs-nbt/distinfo
new file mode 100644
index 000000000000..f388f04f50c3
--- /dev/null
+++ b/sysutils/fusefs-nbt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1650298920
+SHA256 (nbtfsutils-20220412-09b007a-src.tar.bz2) = f1c0155ba741357e90e83bd68f87ad4f501181b3a8cd02b461f9b60b361eb29c
+SIZE (nbtfsutils-20220412-09b007a-src.tar.bz2) = 1459524
diff --git a/sysutils/fusefs-nbt/pkg-descr b/sysutils/fusefs-nbt/pkg-descr
new file mode 100644
index 000000000000..1060a6bd8392
--- /dev/null
+++ b/sysutils/fusefs-nbt/pkg-descr
@@ -0,0 +1,11 @@
+Named Binary Tag (NBT) is a binary format designed for and used by the game
+Minecraft to store various data including worlds, player data and many other
+things. This project provides a way to access those data by simply mounting
+the corresponding data file as a file system, then reading and writing any
+value as usual file system nodes.
+
+NBT parser and writer are originally written by Lukas Niederbremer as cNBT
+project which this project is based on.
+
+This package provides the FUSE-based file system implementation, as well as
+NBT maintenance command-line tools and library (cNBT).
diff --git a/sysutils/fusefs-nbt/pkg-plist b/sysutils/fusefs-nbt/pkg-plist
new file mode 100644
index 000000000000..b58dc26fd30f
--- /dev/null
+++ b/sysutils/fusefs-nbt/pkg-plist
@@ -0,0 +1,15 @@
+bin/nbtdump
+bin/regiondump
+sbin/mkfs.nbt
+sbin/mount.nbt
+man/man1/nbtdump.1.gz
+man/man1/regiondump.1.gz
+man/man8/mkfs.nbt.8.gz
+man/man8/mount.nbt.8.gz
+include/nbt/buffer.h
+include/nbt/list.h
+include/nbt/nbt.h
+include/nbt/version.h
+lib/libnbt.a
+lib/libnbt.so
+lib/libnbt.so.1