aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2002-11-06 22:53:55 +0000
committerGreg Lewis <glewis@FreeBSD.org>2002-11-06 22:53:55 +0000
commitd5ed70a5223470eedbb2ca57527066d5adc96f11 (patch)
tree0bb35f9cc3540b187b4eced4f93be6eb428f08af
parentd9611f93758b42bc9f2e2794b3d0039ec6038c4e (diff)
downloadports-d5ed70a5223470eedbb2ca57527066d5adc96f11.tar.gz
ports-d5ed70a5223470eedbb2ca57527066d5adc96f11.zip
Fix user and group ownership of the installed files when they have been
built by someone other than root. Instead of moving the files with tar, move them with cpio and set up ownership. PR: 36411 (9 more ports to go) Submitted by: alane
Notes
Notes: svn path=/head/; revision=69613
-rw-r--r--java/gnu-regexp/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/java/gnu-regexp/Makefile b/java/gnu-regexp/Makefile
index 09190ef3a6b7..f200663d7721 100644
--- a/java/gnu-regexp/Makefile
+++ b/java/gnu-regexp/Makefile
@@ -20,9 +20,12 @@ NO_BUILD= yes
DOCDIR= ${PREFIX}/share/doc/${PORTNAME}
+CPIO?= /usr/bin/cpio
+
do-install:
${MKDIR} ${DOCDIR}
- (cd ${WRKSRC}/docs && tar cf - . | tar --unlink -xpf - -C ${DOCDIR})
+ cd ${WRKSRC}/docs && ${FIND} . \
+ | ${CPIO} -pdmu -R ${DOCOWN}:${DOCGRP} ${DOCDIR}
${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}-${PORTVERSION}.jar \
${PREFIX}/share/java/classes/${PORTNAME}.jar