aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-03-24 18:28:26 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-03-24 18:28:26 +0000
commitd5f131c7fdd331ce16a0aca14a551695f1bd3330 (patch)
treed30d6400cabf585496169de1dd9e5de13968b5ab
parentf8afd36f587ae8bb5be876fe626ff5e90e1a9ab5 (diff)
downloadports-d5f131c7fdd331ce16a0aca14a551695f1bd3330.tar.gz
ports-d5f131c7fdd331ce16a0aca14a551695f1bd3330.zip
Declare CONFLICTS between freedesktop.org X extension/library ports and
XFree86-libraries.
Notes
Notes: svn path=/head/; revision=105135
-rw-r--r--x11-fonts/libXfont/Makefile2
-rw-r--r--x11/XFree86-4-libraries/Makefile5
-rw-r--r--x11/libICE/Makefile2
-rw-r--r--x11/libSM/Makefile2
-rw-r--r--x11/libX11/Makefile2
-rw-r--r--x11/libXau/Makefile2
-rw-r--r--x11/libXcursor/Makefile2
-rw-r--r--x11/libXdmcp/Makefile2
-rw-r--r--x11/libXext/Makefile2
-rw-r--r--x11/libXfont/Makefile2
-rw-r--r--x11/libXi/Makefile2
-rw-r--r--x11/libXpm/Makefile2
-rw-r--r--x11/libXrandr/Makefile2
-rw-r--r--x11/libXrender/Makefile2
-rw-r--r--x11/libXres/Makefile2
-rw-r--r--x11/libXv/Makefile2
-rw-r--r--x11/randrext/Makefile2
-rw-r--r--x11/renderext/Makefile2
-rw-r--r--x11/resourceext/Makefile2
-rw-r--r--x11/xextensions/Makefile2
-rw-r--r--x11/xproto/Makefile2
21 files changed, 45 insertions, 0 deletions
diff --git a/x11-fonts/libXfont/Makefile b/x11-fonts/libXfont/Makefile
index 5627fedfe647..22a11a831138 100644
--- a/x11-fonts/libXfont/Makefile
+++ b/x11-fonts/libXfont/Makefile
@@ -18,6 +18,8 @@ BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/XFree86-4-libraries/Makefile b/x11/XFree86-4-libraries/Makefile
index c160d8298569..784075b1f37e 100644
--- a/x11/XFree86-4-libraries/Makefile
+++ b/x11/XFree86-4-libraries/Makefile
@@ -28,6 +28,11 @@ COMMENT= XFree86-4 libraries and headers
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+CONFLICTS= libICE-* libSM-* libX11-* libXau-* libXcursor-* libXdmcp-* \
+ libXext-* libXfont-* libXi-* libXpm-* libXrandr-* \
+ libXrender-* libXres-* libXv-* randrext-* renderext-* \
+ resourceext-* xextensions-* xproto-*
+
USE_X_PREFIX= no
PREFIX?= ${X11BASE}
MTREE_FILE= /etc/mtree/BSD.x11-4.dist
diff --git a/x11/libICE/Makefile b/x11/libICE/Makefile
index 056ea42083a4..8d676bf4a680 100644
--- a/x11/libICE/Makefile
+++ b/x11/libICE/Makefile
@@ -21,6 +21,8 @@ BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
${LIB_PC_DEPENDS}
RUN_DEPENDS= ${LIB_PC_DEPENDS}
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/libSM/Makefile b/x11/libSM/Makefile
index 3bceeaf46855..80c4913b5123 100644
--- a/x11/libSM/Makefile
+++ b/x11/libSM/Makefile
@@ -21,6 +21,8 @@ BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
${LIB_PC_DEPENDS}
RUN_DEPENDS= ${LIB_PC_DEPENDS}
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/libX11/Makefile b/x11/libX11/Makefile
index 479994daf4ba..aedf40590481 100644
--- a/x11/libX11/Makefile
+++ b/x11/libX11/Makefile
@@ -21,6 +21,8 @@ BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/xextensions.pc:${PORTSDIR}/x11/xexte
${LIB_PC_DEPENDS}
RUN_DEPENDS= ${LIB_PC_DEPENDS}
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/libXau/Makefile b/x11/libXau/Makefile
index 1d093ff76f70..8e6534e5861a 100644
--- a/x11/libXau/Makefile
+++ b/x11/libXau/Makefile
@@ -16,6 +16,8 @@ COMMENT= Authentication Protocol library for X11
BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/libXcursor/Makefile b/x11/libXcursor/Makefile
index c3f7b1783f36..1676944e6423 100644
--- a/x11/libXcursor/Makefile
+++ b/x11/libXcursor/Makefile
@@ -22,6 +22,8 @@ BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto \
${LIB_PC_DEPENDS}
RUN_DEPENDS= ${LIB_PC_DEPENDS}
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/libXdmcp/Makefile b/x11/libXdmcp/Makefile
index 67764020dcf6..5e508b36865c 100644
--- a/x11/libXdmcp/Makefile
+++ b/x11/libXdmcp/Makefile
@@ -20,6 +20,8 @@ COMMENT= X Display Manager Control Protocol library
BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/libXext/Makefile b/x11/libXext/Makefile
index 2fcc2f4cfc2b..06a1f49283b8 100644
--- a/x11/libXext/Makefile
+++ b/x11/libXext/Makefile
@@ -20,6 +20,8 @@ BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto \
${LIB_PC_DEPENDS}
RUN_DEPENDS= ${LIB_PC_DEPENDS}
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/libXfont/Makefile b/x11/libXfont/Makefile
index 5627fedfe647..22a11a831138 100644
--- a/x11/libXfont/Makefile
+++ b/x11/libXfont/Makefile
@@ -18,6 +18,8 @@ BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/libXi/Makefile b/x11/libXi/Makefile
index 328c3bc9ef20..324e802892b0 100644
--- a/x11/libXi/Makefile
+++ b/x11/libXi/Makefile
@@ -20,6 +20,8 @@ BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto \
${LIB_PC_DEPENDS}
RUN_DEPENDS= ${LIB_PC_DEPENDS}
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/libXpm/Makefile b/x11/libXpm/Makefile
index 25a56674f6e3..dddd8ba17deb 100644
--- a/x11/libXpm/Makefile
+++ b/x11/libXpm/Makefile
@@ -19,6 +19,8 @@ BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto \
${LIB_PC_DEPENDS}
RUN_DEPENDS= ${LIB_PC_DEPENDS}
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/libXrandr/Makefile b/x11/libXrandr/Makefile
index 3ad7584cc033..e207fa881749 100644
--- a/x11/libXrandr/Makefile
+++ b/x11/libXrandr/Makefile
@@ -22,6 +22,8 @@ BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/randr.pc:${PORTSDIR}/x11/randrext \
${LIB_PC_DEPENDS}
RUN_DEPENDS= ${LIB_PC_DEPENDS}
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/libXrender/Makefile b/x11/libXrender/Makefile
index 23ede460d3d7..04c86f43a873 100644
--- a/x11/libXrender/Makefile
+++ b/x11/libXrender/Makefile
@@ -21,6 +21,8 @@ BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/render.pc:${PORTSDIR}/x11/renderext
${LIB_PC_DEPENDS}
RUN_DEPENDS= ${LIB_PC_DEPENDS}
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/libXres/Makefile b/x11/libXres/Makefile
index d1de784a1db1..1ee80faf1680 100644
--- a/x11/libXres/Makefile
+++ b/x11/libXres/Makefile
@@ -22,6 +22,8 @@ BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/resourceext.pc:${PORTSDIR}/x11/resou
${LIB_PC_DEPENDS}
RUN_DEPENDS= ${LIB_PC_DEPENDS}
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/libXv/Makefile b/x11/libXv/Makefile
index d37ea37ed771..ca52f618bb17 100644
--- a/x11/libXv/Makefile
+++ b/x11/libXv/Makefile
@@ -20,6 +20,8 @@ BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/xextensions.pc:${PORTSDIR}/x11/xexte
${LIB_PC_DEPENDS}
RUN_DEPENDS= ${LIB_PC_DEPENDS}
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/randrext/Makefile b/x11/randrext/Makefile
index 4f8ee4d50589..c27400b05858 100644
--- a/x11/randrext/Makefile
+++ b/x11/randrext/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
MAINTAINER= x11@FreeBSD.org
COMMENT= Header files and documentation for the X Resize and Rotate extension
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/renderext/Makefile b/x11/renderext/Makefile
index 4b03fd4c57a2..9bfa0a2e4297 100644
--- a/x11/renderext/Makefile
+++ b/x11/renderext/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= http://pdx.freedesktop.org/~xlibs/release/
MAINTAINER= x11@FreeBSD.org
COMMENT= Header files and documentation for the X render extension
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/resourceext/Makefile b/x11/resourceext/Makefile
index 190b71b81719..1681ecee2412 100644
--- a/x11/resourceext/Makefile
+++ b/x11/resourceext/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= http://pdx.freedesktop.org/~xlibs/release/
MAINTAINER= x11@FreeBSD.org
COMMENT= X Resource usage extension headers
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/xextensions/Makefile b/x11/xextensions/Makefile
index 6ea745debefc..62d3da418018 100644
--- a/x11/xextensions/Makefile
+++ b/x11/xextensions/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= http://pdx.freedesktop.org/~xlibs/release/
MAINTAINER= x11@FreeBSD.org
COMMENT= X11 extension headers
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
diff --git a/x11/xproto/Makefile b/x11/xproto/Makefile
index 7c89ffad147b..5f51c3b13cac 100644
--- a/x11/xproto/Makefile
+++ b/x11/xproto/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= http://pdx.freedesktop.org/~xlibs/release/
MAINTAINER= x11@FreeBSD.org
COMMENT= X11 protocol headers
+CONFLICTS= XFree86-libraries-*
+
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes