aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2023-07-31 12:13:22 +0000
committerFelix Palmen <zirias@FreeBSD.org>2023-07-31 16:37:21 +0000
commitd5f33570094ca4777eb4a906214f2465961a712b (patch)
tree475e9c8909d6aa9ce435a3ff1b3239894ac8e6e2
parentce15103bd7cc3e3f437d5164523f6977b88c4ad7 (diff)
downloadports-d5f33570094ca4777eb4a906214f2465961a712b.tar.gz
ports-d5f33570094ca4777eb4a906214f2465961a712b.zip
x11-wm/fvwm3: Add .desktop entry for XSession
Add a .desktop file of type XSession, so fvwm3 is discoverable for display managers following freedesktop.org standards. PR: 272836 Co-authored-by: Bartek Jasicki <thindil@laeran.pl.eu.org>
-rw-r--r--x11-wm/fvwm3/Makefile8
-rw-r--r--x11-wm/fvwm3/files/fvwm3.desktop.in6
-rw-r--r--x11-wm/fvwm3/pkg-plist1
3 files changed, 14 insertions, 1 deletions
diff --git a/x11-wm/fvwm3/Makefile b/x11-wm/fvwm3/Makefile
index accd089a2535..77f8ed3a7142 100644
--- a/x11-wm/fvwm3/Makefile
+++ b/x11-wm/fvwm3/Makefile
@@ -1,6 +1,6 @@
PORTNAME= fvwm3
DISTVERSION= 1.0.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm
MASTER_SITES= https://github.com/fvwmorg/fvwm3/releases/download/${DISTVERSION}/ \
http://fvwm.sourceforge.net/generated/icon_download/:icons
@@ -25,6 +25,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= ac_cv_path_PYTHON=${PYTHON_CMD}
CONFLICTS_INSTALL= fvwm
+SUB_FILES= fvwm3.desktop
PLIST_SUB= DISTVERSION=${DISTVERSION}
OPTIONS_DEFINE= FRIBIDI GO ICONS ICONV MANPAGES NLS PERL PNG SVG \
@@ -74,6 +75,11 @@ post-patch:
@${REINPLACE_CMD} -e 's,/etc/,${LOCALBASE}/etc/,g' \
${WRKSRC}/bin/fvwm-menu-desktop.in
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/xsessions
+ ${INSTALL_DATA} ${WRKDIR}/fvwm3.desktop \
+ ${STAGEDIR}${PREFIX}/share/xsessions
+
post-install-ICONS-on:
${MKDIR} ${STAGEDIR}${PREFIX}/share/fvwm3/pixmaps
${INSTALL_DATA} ${WRKDIR}/${FVWM_ICONS}/*.xpm \
diff --git a/x11-wm/fvwm3/files/fvwm3.desktop.in b/x11-wm/fvwm3/files/fvwm3.desktop.in
new file mode 100644
index 000000000000..11d64c92ede2
--- /dev/null
+++ b/x11-wm/fvwm3/files/fvwm3.desktop.in
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Name=FVWM3
+Comment=The fvwm3 window manager
+Type=XSession
+Exec=%%PREFIX%%/bin/fvwm3
+TryExec=%%PREFIX%%/bin/fvwm3
diff --git a/x11-wm/fvwm3/pkg-plist b/x11-wm/fvwm3/pkg-plist
index 83fe6fb2310d..3dfb7615b278 100644
--- a/x11-wm/fvwm3/pkg-plist
+++ b/x11-wm/fvwm3/pkg-plist
@@ -125,6 +125,7 @@ libexec/fvwm3/%%DISTVERSION%%/FvwmTalk
%%DATADIR%%/default-config/stalonetrayrc
%%DATADIR%%/fvwm-menu-desktop-config.fpl
%%DATADIR%%/fvwm-script-ComExample.pl
+share/xsessions/fvwm3.desktop
%%PERL%%%%DATADIR%%/perllib/FVWM/Commands.pm
%%PERL%%%%DATADIR%%/perllib/FVWM/Constants.pm
%%PERL%%%%DATADIR%%/perllib/FVWM/Event.pm