aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>2004-07-27 05:35:57 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>2004-07-27 05:35:57 +0000
commitd6057a7a29513b685fc8c56dfc42550372e300c1 (patch)
tree97f6a41761ea36712939e176e70169c83f6ac5a8
parentf276a222e88e630ca22a46b52b3d80b35bc78bbd (diff)
downloadports-d6057a7a29513b685fc8c56dfc42550372e300c1.tar.gz
ports-d6057a7a29513b685fc8c56dfc42550372e300c1.zip
Upgrade, and use mimekit included in the delegate8.9.6-pre11 distribution.
This source contains the patch submitted in PR/28995. PR: 28995 Submitted by: amagai@nue.org While I'm at this: * Better handling for portdocs. * Define do-install: instead of patching the distributed Makefile. * Bump the version to 1.9, since I found that version in the mimekit/Makefile. Don't know since when this was version 1.9. * Update the master site.
Notes
Notes: svn path=/head/; revision=114842
-rw-r--r--japanese/mimekit/Makefile22
-rw-r--r--japanese/mimekit/distinfo4
-rw-r--r--japanese/mimekit/files/patch-aa25
-rw-r--r--japanese/mimekit/files/patch-ab10
-rw-r--r--japanese/mimekit/files/patch-ac25
-rw-r--r--japanese/mimekit/pkg-plist3
6 files changed, 18 insertions, 71 deletions
diff --git a/japanese/mimekit/Makefile b/japanese/mimekit/Makefile
index 1271847e5c60..351d41ce72a5 100644
--- a/japanese/mimekit/Makefile
+++ b/japanese/mimekit/Makefile
@@ -6,21 +6,31 @@
#
PORTNAME= mimekit
-PORTVERSION= 1.8
+PORTVERSION= 1.9
CATEGORIES= japanese devel mail
-MASTER_SITES= ftp://ftp.etl.go.jp/pub/DeleGate/
-DISTNAME= delegate6.1.19
+MASTER_SITES= ftp://ftp.delegate.org/pub/DeleGate/
+DISTNAME= delegate8.9.6-pre11
MAINTAINER= max@FreeBSD.org
COMMENT= Library to handle messages with MIME-encoded headers
WRKSRC= ${WRKDIR}/${DISTNAME}/mimekit
+.if !defined(NOPORTDOCS)
+PORTDOCS= README README-LIB README-PGP
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/deMime ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/enMime ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libmimekit.a ${PREFIX}/lib
+ ${RANLIB} ${PREFIX}/lib/libmimekit.a
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/mimekit
- ${INSTALL_DATA} ${WRKSRC}/README.LIB ${PREFIX}/share/doc/mimekit
- ${INSTALL_DATA} ${WRKSRC}/README.PGP ${PREFIX}/share/doc/mimekit
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/japanese/mimekit/distinfo b/japanese/mimekit/distinfo
index d01ed787d260..6b48a4ed4182 100644
--- a/japanese/mimekit/distinfo
+++ b/japanese/mimekit/distinfo
@@ -1,2 +1,2 @@
-MD5 (delegate6.1.19.tar.gz) = 3cfa4f8b801a669bb4d1588e9afd62a8
-SIZE (delegate6.1.19.tar.gz) = 934013
+MD5 (delegate8.9.6-pre11.tar.gz) = 719647731023005a675a12580a502cd8
+SIZE (delegate8.9.6-pre11.tar.gz) = 1191869
diff --git a/japanese/mimekit/files/patch-aa b/japanese/mimekit/files/patch-aa
index a6e2e8fdcd28..3d34c7b17a50 100644
--- a/japanese/mimekit/files/patch-aa
+++ b/japanese/mimekit/files/patch-aa
@@ -9,28 +9,3 @@
TARGET = all
target: $(TARGET)
libx: Makefile.go
-@@ -60,7 +60,7 @@
- DGDIR = ../src/
- #endif #############
-
--INSTDIR = /usr/local
-+INSTDIR = ${PREFIX}
-
- LOCALFILES = README \
- README.LIB \
-@@ -163,11 +163,11 @@
- enMime deMime bench.o test.out sample.out
-
- install: deMime enMime $(LIBFILE)
-- install -o bin -g bin -m 755 deMime $(INSTDIR)/bin
-- install -o bin -g bin -m 755 enMime $(INSTDIR)/bin
-+ ${BSD_INSTALL_PROGRAM} deMime $(INSTDIR)/bin
-+ ${BSD_INSTALL_PROGRAM} enMime $(INSTDIR)/bin
-
--# install -o root -g staff -m 644 $(LIBFILE) $(INSTDIR)/lib
--# -$(RANLIB) $(INSTDIR)/lib/$(LIBFILE)
-+ ${BSD_INSTALL_DATA} $(LIBFILE) $(INSTDIR)/lib
-+ -$(RANLIB) $(INSTDIR)/lib/$(LIBFILE)
-
- ystring.h:; $(LKFILE) ../include/ystring.h
- html.c:; $(LKFILE) ../rary/html.c .
diff --git a/japanese/mimekit/files/patch-ab b/japanese/mimekit/files/patch-ab
deleted file mode 100644
index 08f44682f562..000000000000
--- a/japanese/mimekit/files/patch-ab
+++ /dev/null
@@ -1,10 +0,0 @@
---- ../include/ystring.h.orig Sun Mar 31 19:40:13 2002
-+++ ../include/ystring.h Sun Mar 31 19:40:18 2002
-@@ -18,7 +18,6 @@
- /*
- * non-standard
- */
--extern char *strcasestr();
- extern char *strrpbrk();
- extern char *stralloc();
- extern char *strtail();
diff --git a/japanese/mimekit/files/patch-ac b/japanese/mimekit/files/patch-ac
deleted file mode 100644
index 995fbd298c0d..000000000000
--- a/japanese/mimekit/files/patch-ac
+++ /dev/null
@@ -1,25 +0,0 @@
---- ../rary/String.c.orig Sun Mar 31 19:39:46 2002
-+++ ../rary/String.c Sun Mar 31 19:40:03 2002
-@@ -72,22 +72,6 @@
- return strncasecmp(a,b,n) == 0;
- }
-
--char *
--strcasestr(s1,s2)
-- char *s1,*s2;
--{ char *p1;
-- int len;
--
-- if( *s2 == 0 )
-- return s1;
--
-- len = strlen(s2);
-- for( p1 = s1; *p1; p1 ++ )
-- if( toupper(*p1) == toupper(*s2) )
-- if( strncasecmp(p1,s2,len)==0 )
-- return p1;
-- return 0;
--}
- char *strtoupper(s1,s2)
- char *s1,*s2;
- {
diff --git a/japanese/mimekit/pkg-plist b/japanese/mimekit/pkg-plist
index 0cb9a11239e3..6f6a1bee2258 100644
--- a/japanese/mimekit/pkg-plist
+++ b/japanese/mimekit/pkg-plist
@@ -1,6 +1,3 @@
bin/deMime
bin/enMime
lib/libmimekit.a
-share/doc/mimekit/README.LIB
-share/doc/mimekit/README.PGP
-@dirrm share/doc/mimekit