aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoryjqg6666 <jinking.this@gmail.com>2023-09-26 08:00:21 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-09-26 11:47:54 +0000
commitd62fb97c7780c729b2b39d1174646ef52ec584d5 (patch)
tree8506a77694c0718321ecb2c55e05c31ab3f7ae64
parent47cd18916ef6aff28c96f076f52184c4814edf98 (diff)
downloadports-d62fb97c7780c729b2b39d1174646ef52ec584d5.tar.gz
ports-d62fb97c7780c729b2b39d1174646ef52ec584d5.zip
java/intellij-ultimate: fix fsnotifier path
PR: 274097 Reported by: jinking.this@gmail.com
-rw-r--r--java/intellij-ultimate/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/java/intellij-ultimate/Makefile b/java/intellij-ultimate/Makefile
index a050857590e5..a2fca6eb8639 100644
--- a/java/intellij-ultimate/Makefile
+++ b/java/intellij-ultimate/Makefile
@@ -1,5 +1,6 @@
PORTNAME= intellij-ultimate
DISTVERSION= 2022.2.5
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= https://download-cdn.jetbrains.com/idea/
DISTNAME= ideaIU-${DISTVERSION}-no-jbr
@@ -69,7 +70,7 @@ do-install:
${INSTALL_MAN} ${FILESDIR}/idea.1 ${STAGEDIR}${PREFIX}/man/man1
${INSTALL_DATA} ${WRKDIR}/idea.desktop ${STAGEDIR}${PREFIX}/share/applications/
# Use fsnotifier replacement provided by java/intellij-fsnotifier
- ${ECHO} "idea.filewatcher.executable.path=${PREFIX}/bin/fsnotifier" >> ${STAGEDIR}${DATADIR}/bin/idea.properties
+ ${ECHO} "idea.filewatcher.executable.path=${PREFIX}/intellij/bin/fsnotifier" >> ${STAGEDIR}${DATADIR}/bin/idea.properties
# Use pty4j replacement provided by java/intellij-pty4j
${LN} -sf ../../../intellij/lib/libpty ${STAGEDIR}${DATADIR}/lib/pty4j-native
# Fix "Typeahead timeout is exceeded" error