aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 19:58:04 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 19:58:04 +0000
commitd691c243fbfecc1e1341c5e50d1dedf9c0139a7a (patch)
tree2d0c5dc97b23e08df3324fddac13d261c9345572
parent098922819481e65166a763066f2997d632ab3c70 (diff)
downloadports-d691c243fbfecc1e1341c5e50d1dedf9c0139a7a.tar.gz
ports-d691c243fbfecc1e1341c5e50d1dedf9c0139a7a.zip
Add py-inequality 1.0.0
inequality implements measures for the analysis of inequality over space and time and is part of the PySAL family. WWW: https://inequality.readthedocs.io/en/latest/ WWW: https://github.com/pysal/inequality
Notes
Notes: svn path=/head/; revision=560052
-rw-r--r--science/Makefile1
-rw-r--r--science/py-inequality/Makefile23
-rw-r--r--science/py-inequality/distinfo3
-rw-r--r--science/py-inequality/pkg-descr5
4 files changed, 32 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 343e54f60a11..7ea569db6285 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -242,6 +242,7 @@
SUBDIR += py-gsd
SUBDIR += py-h5json
SUBDIR += py-h5py
+ SUBDIR += py-inequality
SUBDIR += py-jupyter_jsmol
SUBDIR += py-kim-query
SUBDIR += py-kinematics
diff --git a/science/py-inequality/Makefile b/science/py-inequality/Makefile
new file mode 100644
index 000000000000..0216dbf0db9d
--- /dev/null
+++ b/science/py-inequality/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= inequality
+PORTVERSION= 1.0.0
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Spatial inequality analysis for PySAL
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.3,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.11:science/py-scipy@${PY_FLAVOR}
+
+USES= python:3.5+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-inequality/distinfo b/science/py-inequality/distinfo
new file mode 100644
index 000000000000..73432ab71c64
--- /dev/null
+++ b/science/py-inequality/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609598759
+SHA256 (inequality-1.0.0.tar.gz) = e3ad59ece8d25ecfc7c7e94efe59ead0e4ffb76ff72befd18a60e10caba6fd54
+SIZE (inequality-1.0.0.tar.gz) = 11421
diff --git a/science/py-inequality/pkg-descr b/science/py-inequality/pkg-descr
new file mode 100644
index 000000000000..a28caaf26d5b
--- /dev/null
+++ b/science/py-inequality/pkg-descr
@@ -0,0 +1,5 @@
+inequality implements measures for the analysis of inequality over space and
+time and is part of the PySAL family.
+
+WWW: https://inequality.readthedocs.io/en/latest/
+WWW: https://github.com/pysal/inequality