aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-21 15:57:04 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-21 15:57:04 +0000
commitd6e92414b1bae9ff995689245e98281fc2f3d7bb (patch)
tree75c3390a6473a4d78432a8544cf901c300e94bfa
parenteb463bb4855eef87855f5ed078f3e99da46ec795 (diff)
downloadports-d6e92414b1bae9ff995689245e98281fc2f3d7bb.tar.gz
ports-d6e92414b1bae9ff995689245e98281fc2f3d7bb.zip
- Convert to USES=gmake tcl
- STAGE-clean
Notes
Notes: svn path=/head/; revision=345509
-rw-r--r--www/websh/Makefile32
-rw-r--r--www/websh/pkg-plist19
2 files changed, 16 insertions, 35 deletions
diff --git a/www/websh/Makefile b/www/websh/Makefile
index 97670590bcb8..32d863159c14 100644
--- a/www/websh/Makefile
+++ b/www/websh/Makefile
@@ -16,18 +16,20 @@ MAKE_JOBS_UNSAFE= yes
TCL_DVER= ${TCL_VER:S/.//}
-USE_TCL= 84+
+USES= gmake tcl:84,85
USE_AUTOTOOLS= autoconf
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src/unix
CONFIGURE_ARGS+=--with-tclinclude=${TCL_INCLUDEDIR} \
--with-tcl=${TCL_LIBDIR}
-USE_GMAKE= yes
USE_LDCONFIG= yes
SUB_FILES= httpd.conf pkgIndex.tcl pkg-message
SUB_LIST+= TCL_DVER=${TCL_DVER} WS_VER=${PORTVERSION}
SUB_LIST+= APACHEETCDIR=${APACHEETCDIR} APACHEMODDIR=${APACHEMODDIR}
PLIST_SUB+= TCL_DVER=${TCL_DVER}
+PORTDOCS= *
+PORTEXAMPLES= *
+
USE_APACHE= 22+
CONFIGURE_ARGS+=--with-httpdinclude=`apxs -q includedir`
@@ -36,7 +38,6 @@ CPPFLAGS+= -I ${LOCALBASE}/include/apr-1
CPPFLAGS+= -Wall -Werror
.endif
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's,/usr/local/websh,${PREFIX},' \
${WRKSRC:H:H}/doc/mod_websh/conf/websh.conf
@@ -61,27 +62,26 @@ post-build test:
{print}'
do-install:
- ${MKDIR} ${PREFIX}/lib/${PORTNAME}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}
${INSTALL_DATA} ${WRKSRC:H:H}/doc/mod_websh/conf/*.ws3 \
- ${WRKDIR}/pkgIndex.tcl ${PREFIX}/lib/${PORTNAME}/
+ ${WRKDIR}/pkgIndex.tcl ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/
${INSTALL_DATA} ${WRKSRC:H:H}/doc/mod_websh/conf/websh.conf \
- ${PREFIX}/etc/websh.conf.dist
+ ${STAGEDIR}${PREFIX}/etc/websh.conf.dist
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
${INSTALL_DATA} ${WRKSRC}/mod_websh${PORTVERSION}.so \
- ${PREFIX}/${APACHEMODDIR}/mod_websh.so
- ${INSTALL_DATA} ${WRKSRC}/libwebsh${TCL_DVER}.so.1 ${PREFIX}/lib
+ ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/mod_websh.so
+ ${INSTALL_DATA} ${WRKSRC}/libwebsh${TCL_DVER}.so.1 \
+ ${STAGEDIR}${PREFIX}/lib
${LN} -sf ${PREFIX}/lib/libwebsh${TCL_DVER}.so.1 \
- ${PREFIX}/lib/libwebsh${TCL_DVER}.so
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR}
+ ${STAGEDIR}${PREFIX}/lib/libwebsh${TCL_DVER}.so
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC:H:H}/doc/mod_websh/htdocs/*.ws3 \
${WRKSRC:H:H}/doc/mod_websh/htdocs/*.whtml \
- ${WRKDIR}/httpd.conf ${EXAMPLESDIR}/
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC:H:H}/doc/html/* ${DOCSDIR}
-.endif
+ ${WRKDIR}/httpd.conf ${STAGEDIR}${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC:H:H}/doc/html/* ${STAGEDIR}${DOCSDIR}
post-install:
@${APXS} -e -a -n "${SHORTMODNAME}" "${APACHEMODDIR}/mod_${MODULENAME}.so"
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/www/websh/pkg-plist b/www/websh/pkg-plist
index d89ed3ab3405..4ca0f66b2944 100644
--- a/www/websh/pkg-plist
+++ b/www/websh/pkg-plist
@@ -5,25 +5,6 @@ lib/websh/htmlhandler.ws3
lib/websh/otherhandler.ws3
@dirrm lib/websh/
etc/websh.conf.dist
-%%PORTDOCS%%%%EXAMPLESDIR%%/index.whtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/myApp.ws3
-%%PORTDOCS%%%%EXAMPLESDIR%%/other.whtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/httpd.conf
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%%%DOCSDIR%%/Apache_module_specific_commands.html
-%%PORTDOCS%%%%DOCSDIR%%/command_dispatching_and_session_management.html
-%%PORTDOCS%%%%DOCSDIR%%/configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/context_handling.html
-%%PORTDOCS%%%%DOCSDIR%%/data_encryption.html
-%%PORTDOCS%%%%DOCSDIR%%/file_handling_and_file_IO.html
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/inter-process_and_-system_communication.html
-%%PORTDOCS%%%%DOCSDIR%%/logging.html
-%%PORTDOCS%%%%DOCSDIR%%/misc_commands.html
-%%PORTDOCS%%%%DOCSDIR%%/request_data_handling.html
-%%PORTDOCS%%%%DOCSDIR%%/response_data_handling.html
-%%PORTDOCS%%%%DOCSDIR%%/uri-html-_en-decoding.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%APACHEMODDIR%%/mod_websh.so
@exec %D/sbin/apxs -e -A -n websh %D/%F
@unexec %D/sbin/apxs -e -A -n websh %D/%F