aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-21 17:04:00 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-21 17:04:00 +0000
commitd71c9ebde2b6e326215c5802a79fc62f019e7ffc (patch)
tree4a653054c7c650400f63bdaefa6a7b47e4741b73
parent6187ff7ef34c420dd63f34e44f2630f221536eb4 (diff)
downloadports-d71c9ebde2b6e326215c5802a79fc62f019e7ffc.tar.gz
ports-d71c9ebde2b6e326215c5802a79fc62f019e7ffc.zip
devel/py-jaraco.util: Remove py-jaraco from RUN_DEPENDS
- Bump PORTREVISION for dependency change
-rw-r--r--devel/py-jaraco.util/Makefile17
1 files changed, 3 insertions, 14 deletions
diff --git a/devel/py-jaraco.util/Makefile b/devel/py-jaraco.util/Makefile
index 86bd27c3048b..39c21e44de4b 100644
--- a/devel/py-jaraco.util/Makefile
+++ b/devel/py-jaraco.util/Makefile
@@ -1,6 +1,6 @@
PORTNAME= jaraco.util
PORTVERSION= 15.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,11 +11,10 @@ WWW= https://github.com/jaraco/jaraco.util
LICENSE= MIT
-BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=56:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.1:devel/py-setuptools_scm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jaraco>=0:devel/py-jaraco@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}jaraco.context>=0:devel/py-jaraco.context@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jaraco.context>=0:devel/py-jaraco.context@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-black>=0.3.7:devel/py-pytest-black@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-checkdocs>=2.4:devel/py-pytest-checkdocs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
@@ -28,14 +27,4 @@ USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
-POST_PLIST= trim-jaraco-namespace
-
-post-install:
- @${RM} ${STAGEDIR}${PYTHON_SITELIBDIR}/jaraco/__init__.py*
- -@${RM} ${STAGEDIR}${PYTHON_SITELIBDIR}/jaraco/__pycache__/__init__.*
- -@${RMDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}/jaraco/__pycache__
-
-trim-jaraco-namespace:
- @${REINPLACE_CMD} '/jaraco\/__init__\./d; /jaraco\/__pycache__\/__init__\./d' ${TMPPLIST}
-
.include <bsd.port.mk>