aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2018-10-23 12:32:59 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2018-10-23 12:32:59 +0000
commitd73ac6dfb6c97152ea50872a58226298cd66999d (patch)
treeeee144f5c27a47871fd589122ff7ebf8f3e6a998
parentb590da43ed8fb4da2581dd0ff9afc84718b5bd4b (diff)
downloadports-d73ac6dfb6c97152ea50872a58226298cd66999d.tar.gz
ports-d73ac6dfb6c97152ea50872a58226298cd66999d.zip
fix build with GCC-based architectures.
prior to this patch, some archs still using GCC could not compile the port; tested on powerpc64 (sponsored hardware); also tested on other archs to check if nothing broke. * original patch modified just to bump PORTREVISION, and use PORTSDIR root. PR: 232276 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> Approved by: rene (mentor) Sponsored by: IntegriCloud
Notes
Notes: svn path=/head/; revision=482835
-rw-r--r--textproc/regex2dfa/Makefile2
-rw-r--r--textproc/regex2dfa/files/patch-third__party_openfst_src_include_fst_replace.h11
2 files changed, 13 insertions, 0 deletions
diff --git a/textproc/regex2dfa/Makefile b/textproc/regex2dfa/Makefile
index b9d823a24603..b7d4e19079eb 100644
--- a/textproc/regex2dfa/Makefile
+++ b/textproc/regex2dfa/Makefile
@@ -2,6 +2,7 @@
PORTNAME= regex2dfa
DISTVERSION= 0.1.6
+PORTREVISION= 1
CATEGORIES= textproc
MAINTAINER= egypcio@googlemail.com
@@ -12,6 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= compiler:c++11-lang gmake libtool
USE_GITHUB= yes
+
GH_ACCOUNT= kpdyer
GNU_CONFIGURE= yes
diff --git a/textproc/regex2dfa/files/patch-third__party_openfst_src_include_fst_replace.h b/textproc/regex2dfa/files/patch-third__party_openfst_src_include_fst_replace.h
new file mode 100644
index 000000000000..1cb52acd9062
--- /dev/null
+++ b/textproc/regex2dfa/files/patch-third__party_openfst_src_include_fst_replace.h
@@ -0,0 +1,11 @@
+--- third_party/openfst/src/include/fst/replace.h.orig 2018-10-14 23:15:07 UTC
++++ third_party/openfst/src/include/fst/replace.h
+@@ -1250,7 +1250,7 @@ class ArcIterator< ReplaceFst<A, T, C> > {
+ // If state is already cached, use cached arcs array.
+ if (fst_.GetImpl()->HasArcs(state_)) {
+ (fst_.GetImpl())
+- ->template CacheBaseImpl<typename C::State, C>::InitArcIterator(
++ ->CacheBaseImpl<typename C::State, C>::InitArcIterator(
+ state_, &cache_data_);
+ num_arcs_ = cache_data_.narcs;
+ arcs_ = cache_data_.arcs; // 'arcs_' is a ptr to the cached arcs.