aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2022-08-30 15:06:33 +0000
committerFelix Palmen <zirias@FreeBSD.org>2022-09-06 16:42:12 +0000
commitd7813e3aeb6da2b982eeab6696b9090632c5e692 (patch)
tree96053d93086e9074ca7a1ff7030e7580fd06af98
parent6805cb43f56cee8fd8b3d853805c66ce27e53785 (diff)
downloadports-d7813e3aeb6da2b982eeab6696b9090632c5e692.tar.gz
ports-d7813e3aeb6da2b982eeab6696b9090632c5e692.zip
security/axc: Add new port
Client lib providing crypto interfaces for libsignal-protocol-c. PR: 266104 Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D36468
-rw-r--r--security/Makefile1
-rw-r--r--security/axc/Makefile32
-rw-r--r--security/axc/distinfo7
-rw-r--r--security/axc/pkg-descr8
-rw-r--r--security/axc/pkg-plist7
5 files changed, 55 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index e536f5926a1b..b5b93b5e6c7c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -39,6 +39,7 @@
SUBDIR += aws-c-cal
SUBDIR += aws-iam-authenticator
SUBDIR += aws-vault
+ SUBDIR += axc
SUBDIR += barnyard2
SUBDIR += barnyard2-sguil
SUBDIR += bastillion
diff --git a/security/axc/Makefile b/security/axc/Makefile
new file mode 100644
index 000000000000..e92c3884df5f
--- /dev/null
+++ b/security/axc/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= axc
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.7
+CATEGORIES= security net
+
+PATCH_SITES= https://github.com/gkdr/axc/commit/
+PATCHFILES= c287e25143fc54486c8a8a86f9abb64ce1753372.patch:-p1 \
+ ba53eb408f793652495d7d73775c33487e6cc8d0.patch:-p1
+
+MAINTAINER= micadeyeye@gmail.com
+COMMENT= Crypto interfaces for libsignal-protocol-c
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
+ libgpg-error.so:security/libgpg-error \
+ libsignal-protocol-c.so:net/libsignal-protocol-c
+
+USES= cmake gnome localbase:ldflags pathfix pkgconfig sqlite
+USE_GITHUB= yes
+GH_ACCOUNT= gkdr
+USE_GNOME= glib20
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= TEST
+
+TEST_BUILD_DEPENDS= cmocka>=1.1.5:sysutils/cmocka
+TEST_CMAKE_BOOL= AXC_WITH_TESTS
+TEST_TEST_TARGET= test
+
+.include <bsd.port.mk>
diff --git a/security/axc/distinfo b/security/axc/distinfo
new file mode 100644
index 000000000000..7520b6f0e11f
--- /dev/null
+++ b/security/axc/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1661868709
+SHA256 (gkdr-axc-v0.3.7_GH0.tar.gz) = eb1fb85c29dd1f9edc2ac23d6c29220345d7679720ff3d6fb90b328898806fb8
+SIZE (gkdr-axc-v0.3.7_GH0.tar.gz) = 41742
+SHA256 (c287e25143fc54486c8a8a86f9abb64ce1753372.patch) = b4d12a0528524b42436776525d598f17a47d878cc74aa8e3b85444e0cbf9498b
+SIZE (c287e25143fc54486c8a8a86f9abb64ce1753372.patch) = 1767
+SHA256 (ba53eb408f793652495d7d73775c33487e6cc8d0.patch) = a0de2c82a67768684bfcf27414e4612e374c0776565ded7efcb5062b73702256
+SIZE (ba53eb408f793652495d7d73775c33487e6cc8d0.patch) = 9545
diff --git a/security/axc/pkg-descr b/security/axc/pkg-descr
new file mode 100644
index 000000000000..8cbb9d883250
--- /dev/null
+++ b/security/axc/pkg-descr
@@ -0,0 +1,8 @@
+Client lib for libsignal-c, implementing the needed database and crypto
+interfaces using SQLite and gcrypt.
+
+Additionally it provides utility functions for common use cases like
+encrypting and decrypting, ultimately making direct use of libsignal
+unnecessary.
+
+WWW: https://github.com/gkdr/axc
diff --git a/security/axc/pkg-plist b/security/axc/pkg-plist
new file mode 100644
index 000000000000..26cc0016e94b
--- /dev/null
+++ b/security/axc/pkg-plist
@@ -0,0 +1,7 @@
+include/axc/axc.h
+include/axc/axc_crypto.h
+include/axc/axc_store.h
+lib/libaxc.so
+lib/libaxc.so.0
+lib/libaxc.so.0.3.7
+libdata/pkgconfig/libaxc.pc