aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Timofeev <timp87@gmail.com>2022-01-19 10:11:37 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2022-01-19 10:11:41 +0000
commitd792ff1863af044ec543b679d5b0ed0e88614e51 (patch)
tree2115e8eda6e2398e2c159d3dd4c50b49f9827970
parent342870f57f5e0bed450bee3771b93c703716b734 (diff)
downloadports-d792ff1863af044ec543b679d5b0ed0e88614e51.tar.gz
ports-d792ff1863af044ec543b679d5b0ed0e88614e51.zip
www/squid: update to 5.3: New port: Google Chat plugin for libpurple
-rw-r--r--www/squid/Makefile51
-rw-r--r--www/squid/distinfo6
-rw-r--r--www/squid/files/patch-compat_cpu.h4
-rw-r--r--www/squid/files/patch-configure75
-rw-r--r--www/squid/files/patch-include_squid.h4
-rw-r--r--www/squid/files/patch-src-cf.data.pre4
-rw-r--r--www/squid/files/patch-src_enums.h2
-rw-r--r--www/squid/files/patch-src_ip_Intercept.cc4
-rw-r--r--www/squid/files/patch-src_tools.cc4
-rw-r--r--www/squid/pkg-plist57
10 files changed, 92 insertions, 119 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 1abeb6a7723c..509bbb417ce5 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -1,22 +1,20 @@
PORTNAME= squid
-DISTVERSION= 4.15
+DISTVERSION= 5.3
CATEGORIES= www
-MASTER_SITES= http://www2.pl.squid-cache.org/Versions/v4/ \
- http://ca.squid-cache.org/Versions/v4/ \
- http://www1.il.squid-cache.org/Versions/v4/ \
- http://www1.jp.squid-cache.org/Versions/v4/ \
- http://www2.gr.squid-cache.org/Versions/v4/ \
- http://ca2.squid-cache.org/Versions/v4/ \
- http://www.squid-cache.org/Versions/v4/
+MASTER_SITES= http://www2.pl.squid-cache.org/Versions/v5/ \
+ http://www1.il.squid-cache.org/Versions/v5/ \
+ http://www1.jp.squid-cache.org/Versions/v5/ \
+ http://www2.gr.squid-cache.org/Versions/v5/ \
+ http://ca2.squid-cache.org/Versions/v5/ \
+ http://www.squid-cache.org/Versions/v5/
PATCH_SITES= http://www2.pl.squid-cache.org/%SUBDIR%/ \
- http://ca.squid-cache.org/%SUBDIR%/ \
http://www1.il.squid-cache.org/%SUBDIR%/ \
http://www1.jp.squid-cache.org/%SUBDIR%/ \
http://www2.gr.squid-cache.org/%SUBDIR%/ \
http://ca2.squid-cache.org/%SUBDIR%/ \
http://www.squid-cache.org/%SUBDIR%/
-PATCH_SITE_SUBDIR= Versions/v4/changesets
+PATCH_SITE_SUBDIR= Versions/v5/changesets
MAINTAINER= timp87@gmail.com
COMMENT= HTTP Caching Proxy
@@ -24,9 +22,9 @@ COMMENT= HTTP Caching Proxy
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++11-lib cpe perl5 shebangfix tar:xz
+USES= compiler:c++11-lib cpe gmake localbase:ldflags perl5 shebangfix tar:xz
-CONFLICTS= squid3 squid-devel
+CONFLICTS= squid-devel
CPE_VENDOR= squid-cache
SHEBANG_FILES= scripts/*.pl contrib/*.pl tools/*.pl
GNU_CONFIGURE= yes
@@ -45,7 +43,7 @@ OPTIONS_GROUP= AUTH
OPTIONS_RADIO= FW
OPTIONS_GROUP_AUTH=AUTH_LDAP AUTH_NIS AUTH_SASL AUTH_SMB AUTH_SQL
OPTIONS_RADIO_FW=TP_IPF TP_IPFW TP_PF
-OPTIONS_DEFINE= ARP_ACL BDB CACHE_DIGESTS DEBUG DELAY_POOLS DOCS ECAP ESI EXAMPLES \
+OPTIONS_DEFINE= ARP_ACL TDB CACHE_DIGESTS DEBUG DELAY_POOLS DOCS ECAP ESI EXAMPLES \
FOLLOW_XFF FS_AUFS FS_DISKD FS_ROCK HTCP ICAP ICMP IDENT IPV6 \
KQUEUE LARGEFILE LAX_HTTP NETTLE SNMP SSL SSL_CRTD \
STACKTRACES VIA_DB WCCP WCCPV2
@@ -59,30 +57,23 @@ OPTIONS_DEFAULT=ARP_ACL AUTH_NIS CACHE_DIGESTS DELAY_POOLS FOLLOW_XFF FS_AUFS \
WCCPV2
ARP_ACL_CONFIGURE_ENABLE= eui
-AUTH_LDAP_CFLAGS= -I${LOCALBASE}/include
-AUTH_LDAP_LDFLAGS= -L${LOCALBASE}/lib
AUTH_LDAP_USE= OPENLDAP=yes
AUTH_LDAP_VARS= BASIC_AUTH+=LDAP DIGEST_AUTH+="eDirectory LDAP" EXTERNAL_ACL+="LDAP_group eDirectory_userip"
-AUTH_SASL_CFLAGS= -I${LOCALBASE}/include
-AUTH_SASL_CPPFLAGS= -I${LOCALBASE}/include
-AUTH_SASL_LDFLAGS= -L${LOCALBASE}/lib
AUTH_SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
AUTH_SASL_VARS= BASIC_AUTH+=SASL
AUTH_SMB_USES= samba:run
AUTH_SMB_VARS= BASIC_AUTH+=SMB EXTERNAL_ACL+=wbinfo_group
AUTH_SQL_RUN_DEPENDS= p5-DBI>=1.08:databases/p5-DBI
AUTH_SQL_VARS= EXTERNAL_ACL+=SQL_session
-BDB_USES= bdb
+TDB_CONFIGURE_ENABLE= tdb
+TDB_LIB_DEPENDS= libtdb.so:databases/tdb
+TDB_VARS= EXTERNAL_ACL+="time_quota session"
CACHE_DIGESTS_CONFIGURE_ENABLE= cache-digests
DELAY_POOLS_CONFIGURE_ENABLE= delay-pools
-ECAP_CFLAGS= -I${LOCALBASE}/include
ECAP_CONFIGURE_ENABLE= ecap
-ECAP_LDFLAGS= -L${LOCALBASE}/lib
ECAP_LIB_DEPENDS= libecap.so:www/libecap
ECAP_USES= pkgconfig:build
-ESI_CFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2
ESI_CONFIGURE_ENABLE= esi
-ESI_LDFLAGS= -L${LOCALBASE}/lib
ESI_LIB_DEPENDS= libexpat.so:textproc/expat2 \
libxml2.so:textproc/libxml2
FOLLOW_XFF_CONFIGURE_ENABLE= follow-x-forwarded-for
@@ -116,7 +107,7 @@ STACKTRACES_CONFIGURE_ENABLE= stacktraces
STACKTRACES_EXTRA_PATCHES= ${FILESDIR}/extra-patch-gen-stacktrace
STACKTRACES_LIB_DEPENDS= libunwind.so:devel/libunwind
STACKTRACES_CFLAGS= -g
-STACKTRACES_LDFLAGS= -lunwind -L${LOCALBASE}/lib
+STACKTRACES_LDFLAGS= -lunwind
STACKTRACES_VARS= STRIP=""
TP_IPFW_CONFIGURE_ENABLE= ipfw-transparent
TP_IPF_CONFIGURE_ENABLE= ipf-transparent
@@ -155,7 +146,7 @@ AUTH_NIS_DESC= Install NIS/YP authentication helpers
AUTH_SASL_DESC= Install SASL authentication helpers
AUTH_SMB_DESC= Install SMB auth. helpers (req. Samba)
AUTH_SQL_DESC= Install SQL based auth
-BDB_DESC= Berkeley DB support required for session and time quota external helpers
+TDB_DESC= TrivialDB support required for session and time quota external helpers
CACHE_DIGESTS_DESC= Use cache digests
DEBUG_DESC= Build with extended debugging support
DELAY_POOLS_DESC= Delay pools (bandwidth limiting)
@@ -248,19 +239,13 @@ NEGOTIATE_AUTH= none
PLIST_SUB+= AUTH_KERB="@comment "
.else
# The kerberos_ldap_group external helper also depends on LDAP and SASL:
+# The kerberos_sid_group external helper depends on kerberos_ldap_group meanwhile
. if ${PORT_OPTIONS:MAUTH_LDAP} && ${PORT_OPTIONS:MAUTH_SASL}
-EXTERNAL_ACL+= kerberos_ldap_group
+EXTERNAL_ACL+= kerberos_ldap_group kerberos_sid_group
. endif
NEGOTIATE_AUTH= kerberos wrapper
.endif
-# The session and time_quota external helpers require Berkeley DB support:
-.if ${PORT_OPTIONS:MBDB}
-CPPFLAGS+= -I${BDB_INCLUDE_DIR}
-LDFLAGS+= -L${BDB_LIB_DIR}
-EXTERNAL_ACL+= time_quota session
-.endif
-
# Storage schemes:
STORAGE_SCHEMES+= ufs
DISKIO_MODULES+= AIO Blocking IpcIo Mmapped
diff --git a/www/squid/distinfo b/www/squid/distinfo
index a2a9493de51e..f9472f6118a9 100644
--- a/www/squid/distinfo
+++ b/www/squid/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1622579975
-SHA256 (squid-4.15.tar.xz) = b693a4e5ab2811a8a854f60de0a62afbbf3a952bb1d047952c9ae01321f84a25
-SIZE (squid-4.15.tar.xz) = 2454176
+TIMESTAMP = 1640710772
+SHA256 (squid-5.3.tar.xz) = 45178588df1311ded41ebadd632840c4d93a8d7f5f60e38e74acf2f1ae2f1715
+SIZE (squid-5.3.tar.xz) = 2553980
diff --git a/www/squid/files/patch-compat_cpu.h b/www/squid/files/patch-compat_cpu.h
index 4df40e6b26b4..60a76e54cfb1 100644
--- a/www/squid/files/patch-compat_cpu.h
+++ b/www/squid/files/patch-compat_cpu.h
@@ -1,5 +1,5 @@
---- compat/cpu.h.orig 2021-05-10 02:02:34.000000000 -0700
-+++ compat/cpu.h 2021-11-29 10:31:25.381434000 -0800
+--- compat/cpu.h.orig 2021-12-07 14:15:52 UTC
++++ compat/cpu.h
@@ -15,6 +15,8 @@
#if HAVE_SCHED_H
#include <sched.h>
diff --git a/www/squid/files/patch-configure b/www/squid/files/patch-configure
index ad7f6f291bc2..6fe4b5b2547c 100644
--- a/www/squid/files/patch-configure
+++ b/www/squid/files/patch-configure
@@ -1,19 +1,10 @@
---- configure.orig 2021-05-10 03:35:34.000000000 -0700
-+++ configure 2021-11-29 12:11:20.139764000 -0800
-@@ -35087,7 +35087,7 @@
- ##
-
- BUILD_HELPER="NIS"
--for ac_header in sys/types.h rpc/rpc.h rpcsvc/ypclnt.h rpcsvc/yp_prot.h crypt.h
-+for ac_header in sys/types.h rpc/rpc.h rpcsvc/ypclnt.h rpcsvc/yp_prot.h rpcsvc/crypt.h
- do :
- as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
- ac_fn_cxx_check_header_compile "$LINENO" "$ac_header" "$as_ac_Header" "
-@@ -35102,8 +35102,10 @@
- #define `$as_echo "HAVE_$ac_header" | $as_tr_cpp` 1
+--- configure.orig 2021-12-07 14:11:12 UTC
++++ configure
+@@ -36683,8 +36683,10 @@ then :
+ #define `printf "%s\n" "HAVE_$ac_header" | $as_tr_cpp` 1
_ACEOF
--else
+-else $as_nop
- BUILD_HELPER=""
+# XXX: On FreeBSD we have to do this to make NIS work
+# until https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=188247
@@ -22,33 +13,7 @@
fi
done
-@@ -35576,7 +35578,7 @@
-
- # unconditionally requires crypt(3), for now
- if test "x$ac_cv_func_crypt" != "x"; then
-- for ac_header in unistd.h crypt.h shadow.h
-+ for ac_header in unistd.h rpcsvc/crypt.h shadow.h
- do :
- as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
- ac_fn_cxx_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
-@@ -37982,7 +37984,7 @@
- arpa/nameser.h \
- assert.h \
- bstring.h \
-- crypt.h \
-+ rpcsvc/crypt.h \
- ctype.h \
- direct.h \
- errno.h \
-@@ -38190,6 +38192,7 @@
- #include <netinet/ip.h>
- #endif
- #if HAVE_NETINET_IP_COMPAT_H
-+#include <net/if.h> /* IFNAMSIZ */
- #include <netinet/ip_compat.h>
- #endif
- #if HAVE_NETINET_IP_FIL_H
-@@ -39490,6 +39493,7 @@
+@@ -42604,6 +42606,7 @@ fi
ac_fn_cxx_check_type "$LINENO" "cpu_set_t" "ac_cv_type_cpu_set_t" "
#if HAVE_SCHED_H
@@ -56,35 +21,11 @@
#include <sched.h>
#endif
-@@ -42237,6 +42241,7 @@
- # include <sys/ioccom.h>
- # include <netinet/in.h>
-
-+# include <net/if.h> /* IFNAMSIZ */
- # include <netinet/ip_compat.h>
- # include <netinet/ip_fil.h>
- # include <netinet/ip_nat.h>
-@@ -42267,6 +42272,7 @@
+@@ -45611,6 +45614,7 @@ else $as_nop
# include <sys/ioccom.h>
# include <netinet/in.h>
#undef minor_t
-+# include <net/if.h> /* IFNAMSIZ */
++# include <net/if.h> /* IFNAMSIZ */
# include <netinet/ip_compat.h>
# include <netinet/ip_fil.h>
# include <netinet/ip_nat.h>
-@@ -42311,6 +42317,7 @@
- ip_fil_compat.h \
- ip_fil.h \
- ip_nat.h \
-+ net/if.h \
- netinet/ip_compat.h \
- netinet/ip_fil_compat.h \
- netinet/ip_fil.h \
-@@ -42340,6 +42347,7 @@
- #if HAVE_IP_COMPAT_H
- #include <ip_compat.h>
- #elif HAVE_NETINET_IP_COMPAT_H
-+#include <net/if.h> /* IFNAMSIZ */
- #include <netinet/ip_compat.h>
- #endif
- #if HAVE_IP_FIL_H
diff --git a/www/squid/files/patch-include_squid.h b/www/squid/files/patch-include_squid.h
index 85951b1b6e02..d08de0ff2998 100644
--- a/www/squid/files/patch-include_squid.h
+++ b/www/squid/files/patch-include_squid.h
@@ -1,5 +1,5 @@
---- include/squid.h.orig 2021-05-10 02:02:34.000000000 -0700
-+++ include/squid.h 2021-11-29 08:48:04.020714000 -0800
+--- include/squid.h.orig 2021-12-07 14:15:52 UTC
++++ include/squid.h
@@ -9,6 +9,7 @@
#ifndef SQUID_CONFIG_H
#define SQUID_CONFIG_H
diff --git a/www/squid/files/patch-src-cf.data.pre b/www/squid/files/patch-src-cf.data.pre
index a9ae9f73a33a..d9f7d1394d23 100644
--- a/www/squid/files/patch-src-cf.data.pre
+++ b/www/squid/files/patch-src-cf.data.pre
@@ -1,6 +1,6 @@
---- src/cf.data.pre.orig 2020-04-19 12:38:51 UTC
+--- src/cf.data.pre.orig 2021-12-07 14:15:52 UTC
+++ src/cf.data.pre
-@@ -5062,6 +5062,10 @@ DEFAULT: @DEFAULT_PID_FILE@
+@@ -5354,6 +5354,10 @@ DEFAULT: @DEFAULT_PID_FILE@
LOC: Config.pidFilename
DOC_START
A filename to write the process-id to. To disable, enter "none".
diff --git a/www/squid/files/patch-src_enums.h b/www/squid/files/patch-src_enums.h
index d9647b14d170..2f26fea7e1be 100644
--- a/www/squid/files/patch-src_enums.h
+++ b/www/squid/files/patch-src_enums.h
@@ -1,4 +1,4 @@
---- src/enums.h.orig 2020-04-19 12:38:51 UTC
+--- src/enums.h.orig 2020-04-19 10:50:48 UTC
+++ src/enums.h
@@ -9,6 +9,9 @@
#ifndef SQUID_ENUMS_H
diff --git a/www/squid/files/patch-src_ip_Intercept.cc b/www/squid/files/patch-src_ip_Intercept.cc
index 7635d3c55834..bf8d9ad50899 100644
--- a/www/squid/files/patch-src_ip_Intercept.cc
+++ b/www/squid/files/patch-src_ip_Intercept.cc
@@ -1,6 +1,6 @@
---- src/ip/Intercept.cc.orig 2018-07-02 03:26:07 UTC
+--- src/ip/Intercept.cc.orig 2021-12-07 14:15:52 UTC
+++ src/ip/Intercept.cc
-@@ -215,10 +215,10 @@ Ip::Intercept::IpfInterception(const Comm::ConnectionP
+@@ -211,10 +211,10 @@ Ip::Intercept::IpfInterception(const Comm::ConnectionP
newConn->remote.getInAddr(natLookup.nl_outipaddr.in4);
}
#else
diff --git a/www/squid/files/patch-src_tools.cc b/www/squid/files/patch-src_tools.cc
index 19c4e981969c..155d8d84dcaf 100644
--- a/www/squid/files/patch-src_tools.cc
+++ b/www/squid/files/patch-src_tools.cc
@@ -1,6 +1,6 @@
---- src/tools.cc.orig 2018-06-11 16:30:57 UTC
+--- src/tools.cc.orig 2021-12-07 14:15:52 UTC
+++ src/tools.cc
-@@ -605,7 +605,7 @@ no_suid(void)
+@@ -608,7 +608,7 @@ no_suid(void)
uid = geteuid();
debugs(21, 3, "no_suid: PID " << getpid() << " giving up root privileges forever");
diff --git a/www/squid/pkg-plist b/www/squid/pkg-plist
index b353b05a8775..5cbb9204e45d 100644
--- a/www/squid/pkg-plist
+++ b/www/squid/pkg-plist
@@ -44,6 +44,10 @@ libexec/squid/basic_getpwnam_auth
libexec/squid/basic_fake_auth
libexec/squid/basic_db_auth
%%UNLINKD%%libexec/squid/unlinkd
+%%TDB%%man/man8/ext_time_quota_acl.8.gz
+%%TDB%%man/man8/ext_session_acl.8.gz
+%%TDB%%libexec/squid/ext_time_quota_acl
+%%TDB%%libexec/squid/ext_session_acl
%%SSL%%man/man8/security_file_certgen.8.gz
%%SSL%%libexec/squid/security_file_certgen
%%ICMP%%@(,squid,4510) libexec/squid/pinger
@@ -600,6 +604,7 @@ libexec/squid/basic_db_auth
%%ETCDIR%%/errors/sr-cyrl-me
%%ETCDIR%%/errors/sr-cyrl-cs
%%ETCDIR%%/errors/sr
+%%ETCDIR%%/errors/spq
%%ETCDIR%%/errors/sl/error-details.txt
%%ETCDIR%%/errors/sl/ERR_ZERO_SIZE_OBJECT
%%ETCDIR%%/errors/sl/ERR_WRITE_ERROR
@@ -1719,7 +1724,49 @@ libexec/squid/basic_db_auth
%%ETCDIR%%/errors/es-pe
%%ETCDIR%%/errors/es-pa
%%ETCDIR%%/errors/es-ni
-%%ETCDIR%%/errors/es-mx
+%%ETCDIR%%/errors/es-mx/ERR_ACCESS_DENIED
+%%ETCDIR%%/errors/es-mx/ERR_ACL_TIME_QUOTA_EXCEEDED
+%%ETCDIR%%/errors/es-mx/ERR_AGENT_CONFIGURE
+%%ETCDIR%%/errors/es-mx/ERR_AGENT_WPAD
+%%ETCDIR%%/errors/es-mx/ERR_CACHE_ACCESS_DENIED
+%%ETCDIR%%/errors/es-mx/ERR_CACHE_MGR_ACCESS_DENIED
+%%ETCDIR%%/errors/es-mx/ERR_CANNOT_FORWARD
+%%ETCDIR%%/errors/es-mx/ERR_CONFLICT_HOST
+%%ETCDIR%%/errors/es-mx/ERR_CONNECT_FAIL
+%%ETCDIR%%/errors/es-mx/ERR_DIR_LISTING
+%%ETCDIR%%/errors/es-mx/ERR_DNS_FAIL
+%%ETCDIR%%/errors/es-mx/ERR_ESI
+%%ETCDIR%%/errors/es-mx/ERR_FORWARDING_DENIED
+%%ETCDIR%%/errors/es-mx/ERR_FTP_DISABLED
+%%ETCDIR%%/errors/es-mx/ERR_FTP_FAILURE
+%%ETCDIR%%/errors/es-mx/ERR_FTP_FORBIDDEN
+%%ETCDIR%%/errors/es-mx/ERR_FTP_NOT_FOUND
+%%ETCDIR%%/errors/es-mx/ERR_FTP_PUT_CREATED
+%%ETCDIR%%/errors/es-mx/ERR_FTP_PUT_ERROR
+%%ETCDIR%%/errors/es-mx/ERR_FTP_PUT_MODIFIED
+%%ETCDIR%%/errors/es-mx/ERR_FTP_UNAVAILABLE
+%%ETCDIR%%/errors/es-mx/ERR_GATEWAY_FAILURE
+%%ETCDIR%%/errors/es-mx/ERR_ICAP_FAILURE
+%%ETCDIR%%/errors/es-mx/ERR_INVALID_REQ
+%%ETCDIR%%/errors/es-mx/ERR_INVALID_RESP
+%%ETCDIR%%/errors/es-mx/ERR_INVALID_URL
+%%ETCDIR%%/errors/es-mx/ERR_LIFETIME_EXP
+%%ETCDIR%%/errors/es-mx/ERR_NO_RELAY
+%%ETCDIR%%/errors/es-mx/ERR_ONLY_IF_CACHED_MISS
+%%ETCDIR%%/errors/es-mx/ERR_PRECONDITION_FAILED
+%%ETCDIR%%/errors/es-mx/ERR_PROTOCOL_UNKNOWN
+%%ETCDIR%%/errors/es-mx/ERR_READ_ERROR
+%%ETCDIR%%/errors/es-mx/ERR_READ_TIMEOUT
+%%ETCDIR%%/errors/es-mx/ERR_SECURE_CONNECT_FAIL
+%%ETCDIR%%/errors/es-mx/ERR_SHUTTING_DOWN
+%%ETCDIR%%/errors/es-mx/ERR_SOCKET_FAILURE
+%%ETCDIR%%/errors/es-mx/ERR_TOO_BIG
+%%ETCDIR%%/errors/es-mx/ERR_UNSUP_HTTPVERSION
+%%ETCDIR%%/errors/es-mx/ERR_UNSUP_REQ
+%%ETCDIR%%/errors/es-mx/ERR_URN_RESOLVE
+%%ETCDIR%%/errors/es-mx/ERR_WRITE_ERROR
+%%ETCDIR%%/errors/es-mx/ERR_ZERO_SIZE_OBJECT
+%%ETCDIR%%/errors/es-mx/error-details.txt
%%ETCDIR%%/errors/es-hn
%%ETCDIR%%/errors/es-gt
%%ETCDIR%%/errors/es-es
@@ -1728,6 +1775,8 @@ libexec/squid/basic_db_auth
%%ETCDIR%%/errors/es-cr
%%ETCDIR%%/errors/es-co
%%ETCDIR%%/errors/es-cl
+%%ETCDIR%%/errors/es-cu
+%%ETCDIR%%/errors/es-bz
%%ETCDIR%%/errors/es-bo
%%ETCDIR%%/errors/es-ar
%%ETCDIR%%/errors/en/error-details.txt
@@ -2204,10 +2253,6 @@ libexec/squid/basic_db_auth
%%ETCDIR%%/errors/af/ERR_AGENT_CONFIGURE
%%ETCDIR%%/errors/af/ERR_ACL_TIME_QUOTA_EXCEEDED
%%ETCDIR%%/errors/af/ERR_ACCESS_DENIED
-%%BDB%%man/man8/ext_time_quota_acl.8.gz
-%%BDB%%man/man8/ext_session_acl.8.gz
-%%BDB%%libexec/squid/ext_time_quota_acl
-%%BDB%%libexec/squid/ext_session_acl
%%AUTH_SQL%%man/man8/ext_sql_session_acl.8.gz
%%AUTH_SQL%%libexec/squid/ext_sql_session_acl
%%AUTH_SMB%%man/man8/ext_wbinfo_group_acl.8.gz
@@ -2229,6 +2274,8 @@ libexec/squid/basic_db_auth
%%AUTH_KERB%%libexec/squid/negotiate_wrapper_auth
%%AUTH_KERB%%libexec/squid/negotiate_kerberos_auth_test
%%AUTH_KERB%%libexec/squid/negotiate_kerberos_auth
+%%AUTH_KERB%%%%AUTH_LDAP%%%%AUTH_SASL%%man/man8/ext_kerberos_sid_group_acl.8.gz
+%%AUTH_KERB%%%%AUTH_LDAP%%%%AUTH_SASL%%libexec/squid/ext_kerberos_sid_group_acl
%%AUTH_KERB%%%%AUTH_LDAP%%%%AUTH_SASL%%libexec/squid/ext_kerberos_ldap_group_acl
%%AUTH_KERB%%%%AUTH_LDAP%%%%AUTH_SASL%%libexec/squid/cert_tool
@sample %%ETCDIR%%/squid.conf.sample