aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2023-02-06 21:11:52 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2023-02-06 21:11:52 +0000
commitd79d484154194fcf8139f189043847ed2e482230 (patch)
treeeffe70831a0f67f6ac9a280c2aeb55dccc287d6a
parent8964321174e217f2f201796d1141a23c9cdcf2a4 (diff)
downloadports-d79d484154194fcf8139f189043847ed2e482230.tar.gz
ports-d79d484154194fcf8139f189043847ed2e482230.zip
www/firefox-esr: update to 102.8.0 (rc1)
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox-esr/distinfo6
-rw-r--r--www/firefox-esr/files/patch-bug179998260
3 files changed, 4 insertions, 64 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index deade0e5dd1a..a4729a67b75f 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -1,5 +1,5 @@
PORTNAME= firefox
-DISTVERSION= 102.7.0
+DISTVERSION= 102.8.0
PORTEPOCH= 1
CATEGORIES= www wayland
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/distinfo b/www/firefox-esr/distinfo
index 4ca4dfd7b5a2..5a57c5bad85f 100644
--- a/www/firefox-esr/distinfo
+++ b/www/firefox-esr/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1673286650
-SHA256 (firefox-102.7.0esr.source.tar.xz) = a7a4603417fcb42ec37f2cff9034280ce2ec772c0a5fc500fada4286ba3114aa
-SIZE (firefox-102.7.0esr.source.tar.xz) = 479538092
+TIMESTAMP = 1675714425
+SHA256 (firefox-102.8.0esr.source.tar.xz) = 2d7e7327edf5802d1ad9ade85e77f766b6b909a53bc185e452e064bffa3339b9
+SIZE (firefox-102.8.0esr.source.tar.xz) = 477458144
diff --git a/www/firefox-esr/files/patch-bug1799982 b/www/firefox-esr/files/patch-bug1799982
deleted file mode 100644
index dac77d73390b..000000000000
--- a/www/firefox-esr/files/patch-bug1799982
+++ /dev/null
@@ -1,60 +0,0 @@
-Bug 1799982 - Remove uses of inline flags from XPIDL regexps. r=xpcom-reviewers,kmag
-
-Apparently the use of these is being turned into an error in Python 3.11.
-Fortunately, our uses appears to be rather trivial.
-
-For t_multilinecomment and t_LCDATA, I dropped the (?s) flag and just
-replaced the one use of . with (\n|.). (?s) means DOTALL, which means
-that dot includes any character, including a newline. Otherwise it means
-dot includes any character except a newline.
-
-I took the new t_singlelinecomment from IPDL's parser.py, so I assume
-it is reasonable enough. t_multilinecomment is also now the same as
-in IPDL.
-
-Differential Revision: https://phabricator.services.mozilla.com/D161738
-
-diff --git xpcom/idl-parser/xpidl/xpidl.py xpcom/idl-parser/xpidl/xpidl.py
---- xpcom/idl-parser/xpidl/xpidl.py
-+++ xpcom/idl-parser/xpidl/xpidl.py
-@@ -1634,36 +1634,36 @@ class IDLParser(object):
- t_LSHIFT = r"<<"
- t_RSHIFT = r">>"
-
- literals = '"(){}[]<>,;:=|+-*'
-
- t_ignore = " \t"
-
- def t_multilinecomment(self, t):
-- r"/\*(?s).*?\*/"
-+ r"/\*(\n|.)*?\*/"
- t.lexer.lineno += t.value.count("\n")
- if t.value.startswith("/**"):
- self._doccomments.append(t.value)
-
- def t_singlelinecomment(self, t):
-- r"(?m)//.*?$"
-+ r"//[^\n]*"
-
- def t_IID(self, t):
- return t
-
- t_IID.__doc__ = r"%(c)s{8}-%(c)s{4}-%(c)s{4}-%(c)s{4}-%(c)s{12}" % {"c": hexchar}
-
- def t_IDENTIFIER(self, t):
- r"(unsigned\ long\ long|unsigned\ short|unsigned\ long|long\ long)(?!_?[A-Za-z][A-Za-z_0-9])|_?[A-Za-z][A-Za-z_0-9]*" # NOQA: E501
- t.type = self.keywords.get(t.value, "IDENTIFIER")
- return t
-
- def t_LCDATA(self, t):
-- r"(?s)%\{[ ]*C\+\+[ ]*\n(?P<cdata>.*?\n?)%\}[ ]*(C\+\+)?"
-+ r"%\{[ ]*C\+\+[ ]*\n(?P<cdata>(\n|.)*?\n?)%\}[ ]*(C\+\+)?"
- t.type = "CDATA"
- t.value = t.lexer.lexmatch.group("cdata")
- t.lexer.lineno += t.value.count("\n")
- return t
-
- def t_INCLUDE(self, t):
- r'\#include[ \t]+"[^"\n]+"'
- inc, value, end = t.value.split('"')
-