aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-08-06 13:21:16 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-08-06 13:21:16 +0000
commitd7b8873cd76551f70af43d1e3d2982342fbe9c5d (patch)
tree77608802d83d64e6de43b0d9f5159d66f73f444b
parenta1070ae3174601246150ff32054c23788074f8e3 (diff)
downloadports-d7b8873cd76551f70af43d1e3d2982342fbe9c5d.tar.gz
ports-d7b8873cd76551f70af43d1e3d2982342fbe9c5d.zip
[NEW] www/py-boto3: AWS SDK for Python
Boto3 is the Amazon Web Services (AWS) Software Development Kit (SDK) for Python, which allows Python developers to write software that makes use of services like Amazon S3 and Amazon EC2. You can find the latest, most up to date, documentation at Read the Docs, including a list of services that are supported. WWW: https://github.com/boto/boto3
Notes
Notes: svn path=/head/; revision=419745
-rw-r--r--www/Makefile1
-rw-r--r--www/py-boto3/Makefile36
-rw-r--r--www/py-boto3/distinfo3
-rw-r--r--www/py-boto3/files/patch-setup.py29
-rw-r--r--www/py-boto3/pkg-descr7
5 files changed, 76 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index fb30e43fb123..4a2cfefc477e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1482,6 +1482,7 @@
SUBDIR += py-bjoern
SUBDIR += py-bleach
SUBDIR += py-blogofile
+ SUBDIR += py-boto3
SUBDIR += py-bottle
SUBDIR += py-bottle-cork
SUBDIR += py-cachecontrol
diff --git a/www/py-boto3/Makefile b/www/py-boto3/Makefile
new file mode 100644
index 000000000000..9db0978af1c1
--- /dev/null
+++ b/www/py-boto3/Makefile
@@ -0,0 +1,36 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= boto3
+PORTVERSION= 1.4.0
+CATEGORIES= www python devel
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= AWS SDK for Python
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}botocore>=1.4.1:devel/py-botocore \
+ ${PYTHON_PKGNAMEPREFIX}jmespath>=0.7.1:devel/py-jmespath \
+ ${PYTHON_PKGNAMEPREFIX}s3transfer>=0.1.0:net/py-s3transfer
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock
+
+# Actually -2.7,3.3-3.5
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+
+GH_ACCOUNT= boto
+
+NO_ARCH= yes
+
+# setup.py test runs integration tests which fail
+# https://github.com/boto/s3transfer/issues/41
+# Note: this is an AWS python package wide issue
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m nose -v tests/unit tests/functional
+
+.include <bsd.port.mk>
diff --git a/www/py-boto3/distinfo b/www/py-boto3/distinfo
new file mode 100644
index 000000000000..9a24b2d6dcb5
--- /dev/null
+++ b/www/py-boto3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470475306
+SHA256 (boto-boto3-1.4.0_GH0.tar.gz) = 8fdd3743e34a32e5cb8636fb33dafe7336b7a341583653f52c6c20f7fe764472
+SIZE (boto-boto3-1.4.0_GH0.tar.gz) = 183263
diff --git a/www/py-boto3/files/patch-setup.py b/www/py-boto3/files/patch-setup.py
new file mode 100644
index 000000000000..84d60714cd68
--- /dev/null
+++ b/www/py-boto3/files/patch-setup.py
@@ -0,0 +1,29 @@
+--- setup.py.orig 2016-08-03 00:15:58 UTC
++++ setup.py
+@@ -15,11 +15,14 @@ VERSION_RE = re.compile(r'''__version__
+
+
+ requires = [
+- 'botocore>=1.4.1,<1.5.0',
+- 'jmespath>=0.7.1,<1.0.0',
+- 's3transfer>=0.1.0,<0.2.0'
++ 'botocore>=1.4.1',
++ 'jmespath>=0.7.1',
++ 's3transfer>=0.1.0'
+ ]
+
++tests_require = [
++ 'nose',
++]
+
+ def get_version():
+ init = open(os.path.join(ROOT, 'boto3', '__init__.py')).read()
+@@ -43,6 +46,8 @@ setup(
+ },
+ include_package_data=True,
+ install_requires=requires,
++ tests_require=tests_require,
++ test_suite='nose.collector',
+ license="Apache License 2.0",
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
diff --git a/www/py-boto3/pkg-descr b/www/py-boto3/pkg-descr
new file mode 100644
index 000000000000..c416093c9d84
--- /dev/null
+++ b/www/py-boto3/pkg-descr
@@ -0,0 +1,7 @@
+Boto3 is the Amazon Web Services (AWS) Software Development Kit (SDK)
+for Python, which allows Python developers to write software that makes
+ use of services like Amazon S3 and Amazon EC2. You can find the latest,
+most up to date, documentation at Read the Docs, including a list of
+services that are supported.
+
+WWW: https://github.com/boto/boto3