aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2004-10-21 18:00:45 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2004-10-21 18:00:45 +0000
commitd7e7582683f9ba02c17eaab6a76e20ccea436111 (patch)
treec0651016570f427aeb66a9d5d5fdfb2cec2535d7
parentbd4066ee457a1089e012ea4b1afe800f4db21264 (diff)
downloadports-d7e7582683f9ba02c17eaab6a76e20ccea436111.tar.gz
ports-d7e7582683f9ba02c17eaab6a76e20ccea436111.zip
since gtk20 requires everything nice encoded into utf-8, mime encoded
messages should be also converted into utf-8 format. That fixes the problem I had with wiped out lines containing non-7bit-clean chars. (like german umlauts) Bump PORTREVISION sylpheed-gtk2 authors are informed...
Notes
Notes: svn path=/head/; revision=119914
-rw-r--r--mail/sylpheed-gtk2/Makefile2
-rw-r--r--mail/sylpheed-gtk2/files/patch-encoding22
2 files changed, 23 insertions, 1 deletions
diff --git a/mail/sylpheed-gtk2/Makefile b/mail/sylpheed-gtk2/Makefile
index 316e24342778..59f36193d639 100644
--- a/mail/sylpheed-gtk2/Makefile
+++ b/mail/sylpheed-gtk2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed-gtk2
PORTVERSION= 0.9.12.20040918
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/mail/sylpheed-gtk2/files/patch-encoding b/mail/sylpheed-gtk2/files/patch-encoding
new file mode 100644
index 000000000000..e7f74b25709b
--- /dev/null
+++ b/mail/sylpheed-gtk2/files/patch-encoding
@@ -0,0 +1,22 @@
+--- src/procmime.c.orig Thu Oct 21 17:25:19 2004
++++ src/procmime.c Thu Oct 21 18:12:24 2004
+@@ -694,7 +694,7 @@
+ if (mimeinfo->mime_type == MIME_TEXT) {
+ while (fgets(buf, sizeof(buf), tmpfp) != NULL) {
+ #warning FIXME_GTK2
+- str = conv_codeset_strdup(buf, src_codeset, NULL);
++ str = conv_codeset_strdup(buf, src_codeset, CS_UTF_8);
+ if (str) {
+ fputs(str, outfp);
+ g_free(str);
+--- src/unmime.c.orig Thu Oct 21 17:25:20 2004
++++ src/unmime.c Thu Oct 21 17:37:45 2004
+@@ -113,7 +113,7 @@
+ }
+
+ /* convert to locale encoding */
+- conv_str = conv_codeset_strdup(decoded_text, charset, NULL);
++ conv_str = conv_codeset_strdup(decoded_text, charset, CS_UTF_8);
+ if (conv_str) {
+ len = strlen(conv_str);
+ memcpy(outp, conv_str, len);