aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-04 11:50:00 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-04 13:23:24 +0000
commitd81a0d2d8b9e224a88a93bcaea3f352c4c65142c (patch)
treec594c8e15ad0bae28543a5759e3aefe69ca78a88
parentb684f0f142905f96de7df141674c9cd44e046ce7 (diff)
downloadports-d81a0d2d8b9e224a88a93bcaea3f352c4c65142c.tar.gz
ports-d81a0d2d8b9e224a88a93bcaea3f352c4c65142c.zip
print/pic2fig: Fix build with llvm15
- Pet protclippy - Adopt port
-rw-r--r--print/pic2fig/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/print/pic2fig/Makefile b/print/pic2fig/Makefile
index e17afbbfc4d3..3fefbee987d5 100644
--- a/print/pic2fig/Makefile
+++ b/print/pic2fig/Makefile
@@ -4,16 +4,25 @@ PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= XCONTRIB/utilities
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Pic format to fig format converter
USES= tar:Z
-WRKSRC= ${WRKDIR}/${PORTNAME}
+
CFLAGS+= -Wno-return-type
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
PLIST_FILES= bin/pic2fig man/man1/pic2fig.1.gz
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pic2fig ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/pic2fig.1 ${STAGEDIR}${MANPREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>