aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-07-26 09:04:41 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-07-26 09:04:41 +0000
commitd8722f974d14bb79fb5a8d6b671a94ab866de71e (patch)
tree2dd05ac7ac7ac9dfa4611bac2d4c20e4e838ed13
parent543ccd13ce73f1512b42238b8405632e81c519c3 (diff)
downloadports-d8722f974d14bb79fb5a8d6b671a94ab866de71e.tar.gz
ports-d8722f974d14bb79fb5a8d6b671a94ab866de71e.zip
New port: games/black-hole-solver
Black Hole Solitaire Solver This is a solver, written in C, to solve Golf solitaire, the Solitaire variant called “Black Hole” and the one called “All in a Row”. It provides a portable C library, and a command line application that after being fed with a layout will emit the cards to move. https://www.shlomifish.org/open-source/projects/black-hole-solitaire-solver/ This is an upcoming dependency in games/kpat
Notes
Notes: svn path=/head/; revision=543457
-rw-r--r--games/Makefile1
-rw-r--r--games/black-hole-solver/Makefile20
-rw-r--r--games/black-hole-solver/distinfo3
-rw-r--r--games/black-hole-solver/pkg-descr6
-rw-r--r--games/black-hole-solver/pkg-plist9
5 files changed, 39 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 69dcba4f529f..29416db6c620 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -86,6 +86,7 @@
SUBDIR += biorythm
SUBDIR += bitefusion
SUBDIR += black-box
+ SUBDIR += black-hole-solver
SUBDIR += blackjackclient
SUBDIR += blackshadeselite
SUBDIR += blinken
diff --git a/games/black-hole-solver/Makefile b/games/black-hole-solver/Makefile
new file mode 100644
index 000000000000..a4d8239c6e88
--- /dev/null
+++ b/games/black-hole-solver/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= black-hole-solver
+DISTVERSION= 1.8.0
+CATEGORIES= games
+MASTER_SITES= https://fc-solve.shlomifish.org/downloads/fc-solve/
+
+MAINTAINER= tcberner@FreeBSD.org
+COMMENT= Black Hole Solitaire Solver
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= rinutils>0:devel/rinutils \
+ p5-Path-Tiny>=0:devel/p5-Path-Tiny
+
+USES= cmake tar:xz
+USE_PERL5= build
+
+.include <bsd.port.mk>
diff --git a/games/black-hole-solver/distinfo b/games/black-hole-solver/distinfo
new file mode 100644
index 000000000000..5d27ae94cd30
--- /dev/null
+++ b/games/black-hole-solver/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1595751723
+SHA256 (black-hole-solver-1.8.0.tar.xz) = f73c14272545baa4cba717b61646ec0c610b124e1721288b0a9bff680bb9982c
+SIZE (black-hole-solver-1.8.0.tar.xz) = 76264
diff --git a/games/black-hole-solver/pkg-descr b/games/black-hole-solver/pkg-descr
new file mode 100644
index 000000000000..2b4628e22851
--- /dev/null
+++ b/games/black-hole-solver/pkg-descr
@@ -0,0 +1,6 @@
+This is a solver, written in C, to solve Golf solitaire, the Solitaire variant
+called "Black Hole" and the one called "All in a Row". It provides a portable C
+library, and a command line application that after being fed with a layout will
+emit the cards to move.
+
+WWW: https://www.shlomifish.org/open-source/projects/black-hole-solitaire-solver
diff --git a/games/black-hole-solver/pkg-plist b/games/black-hole-solver/pkg-plist
new file mode 100644
index 000000000000..6e8e834d0f4a
--- /dev/null
+++ b/games/black-hole-solver/pkg-plist
@@ -0,0 +1,9 @@
+bin/black-hole-solve
+include/black-hole-solver/black_hole_solver.h
+include/black-hole-solver/bool.h
+include/black-hole-solver/fcs_dllexport.h
+lib/libblack_hole_solver.so
+lib/libblack_hole_solver.so.1
+lib/libblack_hole_solver.so.1.0.0
+libdata/pkgconfig/libblack-hole-solver.pc
+share/man/man6/black-hole-solve.6.gz