aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2022-01-26 10:26:57 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2022-01-26 10:43:02 +0000
commitd87992a6174b82811a3caf678647784d77c1c045 (patch)
treefcaa2a44c538a8535cfcd05468c740612b313ced
parent5f255f62ce0cc4845b6531fec4ef614003bb8928 (diff)
downloadports-d87992a6174b82811a3caf678647784d77c1c045.tar.gz
ports-d87992a6174b82811a3caf678647784d77c1c045.zip
www/gitlab-ce: fix database migration
The current gitlab version misses a gem, we add it here. Refer to: https://gitlab.com/gitlab-org/gitlab/-/issues/350866
-rw-r--r--www/gitlab-ce/Makefile5
-rw-r--r--www/gitlab-ce/files/patch-Gemfile14
2 files changed, 15 insertions, 4 deletions
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index d4bb50cacec7..6d091c9fe2d6 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -13,6 +13,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
# the rubygems of RUN_DEPENDS matches the order of the Gemfile
# which makes maintaining this long list much easier!
+# devel/rubygem-parser is required for database upgrade process
+# see https://gitlab.com/gitlab-org/gitlab/-/issues/350866
MY_DEPENDS= git>=2.32.0:devel/git \
gitaly>=${PORTVERSION}:devel/gitaly \
gitlab-elasticsearch-indexer>=2.17.0:textproc/gitlab-elasticsearch-indexer \
@@ -254,7 +256,8 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-webauthn>=2.3<3:security/rubygem-webauthn \
rubygem-ipaddress>=0.8.3<0.9:net/rubygem-ipaddress \
rubygem-parslet1>=1.8<2:textproc/rubygem-parslet1 \
- rubygem-ipynbdiff>=0.3.8<0.3.9:devel/rubygem-ipynbdiff
+ rubygem-ipynbdiff>=0.3.8<0.3.9:devel/rubygem-ipynbdiff \
+ rubygem-parser>=0:devel/rubygem-parser
BUILD_DEPENDS= gem:devel/ruby-gems \
${MY_DEPENDS}
diff --git a/www/gitlab-ce/files/patch-Gemfile b/www/gitlab-ce/files/patch-Gemfile
index 5525869a493c..5e0004d14ef5 100644
--- a/www/gitlab-ce/files/patch-Gemfile
+++ b/www/gitlab-ce/files/patch-Gemfile
@@ -26,7 +26,7 @@
gem 'graphlient', '~> 0.4.0' # Used by BulkImport feature (group::import)
gem 'hashie'
-@@ -328,114 +327,13 @@ gem 'batch-loader', '~> 2.0.1'
+@@ -328,115 +327,14 @@ gem 'batch-loader', '~> 2.0.1'
gem 'peek', '~> 1.1'
# Snowplow events tracking
@@ -39,7 +39,7 @@
gem 'prometheus-client-mmap', '~> 0.15.0', require: 'prometheus/client'
gem 'warning', '~> 1.2.0'
--
+
-group :development do
- gem 'lefthook', '~> 0.7.0', require: false
- gem 'solargraph', '~> 0.43', require: false
@@ -139,6 +139,14 @@
- # Moved in `test` because https://gitlab.com/gitlab-org/gitlab/-/issues/217527
- gem 'derailed_benchmarks', require: false
-end
-
+-
gem 'octokit', '~> 4.15'
+ # Updating this gem version here is deprecated. See:
+@@ -542,3 +440,6 @@ gem 'ipaddress', '~> 0.8.3'
+ gem 'parslet', '~> 1.8'
+
+ gem 'ipynbdiff', '0.3.8'
++
++gem 'parser'
++