aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-14 16:40:38 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-14 17:15:56 +0000
commitd881ddcce36b874c410e34d606beae6f5517a2df (patch)
tree9152045b5facab891d826fdfb974595d85686c89
parent1d4d87399c151f7303ce7fdec0c4cfd8e9239a58 (diff)
downloadports-d881ddcce36b874c410e34d606beae6f5517a2df.tar.gz
ports-d881ddcce36b874c410e34d606beae6f5517a2df.zip
devel/py-testtools: Update to 2.7.1
- Convert to USE_PYTHON=pep517 Changes: https://github.com/testing-cabal/testtools/releases
-rw-r--r--devel/py-testtools/Makefile18
-rw-r--r--devel/py-testtools/distinfo6
-rw-r--r--devel/py-testtools/files/patch-requirements.txt7
3 files changed, 16 insertions, 15 deletions
diff --git a/devel/py-testtools/Makefile b/devel/py-testtools/Makefile
index b2728c4e06a7..ff4945f1f76c 100644
--- a/devel/py-testtools/Makefile
+++ b/devel/py-testtools/Makefile
@@ -1,5 +1,5 @@
PORTNAME= testtools
-PORTVERSION= 2.6.0
+PORTVERSION= 2.7.1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,11 +11,13 @@ WWW= https://github.com/testing-cabal/testtools
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=0.11:devel/py-pbr@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=0.11:devel/py-pbr@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatch-vcs>=0:devel/py-hatch-vcs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
@@ -23,8 +25,14 @@ PORTDOCS= api.rst for-framework-folk.rst for-test-authors.rst hacking.rst index.
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} >= 31200
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR}
+.endif
+
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/*.rst ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/py-testtools/distinfo b/devel/py-testtools/distinfo
index dd7cf52acbf1..662c86127503 100644
--- a/devel/py-testtools/distinfo
+++ b/devel/py-testtools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1679498748
-SHA256 (testtools-2.6.0.tar.gz) = 28b65e14c0f2d3ecbbfb5f55c9dcde5e4faa80ac16a37a823909a1fe3cbcb30a
-SIZE (testtools-2.6.0.tar.gz) = 237864
+TIMESTAMP = 1699774640
+SHA256 (testtools-2.7.1.tar.gz) = df6de96010e29ee21f637a147eabf30d50b25e3841dd1d68f93ee89ce77e366c
+SIZE (testtools-2.7.1.tar.gz) = 200953
diff --git a/devel/py-testtools/files/patch-requirements.txt b/devel/py-testtools/files/patch-requirements.txt
deleted file mode 100644
index 9d3b505e204f..000000000000
--- a/devel/py-testtools/files/patch-requirements.txt
+++ /dev/null
@@ -1,7 +0,0 @@
-PR: 228769
-
---- requirements.txt.orig 2023-03-14 10:43:35 UTC
-+++ requirements.txt
-@@ -1,2 +1 @@
- pbr>=0.11
--fixtures>=2.0