aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-11 16:33:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-11 16:33:29 +0000
commitd887fb2b91d38fdb00955c3404ae0443bd6e9358 (patch)
tree29de22bba4ae6127a424379f2e42a18a95c9720b
parent3ee94bc4a0eb3795242fd69236f9d9ec6d2f9e0b (diff)
downloadports-d887fb2b91d38fdb00955c3404ae0443bd6e9358.tar.gz
ports-d887fb2b91d38fdb00955c3404ae0443bd6e9358.zip
- Update to 2.0.0
PR: 107820 Submitted by: Alexander Logvinov <ports@logvinov.com> (maintainer)
Notes
Notes: svn path=/head/; revision=182108
-rw-r--r--comms/atslog/Makefile55
-rw-r--r--comms/atslog/distinfo6
-rw-r--r--comms/atslog/files/atslogd.in2
-rw-r--r--comms/atslog/files/patch-diagram_bars.php26
-rw-r--r--comms/atslog/files/patch-diagram_bars_dur.php26
-rw-r--r--comms/atslog/files/patch-include__atslogmaster.in11
-rw-r--r--comms/atslog/files/pkg-message.in2
-rw-r--r--comms/atslog/pkg-descr2
-rw-r--r--comms/atslog/pkg-plist15
9 files changed, 102 insertions, 43 deletions
diff --git a/comms/atslog/Makefile b/comms/atslog/Makefile
index 16585ffa870c..d96ddbcc6e50 100644
--- a/comms/atslog/Makefile
+++ b/comms/atslog/Makefile
@@ -6,26 +6,21 @@
#
PORTNAME= atslog
-PORTVERSION= 2.0.0.p4
-PORTREVISION= 2
+PORTVERSION= 2.0.0
CATEGORIES= comms
-MASTER_SITES= ${MASTER_SITE_BERLIOS}
-MASTER_SITE_SUBDIR=${PORTNAME}
-DISTNAME= ${PORTNAME}-2.0.0pre4
+MASTER_SITES= BERLIOS
MAINTAINER= ports@logvinov.com
COMMENT= Software for collecting and analyzing calls from different PBX models
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
-
OPTIONS= LIBWRAP "Enable TCP wrapper support" on \
+ MYSQL "Enable MySQL support" on \
+ PGSQL "Enable PostgreSQL support" off \
WWW "Install web interface" on \
WWWGD "Graphic reports" on
HAS_CONFIGURE= yes
USE_PERL5= yes
-USE_MYSQL= yes
USE_RC_SUBR= ${PORTNAME}d
PORTDOCS= CHANGES ChangeLog DEINSTALL INSTALL LICENSE TODO UPDATING USAGE
SUB_FILES= pkg-message
@@ -36,8 +31,12 @@ CONFIGURE_ARGS+=--prefix=${PREFIX} --localstatedir=/var
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_MYSQL) && !defined(WITH_PGSQL)
+IGNORE= is useless without a database. Please (re)run 'make config' and choose one of PGSQL and MYSQL"
+.endif
+
.if !defined(WITHOUT_WWW)
-USE_PHP= mysql pcre
+USE_PHP= pcre
WANT_PHP_WEB= yes
PLIST_SUB+= WWW=""
.if !defined(WITHOUT_WWWGD)
@@ -48,17 +47,31 @@ USE_PHP+= gd
PLIST_SUB+= WWW="@comment "
.endif
+.if !defined(WITHOUT_MYSQL)
+USE_MYSQL= yes
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+.if !defined(WITHOUT_WWW)
+USE_PHP+= mysql
+.endif
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PGSQL= yes
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+.if !defined(WITHOUT_WWW)
+USE_PHP+= pgsql
+.endif
+.endif
+
post-patch:
.if defined(WITHOUT_LIBWRAP)
@${REINPLACE_CMD} -e 's|LIBWRAP=|#LIBWRAP=|' ${WRKSRC}/${USE_RC_SUBR}/Makefile
@${REINPLACE_CMD} -e 's|#define|//#define|' ${WRKSRC}/${USE_RC_SUBR}/${USE_RC_SUBR}.h
.endif
- @${REINPLACE_CMD} -e 's|createsqltables.mysql.sql|${DATADIR}/sql/createsqltables.mysql.sql|' \
+ @${REINPLACE_CMD} -e 's|createsqltables.|${DATADIR}/sql/createsqltables.|g' \
-e 's|data.sql|${DATADIR}/sql/data.sql|' ${WRKSRC}/data/sql/install-sql.pl
-.for i in ${CONFIGS}
- @${REINPLACE_CMD} -e 's|/log|/log/atslog|' ${WRKSRC}/include/${i}.in
-.endfor
- @${MV} ${WRKSRC}/www/include/set/conf.inc.php ${WRKSRC}/www/include/set/conf.inc.default.php
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/${USE_RC_SUBR}/${USE_RC_SUBR} ${PREFIX}/bin
@@ -96,18 +109,18 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/data/sql/install-sql.pl ${DATADIR}/sql
${MKDIR} ${PREFIX}/libexec/${PORTNAME}
cd ${WRKSRC}/libexec && \
- ${FIND} * -type f -exec \
+ ${FIND} . -type f -exec \
${INSTALL_DATA} "{}" "${PREFIX}/libexec/${PORTNAME}/{}" \;
.if !defined(WITHOUT_WWW)
${MKDIR} ${PREFIX}/www/${PORTNAME}
cd ${WRKSRC}/www && \
- ${FIND} * -type d ! -empty -exec \
+ ${FIND} . -type d ! -empty -exec \
${MKDIR} "${PREFIX}/www/${PORTNAME}/{}" \; && \
- ${FIND} -E * -type f ! -iregex ".*Makefile" -exec \
+ ${FIND} -E . -type f ! -iregex "(.*Makefile|.*\.orig)" -exec \
${INSTALL_DATA} "{}" "${PREFIX}/www/${PORTNAME}/{}" \;
-.if !exists(${PREFIX}/www/${PORTNAME}/include/set/conf.inc.php)
- ${INSTALL_DATA} ${WRKSRC}/www/include/set/conf.inc.default.php \
- ${PREFIX}/www/${PORTNAME}/include/set/conf.inc.php
+.if !exists(${PREFIX}/www/${PORTNAME}/include/config.inc.php)
+ ${INSTALL_DATA} ${WRKSRC}/www/include/config.inc.php.default \
+ ${PREFIX}/www/${PORTNAME}/include/config.inc.php
.endif
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/www/${PORTNAME}
.endif
diff --git a/comms/atslog/distinfo b/comms/atslog/distinfo
index 8af0bf437a48..b7207a7463aa 100644
--- a/comms/atslog/distinfo
+++ b/comms/atslog/distinfo
@@ -1,3 +1,3 @@
-MD5 (atslog-2.0.0pre4.tar.gz) = 2b6a76f6af5bbd5a2eefd61fc48e784d
-SHA256 (atslog-2.0.0pre4.tar.gz) = bf639ed98784d6e1c24fefbed29b830016275374c75eb32b3c90c0a14bbeb5d7
-SIZE (atslog-2.0.0pre4.tar.gz) = 589398
+MD5 (atslog-2.0.0.tar.gz) = 441c1fef1fae4a4a56a7de1f2841df94
+SHA256 (atslog-2.0.0.tar.gz) = 33dea90446f9dec22c9aaa6b2e59e21868574300cbf317a16b50ab265d75ce18
+SIZE (atslog-2.0.0.tar.gz) = 596792
diff --git a/comms/atslog/files/atslogd.in b/comms/atslog/files/atslogd.in
index 55c642f39d3b..e3341d6eeffc 100644
--- a/comms/atslog/files/atslogd.in
+++ b/comms/atslog/files/atslogd.in
@@ -3,7 +3,7 @@
# $FreeBSD$
#
# PROVIDE: atslogd
-# REQUIRE: mysql
+# REQUIRE: mysql postgresql
# KEYWORD: shutdown
#
diff --git a/comms/atslog/files/patch-diagram_bars.php b/comms/atslog/files/patch-diagram_bars.php
new file mode 100644
index 000000000000..9abf2b21ee77
--- /dev/null
+++ b/comms/atslog/files/patch-diagram_bars.php
@@ -0,0 +1,26 @@
+--- www/diagram/diagram_bars_dur.php.orig Thu Jan 11 05:43:48 2007
++++ www/diagram/diagram_bars_dur.php Thu Jan 11 20:22:30 2007
+@@ -107,23 +107,7 @@
+ $prevDay=$mkday;
+ $prevDOfMonth=$DayOfMonth;
+ }
+- $Columns = sizeof($allDays);
+- if($Columns > 30){
+- $delta = ceil($Columns/30);
+
+- $giveDelta=0;
+- while (list($key, $val) = each($allDays)) {
+- if($giveDelta == $key){
+- $giveDelta+=$delta;
+- }else{
+- $allDays[$key][0]='';
+- }
+- if($val[1] > $maxValue){
+- $maxValue=$val[1];
+- }
+- }
+- }
+-
+ //if($debug) print_r($allDays);
+ //if($debug) print("I".$maxValue."I");
+
diff --git a/comms/atslog/files/patch-diagram_bars_dur.php b/comms/atslog/files/patch-diagram_bars_dur.php
new file mode 100644
index 000000000000..44574fbadf82
--- /dev/null
+++ b/comms/atslog/files/patch-diagram_bars_dur.php
@@ -0,0 +1,26 @@
+--- www/diagram/diagram_bars.php.orig Thu Jan 11 05:43:48 2007
++++ www/diagram/diagram_bars.php Thu Jan 11 20:22:30 2007
+@@ -105,23 +105,6 @@
+ $prevDOfMonth=$DayOfMonth;
+ }
+
+- $Columns = sizeof($allDays);
+- if($Columns > 30){
+- $delta = ceil($Columns/30);
+-
+- $giveDelta=0;
+- while (list($key, $val) = each($allDays)) {
+- if($giveDelta == $key){
+- $giveDelta+=$delta;
+- }else{
+- $allDays[$key][0]='';
+- }
+- if($val[1] > $maxValue){
+- $maxValue=$val[1];
+- }
+- }
+- }
+-
+ if($debug) print_r($allDays);
+ if($debug) print("I".$maxValue."I");
+
diff --git a/comms/atslog/files/patch-include__atslogmaster.in b/comms/atslog/files/patch-include__atslogmaster.in
deleted file mode 100644
index 8e0a13a458af..000000000000
--- a/comms/atslog/files/patch-include__atslogmaster.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./include/atslogmaster.in.orig Sat Dec 30 06:04:56 2006
-+++ ./include/atslogmaster.in Sat Dec 30 06:05:08 2006
-@@ -45,6 +45,8 @@
- ;;
- esac
-
-+mkdir -p $logdir
-+
- # Проверим, используется tcp порт, или порт в /dev/
- TCPPORT=$(expr $port : ".*tcp:.*\$")
- if [ $TCPPORT = 0 ];then
diff --git a/comms/atslog/files/pkg-message.in b/comms/atslog/files/pkg-message.in
index 731dfde19105..88da694e1af6 100644
--- a/comms/atslog/files/pkg-message.in
+++ b/comms/atslog/files/pkg-message.in
@@ -17,4 +17,4 @@ that you add something like the following to httpd.conf:
Allow from 127.0.0.1 .example.com
</Directory>
-and then edit %%PREFIX%%/www/atslog/include/set/conf.inc.php
+and then edit %%PREFIX%%/www/atslog/include/config.inc.php
diff --git a/comms/atslog/pkg-descr b/comms/atslog/pkg-descr
index 9318a2dc7b28..3aec0630e1bb 100644
--- a/comms/atslog/pkg-descr
+++ b/comms/atslog/pkg-descr
@@ -3,4 +3,4 @@ viewing and analyzing calls for various types of PBX (Private Branch eXchange)
models. At present, the program operates successfully with Panasonic, Samsung,
Hybrex, Siemens, LG, and Alcatel PBX models.
-WWW: http://www.atslog.dp.ua/en/about/
+WWW: http://www.atslog.com/en/about/
diff --git a/comms/atslog/pkg-plist b/comms/atslog/pkg-plist
index 4a477f5fc5c0..3c6792cf7fe6 100644
--- a/comms/atslog/pkg-plist
+++ b/comms/atslog/pkg-plist
@@ -1,5 +1,5 @@
@unexec if cmp -s %D/etc/atslog.conf %D/etc/atslog.conf.default; then rm -f %D/etc/atslog.conf; fi
-%%WWW%%@unexec if cmp -s %D/www/atslog/include/set/conf.inc.php %D/www/atslog/include/set/conf.inc.default.php; then rm -f %D/www/atslog/include/set/conf.inc.php; fi
+%%WWW%%@unexec if cmp -s %D/www/atslog/include/config.inc.php %D/www/atslog/include/config.inc.php.default; then rm -f %D/www/atslog/include/config.inc.php; fi
bin/atslogcleardb.pl
bin/atslogd
bin/atslogdaily
@@ -22,16 +22,17 @@ libexec/atslog/kx-td1232-ru.lib
libexec/atslog/kx-td1232.lib
libexec/atslog/kx-td500.lib
libexec/atslog/kx-td816ru.lib
+libexec/atslog/kx-tda100.lib
libexec/atslog/ldk-300.lib
libexec/atslog/nx-820.lib
+libexec/atslog/officeserv-7200.lib
libexec/atslog/skp-816.lib
%%DATADIR%%/lang/en_US
%%DATADIR%%/lang/ru_RU.CP1251
%%DATADIR%%/lang/ru_RU.KOI8-R
%%DATADIR%%/lang/ru_RU.UTF-8
+%%DATADIR%%/sql/createsqltables.Pg.sql
%%DATADIR%%/sql/createsqltables.mysql.sql
-%%DATADIR%%/sql/createsqltables.pgsql.sql
-%%DATADIR%%/sql/createuser.pgsql.sql
%%DATADIR%%/sql/data.sql
%%DATADIR%%/sql/install-sql.pl
%%EXAMPLESDIR%%/textlogs/Alcatel 4200.txt
@@ -74,12 +75,16 @@ libexec/atslog/skp-816.lib
%%EXAMPLESDIR%%/textlogs/Panasonic KX-TD500 Type C.txt
%%EXAMPLESDIR%%/textlogs/Panasonic KX-TD500 Type D.txt
%%EXAMPLESDIR%%/textlogs/Panasonic KX-TD816RU.txt
+%%EXAMPLESDIR%%/textlogs/Panasonic KX-TDA100 A.txt
+%%EXAMPLESDIR%%/textlogs/Panasonic KX-TDA100 B.txt
+%%EXAMPLESDIR%%/textlogs/Panasonic KX-TDA100 C.txt
%%EXAMPLESDIR%%/textlogs/Panasonic KX-TEM824.txt
%%EXAMPLESDIR%%/textlogs/Samsung DCS Compact II.txt
%%EXAMPLESDIR%%/textlogs/Samsung DCS.txt
%%EXAMPLESDIR%%/textlogs/Samsung NX-1232.txt
%%EXAMPLESDIR%%/textlogs/Samsung NX-820(variant 1).txt
%%EXAMPLESDIR%%/textlogs/Samsung NX-820(variant 2).txt
+%%EXAMPLESDIR%%/textlogs/Samsung OfficeServ 7200.txt
%%EXAMPLESDIR%%/textlogs/Samsung SKP 56_120.txt
%%EXAMPLESDIR%%/textlogs/Samsung SKP-36HX.txt
%%EXAMPLESDIR%%/textlogs/Samsung SKP-816.txt
@@ -208,8 +213,8 @@ libexec/atslog/skp-816.lib
%%WWW%%www/atslog/include/set/printfooter.html
%%WWW%%www/atslog/include/set/menuTable.html
%%WWW%%www/atslog/include/set/footer.html
-%%WWW%%www/atslog/include/set/conf.inc.default.php
-%%WWW%%@exec [ -f %B/conf.inc.php ] || cp %B/%f %B/conf.inc.php
+%%WWW%%www/atslog/include/config.inc.php.default
+%%WWW%%@exec [ -f %B/config.inc.php ] || cp %B/%f %B/config.inc.php
%%WWW%%www/atslog/include/set/functions.js
%%WWW%%www/atslog/include/set/commonData.php
%%WWW%%www/atslog/include/set/.htaccess