aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-07-05 09:09:18 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-07-05 12:23:28 +0000
commitd8d6d6af0c7555b0bb2af494ba2b74c92bb7db92 (patch)
tree9c81910cc3c9d5bc340c1aadcb6e6c0daa5d6904
parent6177ada8583c3bc834b7dc6c5fb418d4e8728d0b (diff)
downloadports-d8d6d6af0c7555b0bb2af494ba2b74c92bb7db92.tar.gz
ports-d8d6d6af0c7555b0bb2af494ba2b74c92bb7db92.zip
graphics/poppler: make boost a build-time dependency
Poppler uses Boost small-vectors for efficiency (over std::vector) when the Splash renderer is enabled. Small-vectors are header-only, so there is no need to depend on the whole boost-libs at runtime. The PR asks to drop Boost entirely; we're not going to do that, but as a build-dep it avoids installed-size bloat. Bump PORTREVISION also of related ports to make sure they are rebuilt; don't need to re-do all consumers because Boost was not linked anyway. PR: 256821
-rw-r--r--graphics/poppler-glib/Makefile2
-rw-r--r--graphics/poppler-qt5/Makefile2
-rw-r--r--graphics/poppler-utils/Makefile2
-rw-r--r--graphics/poppler/Makefile5
4 files changed, 6 insertions, 5 deletions
diff --git a/graphics/poppler-glib/Makefile b/graphics/poppler-glib/Makefile
index 639d50d648ea..3a0237c47bfc 100644
--- a/graphics/poppler-glib/Makefile
+++ b/graphics/poppler-glib/Makefile
@@ -1,6 +1,6 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
-PORTREVISION= 0
+PORTREVISION= 1
COMMENT= GLib bindings to poppler
diff --git a/graphics/poppler-qt5/Makefile b/graphics/poppler-qt5/Makefile
index 5817eaf3853e..16d3aeb64d90 100644
--- a/graphics/poppler-qt5/Makefile
+++ b/graphics/poppler-qt5/Makefile
@@ -1,4 +1,4 @@
-PORTREVISION= 0
+PORTREVISION= 1
PKGNAMESUFFIX= -qt5
COMMENT= Qt 5 bindings to poppler
diff --git a/graphics/poppler-utils/Makefile b/graphics/poppler-utils/Makefile
index e762bf7224b8..e9579593b9b2 100644
--- a/graphics/poppler-utils/Makefile
+++ b/graphics/poppler-utils/Makefile
@@ -1,6 +1,6 @@
# Created by: Michael Nottebrock <lofi@FreeBSD.org>
-PORTREVISION= 0
+PORTREVISION= 1
COMMENT= Poppler's xpdf-workalike command line utilities # '
diff --git a/graphics/poppler/Makefile b/graphics/poppler/Makefile
index bfa291c0f17a..bbb54dad755f 100644
--- a/graphics/poppler/Makefile
+++ b/graphics/poppler/Makefile
@@ -2,6 +2,7 @@
PORTNAME= poppler
DISTVERSION= 21.06.1
+PORTREVISION= 1
CATEGORIES= graphics print
MASTER_SITES= https://poppler.freedesktop.org/
@@ -17,8 +18,8 @@ LIB_DEPENDS= libnspr4.so:devel/nspr \
libtiff.so:graphics/tiff \
libfreetype.so:print/freetype2 \
libnss3.so:security/nss \
- libfontconfig.so:x11-fonts/fontconfig \
- libboost_system.so:devel/boost-libs
+ libfontconfig.so:x11-fonts/fontconfig
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/container/small_vector.hpp:devel/boost-libs
RUN_DEPENDS= poppler-data>0:graphics/poppler-data
USES= compiler:c++11-lang cpe cmake:insource gnome jpeg libtool \