aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-01 12:29:47 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-01 12:29:47 +0000
commitd8ddbeefc3a6ed41c0283e129c33139139a8116d (patch)
tree2fbf1a0d895dc5d3649578f05f1e71dd5df32432
parentb83b882d467f5be4245203fab737aa8bdca5619f (diff)
downloadports-d8ddbeefc3a6ed41c0283e129c33139139a8116d.tar.gz
ports-d8ddbeefc3a6ed41c0283e129c33139139a8116d.zip
Add p5-Text-Delimited 2.00, module for parsing delimited text files.
PR: ports/101158 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=169331
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-Delimited/Makefile28
-rw-r--r--textproc/p5-Text-Delimited/distinfo3
-rw-r--r--textproc/p5-Text-Delimited/pkg-descr10
-rw-r--r--textproc/p5-Text-Delimited/pkg-plist6
5 files changed, 48 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 4741a69b85ad..34c742492a45 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -474,6 +474,7 @@
SUBDIR += p5-Text-Chomp
SUBDIR += p5-Text-Context-EitherSide
SUBDIR += p5-Text-Decorator
+ SUBDIR += p5-Text-Delimited
SUBDIR += p5-Text-Diff
SUBDIR += p5-Text-Diff-HTML
SUBDIR += p5-Text-Diff3
diff --git a/textproc/p5-Text-Delimited/Makefile b/textproc/p5-Text-Delimited/Makefile
new file mode 100644
index 000000000000..ab4c2b7a5b91
--- /dev/null
+++ b/textproc/p5-Text-Delimited/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Text-Delimited
+# Date created: 2006-08-01
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Delimited
+PORTVERSION= 2.00
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Module for parsing delimited text files
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::Delimited.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6.0 or newer, install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Text-Delimited/distinfo b/textproc/p5-Text-Delimited/distinfo
new file mode 100644
index 000000000000..bfa87ba5e193
--- /dev/null
+++ b/textproc/p5-Text-Delimited/distinfo
@@ -0,0 +1,3 @@
+MD5 (Text-Delimited-2.00.tar.gz) = 88469522218212a8b5815f8252fa99ce
+SHA256 (Text-Delimited-2.00.tar.gz) = f0ce4f6383bda240d906e96932b748a3d361dca62cd4cbf5798a436a6b1b91cb
+SIZE (Text-Delimited-2.00.tar.gz) = 5410
diff --git a/textproc/p5-Text-Delimited/pkg-descr b/textproc/p5-Text-Delimited/pkg-descr
new file mode 100644
index 000000000000..60697951f4d4
--- /dev/null
+++ b/textproc/p5-Text-Delimited/pkg-descr
@@ -0,0 +1,10 @@
+Text::Delimited provides a programattical interface to data stored in
+delimited text files. It is dependant upon the first row of the text
+file containing header information for each corresponding "column" in
+the remainder of the file.
+
+After instancing, for each call to Read the next row's data is
+returned as a hash reference. The individual elements are keyed by
+their corresonding column headings.
+
+WWW: http://search.cpan.org/dist/Text-Delimited/
diff --git a/textproc/p5-Text-Delimited/pkg-plist b/textproc/p5-Text-Delimited/pkg-plist
new file mode 100644
index 000000000000..bba79f60549e
--- /dev/null
+++ b/textproc/p5-Text-Delimited/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Delimited/.packlist
+%%SITE_PERL%%/Text/Delimited.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Delimited
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text
+@dirrmtry %%SITE_PERL%%/Text