aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-06-02 05:26:54 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-06-02 05:28:46 +0000
commitd9241604bcd87c961d2b90e76c01e8b26fdd6e2c (patch)
treecf261dc224ebb8e5bc81dc09d62f6ea2c5b3808d
parentb76cfcc0965ae997390fcf6731e7500a15bcfac7 (diff)
downloadports-d9241604bcd87c961d2b90e76c01e8b26fdd6e2c.tar.gz
ports-d9241604bcd87c961d2b90e76c01e8b26fdd6e2c.zip
lang/solidity: Unbreak
* boost-1.77.0 related compilation failure is fixed * missing STL header failure if fixed PR: 246106 Approved by: portmgr (unbreak)
-rw-r--r--lang/solidity/Makefile5
-rw-r--r--lang/solidity/distinfo4
-rw-r--r--lang/solidity/files/patch-tools_solidityUpgrade_SourceUpgrade.cpp13
3 files changed, 19 insertions, 3 deletions
diff --git a/lang/solidity/Makefile b/lang/solidity/Makefile
index a53e7676869b..a34b27306990 100644
--- a/lang/solidity/Makefile
+++ b/lang/solidity/Makefile
@@ -6,6 +6,9 @@ CATEGORIES= lang
MASTER_SITES= https://github.com/ethereum/solidity/releases/download/v${PORTVERSION}/
DISTNAME= ${PORTNAME}_${PORTVERSION}
+PATCH_SITES= https://github.com/ethereum/solidity/commit/
+PATCHFILES= 026e26af998c10ca4e39ab6b1b8e64dbc2fdd910.patch:-p1 # https://github.com/ethereum/solidity/pull/13090
+
MAINTAINER= ale@FreeBSD.org
COMMENT= Solidity Contract-Oriented Programming Language
@@ -14,8 +17,6 @@ LICENSE= GPLv3
NOT_FOR_ARCHS= powerpc powerpc64 powerpcspe sparc64
NOT_FOR_ARCHS_REASON= solidity currently does not support big endian systems
-BROKEN= error: implicit conversion loses integer precision: 'typename std::enable_if<number_category<cpp_int_backend<0, 0, boost::multiprecision::signed_magnitude, boost::multiprecision::unchecked, allocator<unsigned long long>>>::value == number_kind_integer, std::size_t>::type' (aka 'unsigned long') to 'unsigned int'
-
BUILD_DEPENDS= boost-libs>=0:devel/boost-libs \
libfmt>=0:devel/libfmt \
range-v3>=0:devel/range-v3
diff --git a/lang/solidity/distinfo b/lang/solidity/distinfo
index 64d2bfcc474e..a2d79b177fe1 100644
--- a/lang/solidity/distinfo
+++ b/lang/solidity/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1652802997
+TIMESTAMP = 1654144304
SHA256 (solidity_0.8.14.tar.gz) = 7ccdf20c889206103d0a48fe10b1c3f1f21269070861e80382f7ede8785e61d4
SIZE (solidity_0.8.14.tar.gz) = 3214611
+SHA256 (026e26af998c10ca4e39ab6b1b8e64dbc2fdd910.patch) = fe2ecb05f607e19cd6795c135e046a0414b32d6b12eee745c5a5d05fe38ce7c9
+SIZE (026e26af998c10ca4e39ab6b1b8e64dbc2fdd910.patch) = 2189
diff --git a/lang/solidity/files/patch-tools_solidityUpgrade_SourceUpgrade.cpp b/lang/solidity/files/patch-tools_solidityUpgrade_SourceUpgrade.cpp
new file mode 100644
index 000000000000..59e040bce985
--- /dev/null
+++ b/lang/solidity/files/patch-tools_solidityUpgrade_SourceUpgrade.cpp
@@ -0,0 +1,13 @@
+- workaround for https://github.com/ethereum/solidity/issues/13091
+
+--- tools/solidityUpgrade/SourceUpgrade.cpp.orig 2022-06-02 02:23:26 UTC
++++ tools/solidityUpgrade/SourceUpgrade.cpp
+@@ -34,6 +34,8 @@
+ #include <unistd.h>
+ #endif
+
++#include <fstream>
++
+
+ namespace po = boost::program_options;
+ namespace fs = boost::filesystem;