aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-04-10 07:56:58 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-04-10 08:56:49 +0000
commitda134084ee1ea2d89e9c5c03b14eb5e64e9cfa14 (patch)
tree92640bd0af721f59ca3e0b84267c64a8fa4b4c72
parenta059c05e76ec507267a3460d86dc193ead8f6c11 (diff)
downloadports-da134084ee1ea2d89e9c5c03b14eb5e64e9cfa14.tar.gz
ports-da134084ee1ea2d89e9c5c03b14eb5e64e9cfa14.zip
x11-wm/hyprland: switch to upstream commit message fallback
#ifndef GIT_COMMIT_MESSAGE #define GIT_COMMIT_MESSAGE "?" #endif
-rw-r--r--x11-wm/hyprland/Makefile3
-rw-r--r--x11/hyprpaper/Makefile3
-rw-r--r--x11/hyprpicker/Makefile3
3 files changed, 6 insertions, 3 deletions
diff --git a/x11-wm/hyprland/Makefile b/x11-wm/hyprland/Makefile
index 35d3412a07b8..68523208dd5b 100644
--- a/x11-wm/hyprland/Makefile
+++ b/x11-wm/hyprland/Makefile
@@ -1,6 +1,7 @@
PORTNAME= hyprland
DISTVERSIONPREFIX= v
DISTVERSION= 0.24.1
+PORTREVISION= 1
CATEGORIES= x11-wm wayland
MAINTAINER= jbeich@FreeBSD.org
@@ -40,7 +41,7 @@ post-patch:
# Extract (snapshot) version from the port instead of meson.build
@${REINPLACE_CMD} -i .nogit -e "/GIT_BRANCH/s/run_command.*/'main'/" \
-e "/GIT_COMMIT_HASH/s/run_command.*/'${DISTVERSIONFULL}'/" \
- -e "/GIT_COMMIT_MESSAGE/s/run_command.*/'<unknown>'/" \
+ -e "/GIT_COMMIT_MESSAGE/s/run_command.*/'?'/" \
-e "/GIT_DIRTY/s/run_command.*/'portbld'/" \
-e "/version.*jq/s/run_command.*/'${DISTVERSIONFULL}',/" \
${WRKSRC}/meson.build
diff --git a/x11/hyprpaper/Makefile b/x11/hyprpaper/Makefile
index 893f3488beee..91e001535485 100644
--- a/x11/hyprpaper/Makefile
+++ b/x11/hyprpaper/Makefile
@@ -1,6 +1,7 @@
PORTNAME= hyprpaper
DISTVERSIONPREFIX= v
DISTVERSION= 0.1.0
+PORTREVISION= 1
CATEGORIES= x11 wayland
MAINTAINER= jbeich@FreeBSD.org
@@ -28,7 +29,7 @@ post-patch:
@${REINPLACE_CMD} -i .nogit -e '/Get git info/,/^#$$/d' \
-e 's/$${GIT_BRANCH}/main/' \
-e 's/$${GIT_COMMIT_HASH}/${GH_TAGNAME}/' \
- -e 's/$${GIT_COMMIT_MESSAGE}/<unknown>/' \
+ -e 's/$${GIT_COMMIT_MESSAGE}/?/' \
-e 's/$${GIT_DIRTY}/portbld/' \
${WRKSRC}/CMakeLists.txt
# https://clang.llvm.org/cxx_status.html#cxx23
diff --git a/x11/hyprpicker/Makefile b/x11/hyprpicker/Makefile
index 555a670a0391..181e78316ebb 100644
--- a/x11/hyprpicker/Makefile
+++ b/x11/hyprpicker/Makefile
@@ -1,6 +1,7 @@
PORTNAME= hyprpicker
DISTVERSIONPREFIX= v
DISTVERSION= 0.1.0
+PORTREVISION= 1
CATEGORIES= x11 wayland
MAINTAINER= jbeich@FreeBSD.org
@@ -32,7 +33,7 @@ post-patch:
@${REINPLACE_CMD} -i .nogit -e '/Get git info/,/^#$$/d' \
-e 's/$${GIT_BRANCH}/main/' \
-e 's/$${GIT_COMMIT_HASH}/${GH_TAGNAME}/' \
- -e 's/$${GIT_COMMIT_MESSAGE}/<unknown>/' \
+ -e 's/$${GIT_COMMIT_MESSAGE}/?/' \
-e 's/$${GIT_DIRTY}/portbld/' \
${WRKSRC}/CMakeLists.txt
# https://clang.llvm.org/cxx_status.html#cxx23