aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-14 10:54:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-14 10:54:10 +0000
commitda784807debbe51a4101e0306754ce27f09ac125 (patch)
tree1031fb9cf9bcbd5ba45dce9ac37a62d325305ebb
parentb5b1bc6d4b6c38457f928e654748dd56fe95bc15 (diff)
downloadports-da784807debbe51a4101e0306754ce27f09ac125.tar.gz
ports-da784807debbe51a4101e0306754ce27f09ac125.zip
wxMaxima is a wxWidgets GUI for the computer algebra system maxima.
Most of maxima functions are accessible through menus, some have dialogs. The input line has command history (up-key, down-key) and completion based on previous input (tab-key). wxMaxima provides 2d formated display of maxima output. PR: ports/83374 Submitted by: Nicola Vitale <nivit@email.it>
Notes
Notes: svn path=/head/; revision=139194
-rw-r--r--math/Makefile1
-rw-r--r--math/wxMaxima/Makefile26
-rw-r--r--math/wxMaxima/distinfo2
-rw-r--r--math/wxMaxima/pkg-descr9
-rw-r--r--math/wxMaxima/pkg-plist12
5 files changed, 50 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index df7038d1b7be..4cd839bb1cef 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -275,6 +275,7 @@
SUBDIR += wingz
SUBDIR += wingz3
SUBDIR += wmcalc
+ SUBDIR += wxMaxima
SUBDIR += xgfe
SUBDIR += xgobi
SUBDIR += xgraph
diff --git a/math/wxMaxima/Makefile b/math/wxMaxima/Makefile
new file mode 100644
index 000000000000..840e4f94e111
--- /dev/null
+++ b/math/wxMaxima/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: wxMaxima
+# Date created: 2005-07-12
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wxMaxima
+PORTVERSION= 0.6.1
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME:L}
+
+MAINTAINER= nivit@email.it
+COMMENT= A wxWidgets GUI for the computer algebra system maxima
+
+LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24 \
+ xml2.5:${PORTSDIR}/textproc/libxml2
+RUN_DEPENDS= maxima:${PORTSDIR}/math/maxima
+
+WXGTK_CONFIG?= ${X11BASE}/bin/wxgtk2-2.4-config
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-wx-config=${WXGTK_CONFIG} \
+ --program-prefix=
+
+.include <bsd.port.mk>
diff --git a/math/wxMaxima/distinfo b/math/wxMaxima/distinfo
new file mode 100644
index 000000000000..f1f1b09d2707
--- /dev/null
+++ b/math/wxMaxima/distinfo
@@ -0,0 +1,2 @@
+MD5 (wxMaxima-0.6.1.tar.gz) = 32f19a748e38f8028b4d4b0243eba24e
+SIZE (wxMaxima-0.6.1.tar.gz) = 1000110
diff --git a/math/wxMaxima/pkg-descr b/math/wxMaxima/pkg-descr
new file mode 100644
index 000000000000..998d3b71cc80
--- /dev/null
+++ b/math/wxMaxima/pkg-descr
@@ -0,0 +1,9 @@
+wxMaxima is a wxWidgets GUI for the computer algebra system maxima.
+
+Most of maxima functions are accessible through menus, some have
+dialogs. The input line has command history (up-key, down-key) and
+completion based on previous input (tab-key).
+wxMaxima provides 2d formated display of maxima output.
+
+Author: Andrej Vodopivec <andrejv@users.sourceforge.net>
+WWW: http://wxmaxima.sourceforge.net/
diff --git a/math/wxMaxima/pkg-plist b/math/wxMaxima/pkg-plist
new file mode 100644
index 000000000000..5848b742997e
--- /dev/null
+++ b/math/wxMaxima/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+bin/wxmaxima
+share/locale/es/LC_MESSAGES/wxMaxima.mo
+share/locale/fr/LC_MESSAGES/wxMaxima.mo
+share/locale/it/LC_MESSAGES/wxMaxima.mo
+%%DATADIR%%/COPYING
+%%DATADIR%%/README
+%%DATADIR%%/docs.zip
+%%DATADIR%%/intro.zip
+%%DATADIR%%/tips.txt
+%%DATADIR%%/wxmathml.lisp
+@dirrm %%DATADIR%%