aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-07-04 22:01:15 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-07-04 22:01:15 +0000
commitda78f814ff5f377315ed8e4cf565befdefe70b88 (patch)
tree837782d49e51d79f6fd5d96b80940ebcc30ccdb8
parent7f67d08d3a1539e0ac5bca17f7c2acde9d9add9b (diff)
downloadports-da78f814ff5f377315ed8e4cf565befdefe70b88.tar.gz
ports-da78f814ff5f377315ed8e4cf565befdefe70b88.zip
Fix typo in USE_BZIP2 and really use bzipped tarball.
Clean-up and unify with upcoming lyx-2.0 Approved by: Raphael Kubo da Costa (maintainer) via irc
Notes
Notes: svn path=/head/; revision=277070
-rw-r--r--print/lyx16/Makefile16
-rw-r--r--print/lyx16/distinfo4
-rw-r--r--print/lyx16/pkg-message2
3 files changed, 12 insertions, 10 deletions
diff --git a/print/lyx16/Makefile b/print/lyx16/Makefile
index 0e0acda58be8..121237f4d22e 100644
--- a/print/lyx16/Makefile
+++ b/print/lyx16/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= lyx
-PORTVERSION= ${MAJOR_VERSION}.10
+PORTVERSION= ${MAJOR_VERSION}.${MINOR_VERSION}
+PORTREVISION= 1
CATEGORIES= print editors
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/${MAJOR_VERSION}.x/ \
http://www-ftp.lip6.fr/ftp/pub/lyx/stable/${MAJOR_VERSION}.x/ \
@@ -18,21 +19,24 @@ MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/${MAJOR_VERSION}.x/ \
MAINTAINER= kubito@gmail.com
COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG) (stable)
-LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost-libs
-
LICENSE= GPLv2
-CONFLICTS= lyx-1.4* lyx-devel-*
+LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost-libs
+
+LATEST_LINK= lyx16
+CONFLICTS= lyx-1.4* lyx-devel-* lyx-2*
MAJOR_VERSION= 1.6
+MINOR_VERSION= 10
-USE_BZIP= yes
+USE_BZIP2= yes
USE_GMAKE= yes
USE_QT_VER= 4
QT_COMPONENTS= gui moc_build uic_build rcc_build
USE_PYTHON= yes
USE_PERL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
+CPPFLAGS= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-frontend=qt4 \
--without-included-boost \
--without-included-gettext \
diff --git a/print/lyx16/distinfo b/print/lyx16/distinfo
index 2cb1a5bbdcf2..687e510fc761 100644
--- a/print/lyx16/distinfo
+++ b/print/lyx16/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lyx-1.6.10.tar.gz) = 9b4b59968f3313b8d74ed387900f795183dd726a9bee76c657302d63dc54471f
-SIZE (lyx-1.6.10.tar.gz) = 16366547
+SHA256 (lyx-1.6.10.tar.bz2) = dcfb6fc0f6880e706d45ea16459ed2206265179f3882b4685e4955c18adaf569
+SIZE (lyx-1.6.10.tar.bz2) = 12559454
diff --git a/print/lyx16/pkg-message b/print/lyx16/pkg-message
index 5aaf2c679960..f9b07c285ad4 100644
--- a/print/lyx16/pkg-message
+++ b/print/lyx16/pkg-message
@@ -1,6 +1,4 @@
For lyx to work you need to install some kind of TeX software.
-
The easiest way is probably to install print/teTeX port which is quite old.
-
A newer alternative could be TeXLive:
http://code.google.com/p/freebsd-texlive/