aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2011-05-14 16:34:09 +0000
committerGabor Pali <pgj@FreeBSD.org>2011-05-14 16:34:09 +0000
commitdaa312f57335784a7018bf88a4a780a9df358fff (patch)
treebce52cbabbd2acdc8d5f0a20856c2012c47098c3
parent1bba1cea45144d0c2fd8108d783f8e067a437a15 (diff)
downloadports-daa312f57335784a7018bf88a4a780a9df358fff.tar.gz
ports-daa312f57335784a7018bf88a4a780a9df358fff.zip
The 'cabal' command-line program simplifies the process of managing Haskell
software by automating the fetching, configuration, compilation and installation of Haskell libraries and programs. WWW: http://www.haskell.org/cabal/ Obtained from: FreeBSD Haskell
Notes
Notes: svn path=/head/; revision=274111
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-cabal-install/Makefile24
-rw-r--r--devel/hs-cabal-install/distinfo2
-rw-r--r--devel/hs-cabal-install/pkg-descr5
-rw-r--r--lang/ghc/bsd.hackage.mk1
5 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 61be54ca0cf9..e3a77a29f50d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -577,6 +577,7 @@
SUBDIR += hs-bsd-sysctl
SUBDIR += hs-cmdargs
SUBDIR += hs-c2hs
+ SUBDIR += hs-cabal-install
SUBDIR += hs-checkers
SUBDIR += hs-convertible
SUBDIR += hs-cpphs
diff --git a/devel/hs-cabal-install/Makefile b/devel/hs-cabal-install/Makefile
new file mode 100644
index 000000000000..75877182861b
--- /dev/null
+++ b/devel/hs-cabal-install/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: hs-cabal-install
+# Date created: 2010-08-17
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cabal-install
+PORTVERSION= 0.10.2
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= The command-line interface for Cabal and Hackage
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= network>=1 HTTP>=4000.0.2 zlib>=0.4
+
+STANDALONE= yes
+EXECUTABLE= cabal
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-cabal-install/distinfo b/devel/hs-cabal-install/distinfo
new file mode 100644
index 000000000000..a0de39e02e5f
--- /dev/null
+++ b/devel/hs-cabal-install/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/cabal-install-0.10.2.tar.gz) = 6357c8b984d193a30bb2a05e03dbd551650a0ddea17f7d1033e6564f5b7ff515
+SIZE (cabal/cabal-install-0.10.2.tar.gz) = 150699
diff --git a/devel/hs-cabal-install/pkg-descr b/devel/hs-cabal-install/pkg-descr
new file mode 100644
index 000000000000..fa7ddc29711f
--- /dev/null
+++ b/devel/hs-cabal-install/pkg-descr
@@ -0,0 +1,5 @@
+The 'cabal' command-line program simplifies the process of managing Haskell
+software by automating the fetching, configuration, compilation and
+installation of Haskell libraries and programs.
+
+WWW: http://www.haskell.org/cabal/
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 696fa0d066c4..af44ef1e12d7 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -26,6 +26,7 @@ Boolean_port= devel/hs-Boolean
brainfuck_port= lang/hs-brainfuck # executable
bsd-sysctl_port= devel/hs-bsd-sysctl
c2hs_port= devel/hs-c2hs # executable
+cabal-install_port= devel/hs-cabal-install # executable
cairo_port= graphics/hs-cairo
category-extras_port= math/hs-category-extras # BROKEN
cgi_port= www/hs-cgi