aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2022-03-11 16:48:57 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2022-03-11 16:48:57 +0000
commitdac50f111aa7620293289b44785c820ca62dc257 (patch)
tree384067b2f6acdd2ddc275a61abcfd3c8d4d1d603
parenta6fdb60e3b93f59f8f2fced4684183d8e0015037 (diff)
downloadports-dac50f111aa7620293289b44785c820ca62dc257.tar.gz
ports-dac50f111aa7620293289b44785c820ca62dc257.zip
science/kst2: Update to 2022.02.16 snapshot
- Drop upstreamed patches.
-rw-r--r--science/kst2/Makefile7
-rw-r--r--science/kst2/distinfo6
-rw-r--r--science/kst2/files/patch-CMakeLists.txt13
-rw-r--r--science/kst2/files/patch-src_datasources_hdf5_hdf5.cpp14
-rw-r--r--science/kst2/files/patch-src_widgets_gradienteditor.h10
5 files changed, 6 insertions, 44 deletions
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index 16b6c48a3c5e..65850e2294f1 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -2,7 +2,6 @@
PORTNAME= kst
DISTVERSION= ${KST_VERSION}.${KST_DATE}
-PORTREVISION= 4
CATEGORIES= science
MAINTAINER= makc@FreeBSD.org
@@ -24,9 +23,9 @@ USE_QT= concurrent core gui network printsupport svg widgets xml \
USE_LDCONFIG= yes
KST_VERSION= 2.0.8
-KST_DATE= 20210124
-KST_COMMIT= 38eddb53
-KDE_INVENT= 38eddb5322a1d557f9d86ea95d456d76272941e3 graphics kst-plot
+KST_DATE= 20220216
+KST_COMMIT= 40cdf2d3
+KDE_INVENT= 40cdf2d397e4277ee7226188ef89ae3e0f12d884 graphics kst-plot
CMAKE_ARGS= -Dkst_install_prefix=${PREFIX} \
-Dkst_pch=off \
diff --git a/science/kst2/distinfo b/science/kst2/distinfo
index 51c87cf0f0d4..00eb7a0ce55e 100644
--- a/science/kst2/distinfo
+++ b/science/kst2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620381589
-SHA256 (graphics-kst-plot-38eddb5322a1d557f9d86ea95d456d76272941e3_GL0.tar.gz) = 0ffcb24c0aaa416ba8b879e4576ab35e23adde780f7d8a64ceffb27fe8f33f57
-SIZE (graphics-kst-plot-38eddb5322a1d557f9d86ea95d456d76272941e3_GL0.tar.gz) = 18792017
+TIMESTAMP = 1646996686
+SHA256 (graphics-kst-plot-40cdf2d397e4277ee7226188ef89ae3e0f12d884_GL0.tar.gz) = cf6c0b33d915906593cd7613246f4679dcdefecb7e50b67812eeb57866e37ab8
+SIZE (graphics-kst-plot-40cdf2d397e4277ee7226188ef89ae3e0f12d884_GL0.tar.gz) = 18794059
diff --git a/science/kst2/files/patch-CMakeLists.txt b/science/kst2/files/patch-CMakeLists.txt
index 324cf2ae729f..a5a4d70c7be2 100644
--- a/science/kst2/files/patch-CMakeLists.txt
+++ b/science/kst2/files/patch-CMakeLists.txt
@@ -13,19 +13,6 @@
if(kst_sanitize)
-@@ -116,10 +110,10 @@ elseif(kst_3rdparty_download)
- elseif(GCC_VERSION VERSION_EQUAL 4.7 OR GCC_VERSION VERSION_GREATER 4.7)
- set(ver 4.7)
- set(md5 de6e8dbab1bb17eee6057941fddc93e3)
-- else(GCC_VERSION VERSION_EQUAL 4.6 OR GCC_VERSION VERSION_GREATER 4.6)
-+ elseif(GCC_VERSION VERSION_EQUAL 4.6 OR GCC_VERSION VERSION_GREATER 4.6)
- set(ver 4.6)
- set(md5 70d8670af9c21eb8fb466654c95d8e4d)
-- else(GCC_VERSION VERSION_GREATER 4.4)
-+ elseif(GCC_VERSION VERSION_GREATER 4.4)
- set(ver 4.4)
- set(md5 999248fb40a44543af4dd4cd1be0ceeb)
- else()
@@ -240,11 +234,6 @@ message(STATUS)
# React on options
diff --git a/science/kst2/files/patch-src_datasources_hdf5_hdf5.cpp b/science/kst2/files/patch-src_datasources_hdf5_hdf5.cpp
deleted file mode 100644
index 9cca34792f42..000000000000
--- a/science/kst2/files/patch-src_datasources_hdf5_hdf5.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/datasources/hdf5/hdf5.cpp.orig 2021-01-24 05:51:19 UTC
-+++ src/datasources/hdf5/hdf5.cpp
-@@ -308,7 +308,11 @@ herr_t HDF5Source::visitFunc(hid_t id, const char* nam
- return 0;
- }
-
-+#if H5_VERSION_GE(1,12,0)
-+ status = H5Oget_info_by_name(id, name, &infobuf, H5O_INFO_BASIC, H5P_DEFAULT);
-+#else
- status = H5Oget_info_by_name(id, name, &infobuf, H5P_DEFAULT);
-+#endif
- if(status == 0){
- if(infobuf.type == H5O_TYPE_DATASET){
- H5::DataSet dataset = h5Source->_hdfFile->openDataSet(name);
diff --git a/science/kst2/files/patch-src_widgets_gradienteditor.h b/science/kst2/files/patch-src_widgets_gradienteditor.h
deleted file mode 100644
index e4a0ff3e74d7..000000000000
--- a/science/kst2/files/patch-src_widgets_gradienteditor.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/widgets/gradienteditor.h.orig 2020-05-18 16:26:46 UTC
-+++ src/widgets/gradienteditor.h
-@@ -16,6 +16,7 @@
- #include <QHash>
- #include <QWidget>
- #include <QGradient>
-+#include <QPainterPath>
-
- #include "kstwidgets_export.h"
-