aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGoran Mekić <meka@tilda.center>2022-07-13 10:57:25 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2022-07-13 10:59:30 +0000
commitdac907230e47c184f6c2946a44a461b08d38d9d6 (patch)
treeb0ed227abfd49b36f861b5e6ba0c00b823264e00
parent57289e8654dc5744f004de1e699bb9ffa99216c8 (diff)
downloadports-dac907230e47c184f6c2946a44a461b08d38d9d6.tar.gz
ports-dac907230e47c184f6c2946a44a461b08d38d9d6.zip
sysutils/reggae: Update to 0.2.3
-rw-r--r--sysutils/reggae/Makefile4
-rw-r--r--sysutils/reggae/distinfo6
-rw-r--r--sysutils/reggae/files/reggae.in38
-rw-r--r--sysutils/reggae/pkg-plist12
4 files changed, 53 insertions, 7 deletions
diff --git a/sysutils/reggae/Makefile b/sysutils/reggae/Makefile
index 6d3f5429cfc8..ff4b03a5ba3e 100644
--- a/sysutils/reggae/Makefile
+++ b/sysutils/reggae/Makefile
@@ -1,5 +1,5 @@
PORTNAME= reggae
-PORTVERSION= 0.2.1
+DISTVERSION= 0.2.3
CATEGORIES= sysutils
MAINTAINER= meka@tilda.center
@@ -13,7 +13,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/cbsd:sysutils/cbsd \
USE_GITHUB= yes
GH_ACCOUNT= cbsd
-USE_RC_SUBR= reggae_pf
+USE_RC_SUBR= reggae reggae_pf
NO_ARCH= yes
diff --git a/sysutils/reggae/distinfo b/sysutils/reggae/distinfo
index cb7d4132f607..de995aadeda4 100644
--- a/sysutils/reggae/distinfo
+++ b/sysutils/reggae/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1644097601
-SHA256 (cbsd-reggae-0.2.1_GH0.tar.gz) = 1619d7b56fd582e841812379091860d0eae81b01381f493166be10a20340fc1b
-SIZE (cbsd-reggae-0.2.1_GH0.tar.gz) = 53257
+TIMESTAMP = 1657705855
+SHA256 (cbsd-reggae-0.2.3_GH0.tar.gz) = 10228858c7247c5ab14a9bec86dead6749bdbf0afb6984b8fd563d80c158ca65
+SIZE (cbsd-reggae-0.2.3_GH0.tar.gz) = 50216
diff --git a/sysutils/reggae/files/reggae.in b/sysutils/reggae/files/reggae.in
new file mode 100644
index 000000000000..9e071f123e41
--- /dev/null
+++ b/sysutils/reggae/files/reggae.in
@@ -0,0 +1,38 @@
+#!/bin/sh
+
+# PROVIDE: reggae
+# KEYWORD: shutdown
+
+. /etc/rc.subr
+
+name=reggae
+desc="reggae backend"
+rcvar=${name}_enable
+load_rc_config $name
+
+: ${reggae_enable:="NO"}
+: ${reggae_socket_dir:="/var/run/reggae"}
+
+pidfile="/var/run/${name}.pid"
+procname=/bin/sh
+start_precmd="${name}_prestart"
+start_cmd="${name}_start"
+
+
+reggae_prestart() {
+ install -d "${reggae_socket_dir}"
+}
+
+
+reggae_start() {
+ echo -n "Starting ${name} ... "
+ /usr/sbin/daemon -S %%PREFIX%%/bin/reggae service "${reggae_socket_dir}" "${pidfile}"
+ status=$?
+ if [ "${status}" = "0" ]; then
+ echo "done"
+ else
+ echo "failed!"
+ fi
+}
+
+run_rc_command $*
diff --git a/sysutils/reggae/pkg-plist b/sysutils/reggae/pkg-plist
index 3a3abdd30d8f..29a900ba03b3 100644
--- a/sysutils/reggae/pkg-plist
+++ b/sysutils/reggae/pkg-plist
@@ -35,7 +35,12 @@ man/man1/reggae.1.gz
%%DATADIR%%/cbsd-profile/skel/usr/home/provision/.rhosts
%%DATADIR%%/cbsd-profile/skel/usr/home/provision/.shrc
%%DATADIR%%/cbsd-profile/skel/usr/local/etc/sudoers
+%%DATADIR%%/cbsd-profile/system/clone-local.d/placeholder
+%%DATADIR%%/cbsd-profile/system/clone.d/placeholder
+%%DATADIR%%/cbsd-profile/system/create.d/placeholder
+%%DATADIR%%/cbsd-profile/system/facts.d/placeholder
%%DATADIR%%/cbsd-profile/system/facts.d/reggae_ip
+%%DATADIR%%/cbsd-profile/system/master_create.d/placeholder
%%DATADIR%%/cbsd-profile/system/master_poststart.d/placeholder
%%DATADIR%%/cbsd-profile/system/master_poststop.d/deregister.sh
%%DATADIR%%/cbsd-profile/system/master_poststop.d/placeholder
@@ -43,6 +48,7 @@ man/man1/reggae.1.gz
%%DATADIR%%/cbsd-profile/system/master_prestart.d/register.sh
%%DATADIR%%/cbsd-profile/system/master_prestop.d/placeholder
%%DATADIR%%/cbsd-profile/system/remove.d/placeholder
+%%DATADIR%%/cbsd-profile/system/rename.d/placeholder
%%DATADIR%%/cbsd-profile/system/start.d/placeholder
%%DATADIR%%/cbsd-profile/system/stop.d/placeholder
%%DATADIR%%/id_rsa
@@ -81,6 +87,7 @@ man/man1/reggae.1.gz
%%DATADIR%%/scripts/register.sh
%%DATADIR%%/scripts/salt-provision.sh
%%DATADIR%%/scripts/scp.sh
+%%DATADIR%%/scripts/service.sh
%%DATADIR%%/scripts/shell-provision.sh
%%DATADIR%%/scripts/ssh-ping.sh
%%DATADIR%%/scripts/ssh.sh
@@ -104,8 +111,6 @@ man/man1/reggae.1.gz
%%DATADIR%%/templates/cbsd-bhyve.conf.tpl
%%DATADIR%%/templates/cbsd-vnet.conf.tpl
%%DATADIR%%/templates/cbsd.conf.tpl
-%%DATADIR%%/templates/cbsd.zone
-%%DATADIR%%/templates/cbsd_reverse.zone
%%DATADIR%%/templates/cloud-devops.sh
%%DATADIR%%/templates/cloud-init/meta-data
%%DATADIR%%/templates/cloud-init/user-data
@@ -114,6 +119,7 @@ man/man1/reggae.1.gz
%%DATADIR%%/templates/dhcpcd.conf
%%DATADIR%%/templates/dhcpd-hook.sh
%%DATADIR%%/templates/dhcpd.conf
+%%DATADIR%%/templates/dhcpd6.conf
%%DATADIR%%/templates/export-ports.sh
%%DATADIR%%/templates/freebsd-update.conf
%%DATADIR%%/templates/gitignore
@@ -121,6 +127,7 @@ man/man1/reggae.1.gz
%%DATADIR%%/templates/initenv.conf
%%DATADIR%%/templates/install-packages.sh
%%DATADIR%%/templates/ip-by-mac.sh
+%%DATADIR%%/templates/linux.conf.tpl
%%DATADIR%%/templates/master.conf
%%DATADIR%%/templates/master.fstab
%%DATADIR%%/templates/mount-project.sh
@@ -131,6 +138,7 @@ man/man1/reggae.1.gz
%%DATADIR%%/templates/pkg.conf
%%DATADIR%%/templates/reggae-register.sh
%%DATADIR%%/templates/resolvconf.conf
+%%DATADIR%%/templates/rtadvd.conf
%%DATADIR%%/templates/rtsold
%%DATADIR%%/templates/setup-vm.sh
%%DATADIR%%/templates/sudoers