aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2022-04-20 09:18:45 +0000
committerAlex Dupre <ale@FreeBSD.org>2022-04-20 09:20:06 +0000
commitdadecc16117c75b151c6c9e65969aa94b731b644 (patch)
tree389d4c5b710fdb1b3ee8dbfd63ee30371b3d61e9
parent4444993c5322ea2165b8b35b01a4a76718362454 (diff)
downloadports-dadecc16117c75b151c6c9e65969aa94b731b644.tar.gz
ports-dadecc16117c75b151c6c9e65969aa94b731b644.zip
www/tomcat-native: update to 1.2.32 release
PR: 263254 Submitted by: Michael Osipov <michael.osipov@siemens.com>
-rw-r--r--www/tomcat-native/Makefile3
-rw-r--r--www/tomcat-native/distinfo6
-rw-r--r--www/tomcat-native/files/patch-include_ssl__private.h11
-rw-r--r--www/tomcat-native/files/patch-src_ssl.c46
4 files changed, 4 insertions, 62 deletions
diff --git a/www/tomcat-native/Makefile b/www/tomcat-native/Makefile
index ffb404e0362c..562c18b78be0 100644
--- a/www/tomcat-native/Makefile
+++ b/www/tomcat-native/Makefile
@@ -1,8 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
PORTNAME= tomcat-native
-PORTVERSION= 1.2.24
-PORTREVISION= 1
+PORTVERSION= 1.2.32
CATEGORIES= www java
MASTER_SITES= https://archive.apache.org/dist/tomcat/tomcat-connectors/native/${PORTVERSION}/source/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
diff --git a/www/tomcat-native/distinfo b/www/tomcat-native/distinfo
index edf066136e31..e5a9b5826ed7 100644
--- a/www/tomcat-native/distinfo
+++ b/www/tomcat-native/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588667024
-SHA256 (tomcat-native-1.2.24-src.tar.gz) = 037f52f9a345e766a7dde8361c55b3b69045928f9a8068a406612b603819e76c
-SIZE (tomcat-native-1.2.24-src.tar.gz) = 419572
+TIMESTAMP = 1650442475
+SHA256 (tomcat-native-1.2.32-src.tar.gz) = 805ca999267f07afe701a8a434d517dc0b7f4317c366560f43c0fbca593578bd
+SIZE (tomcat-native-1.2.32-src.tar.gz) = 429747
diff --git a/www/tomcat-native/files/patch-include_ssl__private.h b/www/tomcat-native/files/patch-include_ssl__private.h
deleted file mode 100644
index da019e097d03..000000000000
--- a/www/tomcat-native/files/patch-include_ssl__private.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/ssl_private.h.orig 2020-04-24 19:24:44 UTC
-+++ include/ssl_private.h
-@@ -241,7 +241,7 @@
- #define TLS_server_method SSLv23_server_method
- #endif /* OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER) */
-
--#if OPENSSL_VERSION_NUMBER >= 0x10101000L
-+#if OPENSSL_VERSION_NUMBER >= 0x10101000L && !defined(LIBRESSL_VERSION_NUMBER)
- #define HAVE_KEYLOG_CALLBACK
- #endif
-
diff --git a/www/tomcat-native/files/patch-src_ssl.c b/www/tomcat-native/files/patch-src_ssl.c
deleted file mode 100644
index 13c1e036beb5..000000000000
--- a/www/tomcat-native/files/patch-src_ssl.c
+++ /dev/null
@@ -1,46 +0,0 @@
---- src/ssl.c.orig 2020-04-24 19:24:44 UTC
-+++ src/ssl.c
-@@ -367,11 +367,6 @@ static apr_status_t ssl_init_cleanup(void *data)
- #endif
- free_dh_params();
-
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
-- /* Openssl v1.1+ handles all termination automatically. Do
-- * nothing in this case.
-- */
--#else
- /*
- * Try to kill the internals of the SSL library.
- */
-@@ -394,7 +389,6 @@ static apr_status_t ssl_init_cleanup(void *data)
- #if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- ERR_remove_thread_state(NULL);
- #endif
--#endif
-
- #ifdef HAVE_KEYLOG_CALLBACK
- if (key_log_file) {
-@@ -764,14 +758,7 @@ TCN_IMPLEMENT_CALL(jint, SSL, initialize)(TCN_STDARGS,
- TCN_FREE_CSTRING(engine);
- return (jint)APR_SUCCESS;
- }
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
-- /* Openssl v1.1+ handles all initialisation automatically, apart
-- * from hints as to how we want to use the library.
-- *
-- * We tell openssl we want to include engine support.
-- */
-- OPENSSL_init_ssl(OPENSSL_INIT_ENGINE_ALL_BUILTIN, NULL);
--#else
-+
- /* We must register the library in full, to ensure our configuration
- * code can successfully test the SSL environment.
- */
-@@ -785,6 +772,7 @@ TCN_IMPLEMENT_CALL(jint, SSL, initialize)(TCN_STDARGS,
- #endif
- OPENSSL_load_builtin_modules();
-
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- #if ! (defined(WIN32) || defined(WIN64))
- err = apr_threadkey_private_create(&thread_exit_key, _ssl_thread_exit,
- tcn_global_pool);