aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-06-10 03:32:12 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-06-10 03:32:12 +0000
commitdaec1c18f25334f8ed7be23cbae1c1b65d213c16 (patch)
tree62c6bc8d66aebf05d4e9d09d2aabb5dfa239c0a0
parent7240f5e588cef0333ab79b7afa1d894df47e10cd (diff)
downloadports-daec1c18f25334f8ed7be23cbae1c1b65d213c16.tar.gz
ports-daec1c18f25334f8ed7be23cbae1c1b65d213c16.zip
New port: audio/tamgamp-lv2: LV2 guitar amp simulator
Notes
Notes: svn path=/head/; revision=538366
-rw-r--r--audio/Makefile1
-rw-r--r--audio/tamgamp-lv2/Makefile36
-rw-r--r--audio/tamgamp-lv2/distinfo5
-rw-r--r--audio/tamgamp-lv2/pkg-descr15
4 files changed, 57 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 6ac85a7ba050..07d6a79fdaa8 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -788,6 +788,7 @@
SUBDIR += taglookup
SUBDIR += tagtool
SUBDIR += tagutil
+ SUBDIR += tamgamp-lv2
SUBDIR += tap-plugins
SUBDIR += tap-plugins-lv2
SUBDIR += tcd
diff --git a/audio/tamgamp-lv2/Makefile b/audio/tamgamp-lv2/Makefile
new file mode 100644
index 000000000000..33dd30257361
--- /dev/null
+++ b/audio/tamgamp-lv2/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= tamgamp
+DISTVERSION= g20200514
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= 04c59043ab0939dff5a11698704d15289931bd2e.patch:-p1
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= LV2 guitar amp simulator
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+LIB_DEPENDS= libzita-resampler.so:audio/zita-resampler
+
+USES= gmake localbase:ldflags pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= sadko4u
+GH_PROJECT= tamgamp.lv2
+GH_TAGNAME= 590ced0a1da96ca481a1a719eebdb17f3af472e4
+
+BINARY_ALIAS= make=${GMAKE} # https://github.com/sadko4u/tamgamp.lv2/issues/8
+
+PLIST_FILES= lib/lv2/tamgamp.lv2/manifest.ttl \
+ lib/lv2/tamgamp.lv2/tamgamp-lv2.so \
+ lib/lv2/tamgamp.lv2/tamgamp.ttl \
+ lib/lv2/tamgamp.lv2/tamgamp_gx.ttl
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/tamgamp.lv2/tamgamp-lv2.so
+
+.include <bsd.port.mk>
diff --git a/audio/tamgamp-lv2/distinfo b/audio/tamgamp-lv2/distinfo
new file mode 100644
index 000000000000..352857db673c
--- /dev/null
+++ b/audio/tamgamp-lv2/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1591757226
+SHA256 (sadko4u-tamgamp.lv2-g20200514-590ced0a1da96ca481a1a719eebdb17f3af472e4_GH0.tar.gz) = aafca47fe89a75beffb25fea652c9a745fd2231708f450c3a1006d1de67f882f
+SIZE (sadko4u-tamgamp.lv2-g20200514-590ced0a1da96ca481a1a719eebdb17f3af472e4_GH0.tar.gz) = 3807815
+SHA256 (04c59043ab0939dff5a11698704d15289931bd2e.patch) = 2f11f2498f51b24b9a4eba60606214aa12c2b2b764f3a38d60db267eca91bce7
+SIZE (04c59043ab0939dff5a11698704d15289931bd2e.patch) = 748
diff --git a/audio/tamgamp-lv2/pkg-descr b/audio/tamgamp-lv2/pkg-descr
new file mode 100644
index 000000000000..d2d12db5fb04
--- /dev/null
+++ b/audio/tamgamp-lv2/pkg-descr
@@ -0,0 +1,15 @@
+Tamgamp (Rhymes with: "Damage Amp") is LV2 guitar amp simulator that provides
+two plugins:
+* Tamgamp - a plugin based on Guitarix DK Builder simulated chains.
+* TamgampGX - a plugin based on tuned Guitarix internal amplifiers
+ implementation.
+
+The key features of this project according to initial technical requirements are
+* Simplicity of the interface, no UI (use generic one), minimum knobs/sliders.
+* Preamplifier simulation only, for simplicity and flexibility (use a separate
+ cab simulator).
+* Smooth bypass/automation. No pops, spikes or clicks.
+* Normalized output level: different amplifiers should sound almost of the same
+ output loudness with different gain settings.
+
+WWW: https://github.com/sadko4u/tamgamp.lv2