aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2023-01-15 21:18:28 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2023-01-15 21:23:43 +0000
commitdb0879544520d16db58a403f072b38af9c4cf208 (patch)
tree20e91d849aba0af5ac636520d8106887c9540372
parent6d8e63c53f121527898f3228fdecdc72a57022e3 (diff)
downloadports-db0879544520d16db58a403f072b38af9c4cf208.tar.gz
ports-db0879544520d16db58a403f072b38af9c4cf208.zip
audio/py-gtts: Make build system PEP-518 conform
Declare minimum build dependencies for build system See: https://peps.python.org/pep-0518/#build-system-table PR: 268902 Reported by: Charlie Li <vishwin@freebsd.org>
-rw-r--r--audio/py-gtts/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/audio/py-gtts/Makefile b/audio/py-gtts/Makefile
index c654bb26bab6..d2edecc58d66 100644
--- a/audio/py-gtts/Makefile
+++ b/audio/py-gtts/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gTTS
DISTVERSION= 2.3.0
+PORTREVISION= 1
CATEGORIES= audio python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +12,8 @@ WWW= https://github.com/pndurette/gTTS
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=8.1.3:devel/py-click@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.28.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.16.0:devel/py-six@${PY_FLAVOR}