aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2023-06-03 10:49:36 +0000
committerKai Knoblich <kai@FreeBSD.org>2023-06-03 10:49:36 +0000
commitdb12b15e5e9e90d22b6478447ded3ceabab24de8 (patch)
treee54be002358f6b7fd1bc4891ae462b0fe0654900
parentdaf12c76bd531335f58e7602afd3bc8da8fc5c33 (diff)
downloadports-db12b15e5e9e90d22b6478447ded3ceabab24de8.tar.gz
ports-db12b15e5e9e90d22b6478447ded3ceabab24de8.zip
www/py-asgiref: Add missing dependencies
* Python versions prior 3.11 requires devel/py-typing-extensions as noted in the setup.cfg. Otherwise it leads to following error [1]: [...] from asgiref.sync import sync_to_async File "/usr/local/lib/python3.9/site-packages/asgiref/sync.py", line 27, in <module> from .current_thread_executor import CurrentThreadExecutor File "/usr/local/lib/python3.9/site-packages/asgiref/current_thread_executor.py", line 10, in <module> from typing_extensions import ParamSpec ModuleNotFoundError: No module named 'typing_extensions' [...] * Bump PORTREVISION due changed dependencies. Reported by: pkg-fallout [1] (for www/py-django-treebeard) Approved by: portmgr (buildfix blanket) Fixes: 8a94364e8648 www/py-asgiref: Update to 3.7.2
-rw-r--r--www/py-asgiref/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/www/py-asgiref/Makefile b/www/py-asgiref/Makefile
index d1fcaa89888e..b0ab70d62b4c 100644
--- a/www/py-asgiref/Makefile
+++ b/www/py-asgiref/Makefile
@@ -1,5 +1,6 @@
PORTNAME= asgiref
PORTVERSION= 3.7.2
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,7 +20,13 @@ USE_PYTHON= distutils autoplist
NO_ARCH= yes
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 31100
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=4:devel/py-typing-extensions@${PY_FLAVOR}
+.endif
+
do-test:
(cd ${WRKSRC} && pytest)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>