aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2022-01-10 19:32:06 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2022-01-10 19:32:06 +0000
commitdb48936a5f19da6a6f1e7df73f4219dab9d1de5b (patch)
tree25a36745af33e34dfb3592cde11f43c9a2d32d80
parente3b18f793cc16223a94673f400183250a1c9b00e (diff)
downloadports-db48936a5f19da6a6f1e7df73f4219dab9d1de5b.tar.gz
ports-db48936a5f19da6a6f1e7df73f4219dab9d1de5b.zip
science/cdf: Allow build for ARM.
Obtained from: Robert Clausecker <fuz@fuz.su>
-rw-r--r--science/cdf/Makefile5
-rw-r--r--science/cdf/files/patch-src_include_cdfdist.h11
2 files changed, 11 insertions, 5 deletions
diff --git a/science/cdf/Makefile b/science/cdf/Makefile
index 161cf75db9c6..2bbfcf72ba32 100644
--- a/science/cdf/Makefile
+++ b/science/cdf/Makefile
@@ -15,10 +15,6 @@ LICENSE_NAME= NASA/Goddard Space Flight Center
LICENSE_FILE= ${WRKSRC}/CDF_copyright.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BROKEN_aarch64= fails to compile: error: use of undeclared identifier FP1ZEROsingle; did you mean FP1zeroSingle?
-BROKEN_armv6= fails to compile: error: use of undeclared identifier FP1ZEROsingle; did you mean FP1zeroSingle?
-BROKEN_armv7= fails to compile: error: use of undeclared identifier FP1ZEROsingle; did you mean FP1zeroSingle?
-
BUILD_DEPENDS= bash:shells/bash
USES= fortran ncurses gmake
@@ -41,6 +37,7 @@ PORTDOCS= CDF_copyright.txt CHANGES.txt Release.notes Welcome.txt
OPTIONS_DEFINE= DOCS EXAMPLES
MAKE_ARGS+= OS=freebsd ENV=gnu all
+TEST_TARGET= test
post-patch:
.for def in ${DEFS}
diff --git a/science/cdf/files/patch-src_include_cdfdist.h b/science/cdf/files/patch-src_include_cdfdist.h
index 6e3d27a36448..3e3b47c5d8b1 100644
--- a/science/cdf/files/patch-src_include_cdfdist.h
+++ b/science/cdf/files/patch-src_include_cdfdist.h
@@ -1,5 +1,14 @@
---- src/include/cdfdist.h.orig 2022-01-08 02:20:38 UTC
+--- src/include/cdfdist.h.orig 2019-10-16 16:22:18 UTC
+++ src/include/cdfdist.h
+@@ -135,7 +135,7 @@
+ # define unix
+ #endif
+
+-#if defined(__arm__)
++#if defined(__arm__) || defined (__aarch64__)
+ # define ARM
+ # if defined(__BYTE_ORDER__)
+ # if __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
@@ -567,7 +567,7 @@ typedef sChar sByte;
# if defined(__DARWIN_64_BIT_INO_T)
# define STAT stat