diff options
author | VinÃcius Zavam <egypcio@FreeBSD.org> | 2021-04-13 13:50:59 +0000 |
---|---|---|
committer | VinÃcius Zavam <egypcio@FreeBSD.org> | 2021-04-13 13:57:29 +0000 |
commit | db8dbd775cb9484f9b92f0d1348a2b62ce70ef2f (patch) | |
tree | 509f8b31903df6687a10feca86bb23674aa95e9b | |
parent | e91e2f083ae3f2669812458bb253fd08d40814fd (diff) | |
download | ports-db8dbd775cb9484f9b92f0d1348a2b62ce70ef2f.tar.gz ports-db8dbd775cb9484f9b92f0d1348a2b62ce70ef2f.zip |
REVIVE: security/apg, Automated Password Generator written in Go
apg-go is a simple APG-like password generator written in Go.
It tries to replicate the functionality of the "Automated Password
Generator", which hasn't been maintained since 2003. Since FIPS-181
(pronouncable passwords) has been withdrawn in 2015, I didn't see
any use in replicating that feature. Therfore apg-go does not support
pronouncable passwords.
WWW: https://github.com/wneessen/apg-go
-rw-r--r-- | MOVED | 1 | ||||
-rw-r--r-- | security/Makefile | 1 | ||||
-rw-r--r-- | security/apg/Makefile | 19 | ||||
-rw-r--r-- | security/apg/distinfo | 3 | ||||
-rw-r--r-- | security/apg/pkg-descr | 11 |
5 files changed, 34 insertions, 1 deletions
@@ -16191,7 +16191,6 @@ net-p2p/sonarr-devel|net-p2p/sonarr|2021-03-23|Removed, use net-p2p/sonarr inste www/py-django-jsonfield||2021-03-24|Removed: This port will be deleted in the future, please switch to use www/py-jsonfield or www/py-jsonfield2 devel/hs-c2hs||2021-03-27|Has expired: Was used as BUILD_DEPENDS, not useful on its own x11-toolkits/tile||2021-03-27|Has expired: The Tile widget set is part of Tk 8.5 and above, see TIP 248 -security/apg||2021-03-28|Has expired: Abandonware. Please try security/makepasswd or security/rndpassw instead lang/Gofer||2021-03-28|Has expired: Old, unmaintained language net/libsignal|net/libsignal-protocol-c|2021-03-30|Rename to match upstream naming databases/redis4|databases/redis|2021-04-06|Has expired: End of life, please use modern version diff --git a/security/Makefile b/security/Makefile index eb3849e0ebe5..2bafb147f36d 100644 --- a/security/Makefile +++ b/security/Makefile @@ -26,6 +26,7 @@ SUBDIR += amavisd-milter SUBDIR += amavisd-new SUBDIR += apache-xml-security-c + SUBDIR += apg SUBDIR += apkid SUBDIR += arirang SUBDIR += arpCounterattack diff --git a/security/apg/Makefile b/security/apg/Makefile new file mode 100644 index 000000000000..99907864de77 --- /dev/null +++ b/security/apg/Makefile @@ -0,0 +1,19 @@ +PORTNAME= apg +DISTVERSIONPREFIX= v +DISTVERSION= 0.3.0 +CATEGORIES= security sysutils + +MAINTAINER= egypcio@FreeBSD.org +COMMENT= Automated Password Generator written in Go + +LICENSE= MIT +LICENSE_FILE= ${WRKSRC}/LICENSE + +USES= go:modules +USE_GITHUB= yes +GH_ACCOUNT= wneessen +GH_PROJECT= apg-go + +PLIST_FILES= bin/${PORTNAME} + +.include <bsd.port.mk> diff --git a/security/apg/distinfo b/security/apg/distinfo new file mode 100644 index 000000000000..30368119ffc6 --- /dev/null +++ b/security/apg/distinfo @@ -0,0 +1,3 @@ +TIMESTAMP = 1618314166 +SHA256 (wneessen-apg-go-v0.3.0_GH0.tar.gz) = acb750ac03de7d467ef3b5f576a7b7eea47d0a4f521c2647d80f0ebe641d3c56 +SIZE (wneessen-apg-go-v0.3.0_GH0.tar.gz) = 13392 diff --git a/security/apg/pkg-descr b/security/apg/pkg-descr new file mode 100644 index 000000000000..f201dc473dd8 --- /dev/null +++ b/security/apg/pkg-descr @@ -0,0 +1,11 @@ +apg-go is a simple APG-like password generator written in Go. + +It tries to replicate the functionality of the "Automated Password Generator", +which hasn't been maintained since 2003. Since more and more Unix +distributions are abondoning the tool, I was looking for an alternative. + +Since FIPS-181 (pronouncable passwords) has been withdrawn in 2015, I didn't +see any use in replicating that feature. Therfore apg.go does not support +pronouncable passwords. + +WWW: https://github.com/wneessen/apg-go |