aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-26 09:29:30 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-26 09:29:30 +0000
commitdbcfc7e7237532da6c6f607d32c7b915897266bc (patch)
treeee1427005cafaf1c9d4a9e2740b5affce4f0d574
parentec89a81d865d3cec29036c2e3d64d1e4612f4842 (diff)
downloadports-dbcfc7e7237532da6c6f607d32c7b915897266bc.tar.gz
ports-dbcfc7e7237532da6c6f607d32c7b915897266bc.zip
www/py-django-simple-captcha: Fix build with DOCS option enabled
running build_sphinx Running Sphinx v5.3.0 Configuration error: There is a programmable error in your configuration file: Traceback (most recent call last): File "/usr/local/lib/python3.9/site-packages/sphinx/config.py", line 350, in eval_config_file exec(code, namespace) File "/wrkdirs/usr/ports/www/py-django-simple-captcha/work-py39/django-simple-captcha-0.5.14/docs/conf.py", line 17, in <module> from six import u ModuleNotFoundError: No module named 'six' *** Error code 1 Approved by: portmgr (blanket) With hat: python
-rw-r--r--www/py-django-simple-captcha/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/www/py-django-simple-captcha/Makefile b/www/py-django-simple-captcha/Makefile
index c84cf446a8ed..ed61cae9db34 100644
--- a/www/py-django-simple-captcha/Makefile
+++ b/www/py-django-simple-captcha/Makefile
@@ -25,7 +25,8 @@ NO_ARCH= yes
PORTDOCS= *
OPTIONS_DEFINE= DOCS MIGRATIONS
-DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_FLAVOR}
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_FLAVOR}
DOCS_VARS= PYDISTUTILS_BUILD_TARGET+="build_sphinx -a -E"
MIGRATIONS_DESC= Schema and data migration support (via south)
MIGRATIONS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}south>0:databases/py-south@${PY_FLAVOR}