aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-18 13:27:52 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-18 13:28:20 +0000
commitdbda1c23ea918a144c81888ff87dc6e127620f86 (patch)
treed7e6e32a7adada351b99400c32c36f56573686a2
parenta6a428bcd414da741ed7271224816e7a23c95f17 (diff)
downloadports-dbda1c23ea918a144c81888ff87dc6e127620f86.tar.gz
ports-dbda1c23ea918a144c81888ff87dc6e127620f86.zip
audio/libmad: Fix build with libmad 0.16.4
-rw-r--r--audio/cmus/files/patch-configure11
-rw-r--r--audio/qtractor/files/patch-CMakeLists.txt9
-rw-r--r--audio/sonic-visualiser/files/patch-configure.ac9
-rw-r--r--multimedia/dvbcut/files/patch-src_dvbcut.pro14
-rw-r--r--multimedia/libxine/files/patch-configure44
-rw-r--r--sysutils/cdrdao/files/patch-configure.ac21
-rw-r--r--sysutils/mtpfs/files/patch-configure.ac11
7 files changed, 3 insertions, 116 deletions
diff --git a/audio/cmus/files/patch-configure b/audio/cmus/files/patch-configure
deleted file mode 100644
index ee957c751f73..000000000000
--- a/audio/cmus/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2022-05-09 00:59:25 UTC
-+++ configure
-@@ -229,7 +229,7 @@ check_flac()
-
- check_mad()
- {
-- pkg_config MAD "mad" "" "-lmad -lm"
-+ pkg_config MAD "libmad" "" "-lmad -lm"
- return $?
- }
-
diff --git a/audio/qtractor/files/patch-CMakeLists.txt b/audio/qtractor/files/patch-CMakeLists.txt
index cf20ce0b7935..8a466b19ee5d 100644
--- a/audio/qtractor/files/patch-CMakeLists.txt
+++ b/audio/qtractor/files/patch-CMakeLists.txt
@@ -9,12 +9,3 @@
if (NOT Qt6_FOUND)
set (CONFIG_QT6 0)
endif ()
-@@ -385,7 +385,7 @@ endif ()
-
- # Check for MAD libraries.
- if (CONFIG_LIBMAD)
-- pkg_check_modules (MAD IMPORTED_TARGET mad)
-+ pkg_check_modules (MAD IMPORTED_TARGET libmad)
- if (NOT MAD_FOUND)
- message (WARNING "*** MAD library not found.")
- set (CONFIG_LIBMAD 0)
diff --git a/audio/sonic-visualiser/files/patch-configure.ac b/audio/sonic-visualiser/files/patch-configure.ac
index 3efda3765b36..657ce488d309 100644
--- a/audio/sonic-visualiser/files/patch-configure.ac
+++ b/audio/sonic-visualiser/files/patch-configure.ac
@@ -1,11 +1,6 @@
--- configure.ac.orig 2019-12-10 09:29:11 UTC
+++ configure.ac
-@@ -123,12 +123,12 @@ SV_MODULE_OPTIONAL([libpulse],[libpulse >= 0.9],[pulse
- SV_MODULE_REQUIRED([lrdf],[lrdf >= 0.2],[lrdf.h],[lrdf],[lrdf_init])
- SV_MODULE_REQUIRED([oggz],[oggz >= 1.0.0],[oggz/oggz.h],[oggz],[oggz_run])
- SV_MODULE_REQUIRED([fishsound],[fishsound >= 1.0.0],[fishsound/fishsound.h],[fishsound],[fish_sound_new])
--SV_MODULE_REQUIRED([mad],[mad >= 0.15.0],[mad.h],[mad],[mad_decoder_init])
-+SV_MODULE_REQUIRED([mad],[libmad >= 0.15.0],[mad.h],[mad],[mad_decoder_init])
+@@ -127,8 +127,8 @@ SV_MODULE_REQUIRED([opus],[opusfile],[opus/opusfile.h]
SV_MODULE_REQUIRED([id3tag],[id3tag >= 0.15.0],[id3tag.h],[id3tag],[id3_tag_new])
SV_MODULE_REQUIRED([opus],[opusfile],[opus/opusfile.h],[opusfile],[op_read_float])
@@ -16,7 +11,7 @@
AC_SUBST(PERL)
AC_SUBST(XARGS)
-@@ -154,6 +154,7 @@ AC_CONFIG_FILES([config.pri])
+@@ -154,6 +154,7 @@ AC_OUTPUT
AC_OUTPUT
diff --git a/multimedia/dvbcut/files/patch-src_dvbcut.pro b/multimedia/dvbcut/files/patch-src_dvbcut.pro
deleted file mode 100644
index e5f2540f027a..000000000000
--- a/multimedia/dvbcut/files/patch-src_dvbcut.pro
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/dvbcut.pro.orig 2018-08-19 23:08:52 UTC
-+++ src/dvbcut.pro
-@@ -112,9 +112,9 @@ system(pkg-config --exists ao) {
- PKGCONFIG += ao
- } else { error(Please install development package libao-dev) }
-
--system(pkg-config --exists mad) {
-+system(pkg-config --exists libmad) {
- QMAKE_CXXFLAGS += -DHAVE_LIB_MAD
-- PKGCONFIG += mad
-+ PKGCONFIG += libmad
- } else { error(Please install development package libmad0-dev) }
-
- QMAKE_CXXFLAGS += -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -D_FILE_OFFSET_BITS=64
diff --git a/multimedia/libxine/files/patch-configure b/multimedia/libxine/files/patch-configure
index 5ef94ba0253e..05d52d8a2e80 100644
--- a/multimedia/libxine/files/patch-configure
+++ b/multimedia/libxine/files/patch-configure
@@ -27,47 +27,3 @@
*) have_dvb=no ;;
esac
if test x"$hard_enable_dvb" = x"yes" && test x"$have_dvb" != x"yes"; then
-@@ -32826,12 +32826,12 @@ if test -n "$PKG_CONFIG"; then
- pkg_cv_LIBMAD_CFLAGS="$LIBMAD_CFLAGS"
- else
- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"mad\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "mad") 2>&5
-+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libmad\""; } >&5
-+ ($PKG_CONFIG --exists --print-errors "libmad") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; }; then
-- pkg_cv_LIBMAD_CFLAGS=`$PKG_CONFIG --cflags "mad" 2>/dev/null`
-+ pkg_cv_LIBMAD_CFLAGS=`$PKG_CONFIG --cflags "libmad" 2>/dev/null`
- else
- pkg_failed=yes
- fi
-@@ -32844,12 +32844,12 @@ if test -n "$PKG_CONFIG"; then
- pkg_cv_LIBMAD_LIBS="$LIBMAD_LIBS"
- else
- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"mad\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "mad") 2>&5
-+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libmad\""; } >&5
-+ ($PKG_CONFIG --exists --print-errors "libmad") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; }; then
-- pkg_cv_LIBMAD_LIBS=`$PKG_CONFIG --libs "mad" 2>/dev/null`
-+ pkg_cv_LIBMAD_LIBS=`$PKG_CONFIG --libs "libmad" 2>/dev/null`
- else
- pkg_failed=yes
- fi
-@@ -32868,9 +32868,9 @@ else
- _pkg_short_errors_supported=no
- fi
- if test $_pkg_short_errors_supported = yes; then
-- LIBMAD_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "mad"`
-+ LIBMAD_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "libmad"`
- else
-- LIBMAD_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "mad"`
-+ LIBMAD_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "libmad"`
- fi
- # Put the nasty error message in config.log where it belongs
- echo "$LIBMAD_PKG_ERRORS" >&5
diff --git a/sysutils/cdrdao/files/patch-configure.ac b/sysutils/cdrdao/files/patch-configure.ac
index 62cbaebf259f..0c886722dd1e 100644
--- a/sysutils/cdrdao/files/patch-configure.ac
+++ b/sysutils/cdrdao/files/patch-configure.ac
@@ -1,15 +1,6 @@
Remove redundant check for libao which causes it to always be required even if
mp3 and ogg support are disabled.
-Temporarily support either mad.pc or libmad.pc to prevent breakage with future
-versions of libmad. After libmad 0.16.3, new upstream renamed the pkgconfig
-file to mad.pc [1], assumingly to conform to what we and most of the Linux
-packagers decided upon almost 9 years ago [2], as the original libmad never
-had a pkgconfig file.
-
-[1] https://codeberg.org/tenacityteam/libmad/commit/486e615d4d8aab5b426d8b82b7dfa9867f0b2146
-[2] https://cgit.freebsd.org/ports/commit/audio/libmad?id=d52971d56c7520e7b8af206bc70e05cceed295a5
-
--- configure.ac.orig 2023-02-03 14:46:06 UTC
+++ configure.ac
@@ -314,8 +314,10 @@ dnl Check for libao
@@ -23,17 +14,7 @@ had a pkgconfig file.
dnl Check for OGG support
if test "$with_ogg_support" = yes; then
-@@ -326,7 +328,8 @@ if test "$with_mp3_support" = yes; then
- dnl Check for MP3 support
- if test "$with_mp3_support" = yes; then
- PKG_CHECK_MODULES(MAD, mad >= 0.10, [],
-- [echo "libMAD detection via pkg-config failed"; with_mp3_support=no])
-+ [PKG_CHECK_MODULES(MAD, libmad >= 0.10, [],
-+ [echo "libMAD detection via pkg-config failed"; with_mp3_support=no])])
- if test "$with_mp3_support" = no; then
- AC_CHECK_LIB(mad, mad_stream_init, [AC_CHECK_HEADER([mad.h])])
- if test "$ac_cv_lib_mad_mad_stream_init" = yes; then
-@@ -339,12 +342,6 @@ if test "$with_mp3_support" = yes; then
+@@ -339,12 +341,6 @@ if test "$with_mp3_support" = yes; then
echo "MP3 support disabled"; with_mp3_support=no
fi
fi
diff --git a/sysutils/mtpfs/files/patch-configure.ac b/sysutils/mtpfs/files/patch-configure.ac
deleted file mode 100644
index a6bbcdd5db1a..000000000000
--- a/sysutils/mtpfs/files/patch-configure.ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.ac.orig 2022-05-06 23:16:39 UTC
-+++ configure.ac
-@@ -22,7 +22,7 @@ AC_ARG_ENABLE([mad],
- [AS_HELP_STRING([--disable-mad], [disable libmad handling of mp3 files])])
-
- AS_IF([test "x$enable_mad" != "xno"] , [
-- PKG_CHECK_MODULES(MAD, mad >= 0.15 \
-+ PKG_CHECK_MODULES(MAD, libmad >= 0.15 \
- id3tag >= 0.15)
- AC_SUBST(MAD_CFLAGS)
- AC_SUBST(MAD_LIBS)