aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-12-25 14:41:49 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-12-25 14:41:49 +0000
commitdc123a0b00ae563e1fcdbca99934d8a7398bc0b5 (patch)
tree1f2fa9f2ba146f0057074f13ad03e11f86217dbe
parentc62f40fb68bfe1adff8f68b8bcf89726d890d20c (diff)
downloadports-dc123a0b00ae563e1fcdbca99934d8a7398bc0b5.tar.gz
ports-dc123a0b00ae563e1fcdbca99934d8a7398bc0b5.zip
deskutils/mindforger: fix build on non-aarch64 non-x86
-rw-r--r--deskutils/mindforger/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/deskutils/mindforger/Makefile b/deskutils/mindforger/Makefile
index cd0e1d333d93..ff215988020e 100644
--- a/deskutils/mindforger/Makefile
+++ b/deskutils/mindforger/Makefile
@@ -11,14 +11,14 @@ LICENSE= GPLv2+
USES= qmake qt:5
USE_QT= buildtools_build core declarative gui location network \
- printsupport webchannel webengine widgets
+ printsupport webchannel widgets
USE_GITHUB= yes
GH_ACCOUNT= dvorka
GH_PROJECT= cmark:cm
GH_TAGNAME= f06d944:cm
GH_SUBDIR= deps/cmark-gfm:cm
-QMAKE_ARGS= CONFIG+="mfnocxx mfwebengine"
+QMAKE_ARGS= CONFIG+="mfnocxx"
OPTIONS_DEFINE= CMARK
OPTIONS_DEFAULT= CMARK
@@ -27,6 +27,15 @@ CMARK_DESC= CommonMark support (Markdown -> HTML rendering)
CMARK_BUILD_DEPENDS= cmake:devel/cmake
CMARK_QMAKE_OFF= CONFIG+="mfnomd2html"
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == i386
+USE_QT+= webengine
+QMAKE_ARGS+= CONFIG+="mfwebengine"
+.else
+USE_QT+= webkit
+.endif
+
pre-build-CMARK-on:
@cd ${WRKSRC_cm} && cmake -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON \
-DCMARK_TESTS:BOOL=OFF -DCMARK_SHARED:BOOL=OFF \