aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-08-22 16:59:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-08-22 17:03:39 +0000
commitdcf9487661860b4d04db70b1e06395bdf5b973dd (patch)
tree0d2920ec14c7b3aa0cec888b4c563ad0cc32b68c
parent85b9e25367ffc7e74cff4e9800fb02232679220e (diff)
downloadports-dcf9487661860b4d04db70b1e06395bdf5b973dd.tar.gz
ports-dcf9487661860b4d04db70b1e06395bdf5b973dd.zip
qt-dist.mk: expose QT_CMAKEDIR to plist for Qt5
This was removed for Qt 6, but was still required for Qt 5.
-rw-r--r--Mk/Uses/qt-dist.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Mk/Uses/qt-dist.mk b/Mk/Uses/qt-dist.mk
index bc9583eb77f8..9fd8dcce4d1f 100644
--- a/Mk/Uses/qt-dist.mk
+++ b/Mk/Uses/qt-dist.mk
@@ -293,6 +293,13 @@ PLIST_SUB+= QT_${dir}DIR="${QT_${dir}DIR_REL}"
. endfor
. if ${_QT_VER:M5}
+. for dir in CMAKE
+# Export QT_CMAKEDIR.
+PLIST_SUB+= QT_${dir}DIR="${QT_${dir}DIR_REL}"
+. endfor
+. endif
+
+. if ${_QT_VER:M5}
. if ${_QT_DIST} == "base"
# qtbase requires some tools to be symlinked to the build directory.
_QT_TOOLS= # empty