aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-05-04 04:38:12 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-05-04 04:38:12 +0000
commitdd32b25a29166ee5e49730ef3cc6efa80c37319f (patch)
tree3f4e3b89ee9d03e537c30fdd32b978bf1b0ed849
parent68fc467fd6af4262efa004bf61a651bd659fe278 (diff)
downloadports-dd32b25a29166ee5e49730ef3cc6efa80c37319f.tar.gz
ports-dd32b25a29166ee5e49730ef3cc6efa80c37319f.zip
openssl:
- some configure scripts check the version of the lib so we need to update SHLIBVER - bump PORTREVISION openssh: - build ports with local openssl, if it exists
Notes
Notes: svn path=/head/; revision=58521
-rw-r--r--security/hpn-ssh/Makefile6
-rw-r--r--security/openssh-portable/Makefile6
-rw-r--r--security/openssh/Makefile6
-rw-r--r--security/openssl-beta/Makefile4
-rw-r--r--security/openssl-beta/pkg-plist4
-rw-r--r--security/openssl/Makefile4
-rw-r--r--security/openssl/pkg-plist4
7 files changed, 19 insertions, 15 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index c0e6f1fca76d..ca1133761e69 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -83,10 +83,10 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 430000
-OPENSSLBASE= /usr/local
+.if ${OSVERSION} < 430000 || exists(${LOCALBASE}/lib/libcrypto.so.3)
+OPENSSLBASE= ${LOCALBASE}
OPENSSLDIR= ${OPENSSLBASE}/openssl
-LIB_DEPENDS+= crypto.2:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl
OPENSSLLIB= ${OPENSSLBASE}/lib
OPENSSLINC= ${OPENSSLBASE}/include
MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index c0e6f1fca76d..ca1133761e69 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -83,10 +83,10 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 430000
-OPENSSLBASE= /usr/local
+.if ${OSVERSION} < 430000 || exists(${LOCALBASE}/lib/libcrypto.so.3)
+OPENSSLBASE= ${LOCALBASE}
OPENSSLDIR= ${OPENSSLBASE}/openssl
-LIB_DEPENDS+= crypto.2:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl
OPENSSLLIB= ${OPENSSLBASE}/lib
OPENSSLINC= ${OPENSSLBASE}/include
MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index 5a91e4bc6f33..a449e9bb666d 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -32,10 +32,10 @@ FIXME= lib/Makefile scp/Makefile sftp/Makefile sftp-server/Makefile \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 430000
-OPENSSLBASE= /usr/local
+.if ${OSVERSION} < 430000 || exists(${LOCALBASE}/lib/libcrypto.so.3)
+OPENSSLBASE= ${LOCALBASE}
OPENSSLDIR= ${OPENSSLBASE}/openssl
-LIB_DEPENDS+= crypto.2:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl
OPENSSLLIB= ${OPENSSLBASE}/lib
OPENSSLINC= ${OPENSSLBASE}/include
MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
diff --git a/security/openssl-beta/Makefile b/security/openssl-beta/Makefile
index 1fbe3f02f33b..f52553f235d9 100644
--- a/security/openssl-beta/Makefile
+++ b/security/openssl-beta/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssl
PORTVERSION= 0.9.6c
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
@@ -31,8 +32,9 @@ USE_PERL5= yes
PLIST= ${PKGDIR}/pkg-plist.noshared
.else
ALL_TARGET= freebsd-shared all
-SHLIBVER= 2
+SHLIBVER= 3
MAKE_ENV+= SHLIBVER=${SHLIBVER}
+PLIST_SUB+= SHLIBVER=${SHLIBVER}
INSTALLS_SHLIB= yes
.endif
diff --git a/security/openssl-beta/pkg-plist b/security/openssl-beta/pkg-plist
index c0c7e4a028ed..67060bf550d4 100644
--- a/security/openssl-beta/pkg-plist
+++ b/security/openssl-beta/pkg-plist
@@ -58,10 +58,10 @@ include/openssl/x509v3.h
lib/libRSAglue.a
lib/libcrypto.a
lib/libcrypto.so
-lib/libcrypto.so.2
+lib/libcrypto.so.%%SHLIBVER%%
lib/libssl.a
lib/libssl.so
-lib/libssl.so.2
+lib/libssl.so.%%SHLIBVER%%
openssl/misc/CA.pl
openssl/misc/CA.sh
openssl/misc/c_hash
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 1fbe3f02f33b..f52553f235d9 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssl
PORTVERSION= 0.9.6c
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
@@ -31,8 +32,9 @@ USE_PERL5= yes
PLIST= ${PKGDIR}/pkg-plist.noshared
.else
ALL_TARGET= freebsd-shared all
-SHLIBVER= 2
+SHLIBVER= 3
MAKE_ENV+= SHLIBVER=${SHLIBVER}
+PLIST_SUB+= SHLIBVER=${SHLIBVER}
INSTALLS_SHLIB= yes
.endif
diff --git a/security/openssl/pkg-plist b/security/openssl/pkg-plist
index c0c7e4a028ed..67060bf550d4 100644
--- a/security/openssl/pkg-plist
+++ b/security/openssl/pkg-plist
@@ -58,10 +58,10 @@ include/openssl/x509v3.h
lib/libRSAglue.a
lib/libcrypto.a
lib/libcrypto.so
-lib/libcrypto.so.2
+lib/libcrypto.so.%%SHLIBVER%%
lib/libssl.a
lib/libssl.so
-lib/libssl.so.2
+lib/libssl.so.%%SHLIBVER%%
openssl/misc/CA.pl
openssl/misc/CA.sh
openssl/misc/c_hash