aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-05-16 13:23:41 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-05-16 21:46:47 +0000
commitdd54f12532c55dbb8e2cd6910a0b99436c657f7a (patch)
tree189b90f4946b04a578527feb59244153a5a98e4a
parent53b381f3cbf76ce257869abc5bde0c19470c7ec9 (diff)
downloadports-dd54f12532c55dbb8e2cd6910a0b99436c657f7a.tar.gz
ports-dd54f12532c55dbb8e2cd6910a0b99436c657f7a.zip
sysutils/consolekit2: update to 1.2.2, latest upstream
This commit picks up several ideas: - update to the 1.2.2 release from upstream (PR 252783) - make the X11 option useful again; it **was** useless, so PR 255847 proposed removing the option -- X11 is mandatory -- but there was patches also to remove X11 entirely, for a Wayland-only experience. I've massaged it all until the option is useful and meaningfully selects for X11 (or not). The original patch for optionalize-X11 came from amdmi3@, and the "competing" one was -- via DankBSD, from unrelentingtech, who also has other patches (obtained from GitHub) for CK2. PR: 252783 255847 Reported by: Olivier Duchateau
-rw-r--r--sysutils/consolekit2/Makefile13
-rw-r--r--sysutils/consolekit2/distinfo6
-rw-r--r--sysutils/consolekit2/files/patch-Makefile.am17
-rw-r--r--sysutils/consolekit2/files/patch-configure.ac23
-rw-r--r--sysutils/consolekit2/files/patch-doc_Makefile.am8
-rw-r--r--sysutils/consolekit2/files/patch-tools_Makefile.am19
-rw-r--r--sysutils/consolekit2/pkg-plist4
7 files changed, 79 insertions, 11 deletions
diff --git a/sysutils/consolekit2/Makefile b/sysutils/consolekit2/Makefile
index b3811be46089..c33aaf765735 100644
--- a/sysutils/consolekit2/Makefile
+++ b/sysutils/consolekit2/Makefile
@@ -1,12 +1,9 @@
# Created by: FreeBSD GNOME Team <gnome@freebsd.org>
PORTNAME= consolekit
-PORTVERSION= 1.2.1
-PORTREVISION= 2
+PORTVERSION= 1.2.2
CATEGORIES= sysutils gnome
-MASTER_SITES= https://github.com/ConsoleKit2/ConsoleKit2/releases/download/${PORTVERSION}/
PKGNAMESUFFIX= 2
-DISTNAME= ConsoleKit2-${PORTVERSION}
# Support for DRM/evdev
PATCH_SITES= https://github.com/unrelentingtech/ConsoleKit2/commit/
@@ -38,8 +35,13 @@ POLKIT_CONFIGURE_ENABLE= polkit
X11_USES= xorg
X11_USE= XORG=x11
+X11_CONFIGURE_WITH= x
+
+USE_GITHUB= yes
+GH_ACCOUNT= ConsoleKit2
+GH_PROJECT= ConsoleKit2
+GH_TAGNAME= 51c11c1 # v1.2.2
-WRKSRC= ${WRKDIR}/ConsoleKit2-${PORTVERSION}
USES= autoreconf gettext gmake gnome libtool localbase pathfix pkgconfig \
tar:bzip2
USE_CSTD= gnu99
@@ -54,7 +56,6 @@ CONFIGURE_ARGS= --with-pid-file=/var/run/${PORTNAME}.pid \
--enable-libdrm \
--enable-libevdev \
--enable-libudev \
- --without-html-dir \
--disable-udev-acl \
--disable-libcgmanager \
--without-systemdsystemunitdir
diff --git a/sysutils/consolekit2/distinfo b/sysutils/consolekit2/distinfo
index 62b233aa8d76..f0b639d32442 100644
--- a/sysutils/consolekit2/distinfo
+++ b/sysutils/consolekit2/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1612811434
-SHA256 (ConsoleKit2-1.2.1.tar.bz2) = 9af223096ece88b217bcd3fe85093390a8d1527b6492124b0e90ea7688ec934b
-SIZE (ConsoleKit2-1.2.1.tar.bz2) = 1182946
+TIMESTAMP = 1610903180
+SHA256 (ConsoleKit2-ConsoleKit2-1.2.2-51c11c1_GH0.tar.gz) = 88ec6d7b5fdfbf735e054cba8168fbcdd2a3bf36ee09926779d203c65f6bd435
+SIZE (ConsoleKit2-ConsoleKit2-1.2.2-51c11c1_GH0.tar.gz) = 254801
SHA256 (03eaa9779f2c9c7b0acf0521a5547036bdec2245.patch) = efcf04ccaba47ad4c979fa694baab3abe7f04fc24c90838b6cbf1e7d709056e6
SIZE (03eaa9779f2c9c7b0acf0521a5547036bdec2245.patch) = 1457
SHA256 (05f26e99539e7a442e57035ed6d64fdd9a50feb9.patch) = 36eb5011e29173f955e27f9b6987eecae27e1793b24e09a09bacda7db9fc2296
diff --git a/sysutils/consolekit2/files/patch-Makefile.am b/sysutils/consolekit2/files/patch-Makefile.am
new file mode 100644
index 000000000000..cdcdecd95ebc
--- /dev/null
+++ b/sysutils/consolekit2/files/patch-Makefile.am
@@ -0,0 +1,17 @@
+--- Makefile.am.orig 2020-12-07 11:27:30 UTC
++++ Makefile.am
+@@ -27,7 +27,6 @@ EXTRA_DIST = config.rpath \
+ NEWS \
+ ChangeLog \
+ m4 \
+- gtk-doc.make \
+ $(NULL)
+
+ DISTCLEANFILES = \
+@@ -73,5 +72,5 @@ $(srcdir)/ChangeLog:
+
+ DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-introspection \
+- --enable-gtk-doc \
++ --disable-gtk-doc \
+ --with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)
diff --git a/sysutils/consolekit2/files/patch-configure.ac b/sysutils/consolekit2/files/patch-configure.ac
new file mode 100644
index 000000000000..b2b800bbedc3
--- /dev/null
+++ b/sysutils/consolekit2/files/patch-configure.ac
@@ -0,0 +1,23 @@
+--- configure.ac.orig 2020-12-07 11:27:30 UTC
++++ configure.ac
+@@ -96,7 +96,11 @@ AC_DEFINE(GLIB_VERSION_MAX_ALLOWED, GLIB_VERSION_2_40,
+
+
+ # Check for X11 installed
+-XDT_CHECK_LIBX11_REQUIRE()
++XDT_CHECK_LIBX11()
++if test "x$with_x" = "xyes" ; then
++ XDT_CHECK_LIBX11_REQUIRE()
++fi
++AM_CONDITIONAL([USE_LIBX11], [test "x$with_x" = xyes])
+
+ # Check for Polkit/PolicyKit
+ XDT_CHECK_OPTIONAL_PACKAGE([POLKIT], [polkit-gobject-1], [polkit_minimum_version],
+@@ -553,7 +557,6 @@ doc/Makefile
+ doc/console-kit-daemon.1m
+ doc/dbus/ConsoleKit.xml
+ doc/dbus/Makefile
+-doc/libconsolekit/Makefile
+ libconsolekit/Makefile
+ libconsolekit/libconsolekit.pc
+ libck-connector/Makefile
diff --git a/sysutils/consolekit2/files/patch-doc_Makefile.am b/sysutils/consolekit2/files/patch-doc_Makefile.am
new file mode 100644
index 000000000000..6748e03c6a5c
--- /dev/null
+++ b/sysutils/consolekit2/files/patch-doc_Makefile.am
@@ -0,0 +1,8 @@
+--- doc/Makefile.am.orig 2020-12-07 11:27:30 UTC
++++ doc/Makefile.am
+@@ -1,4 +1,4 @@
+-SUBDIRS = dbus libconsolekit
++SUBDIRS = dbus
+
+ manpagedir = $(mandir)/man1
+ manpage_DATA = \
diff --git a/sysutils/consolekit2/files/patch-tools_Makefile.am b/sysutils/consolekit2/files/patch-tools_Makefile.am
new file mode 100644
index 000000000000..fdc8efa10f08
--- /dev/null
+++ b/sysutils/consolekit2/files/patch-tools_Makefile.am
@@ -0,0 +1,19 @@
+--- tools/Makefile.am.orig 2020-04-11 15:14:59 UTC
++++ tools/Makefile.am
+@@ -148,10 +148,14 @@ ck_log_system_stop_LDADD = \
+
+ libexec_PROGRAMS = \
+ ck-collect-session-info \
+- ck-get-x11-server-pid \
+- ck-get-x11-display-device \
+ ck-remove-directory \
+ $(NULL)
++
++if USE_LIBX11
++libexec_PROGRAMS += \
++ ck-get-x11-server-pid \
++ ck-get-x11-display-device
++endif
+
+ ck_collect_session_info_SOURCES = \
+ ck-collect-session-info.c \
diff --git a/sysutils/consolekit2/pkg-plist b/sysutils/consolekit2/pkg-plist
index af1bd2de3999..469d998582c2 100644
--- a/sysutils/consolekit2/pkg-plist
+++ b/sysutils/consolekit2/pkg-plist
@@ -25,8 +25,8 @@ lib/pam_ck_connector.so
libdata/pkgconfig/ck-connector.pc
libdata/pkgconfig/libconsolekit.pc
libexec/ck-collect-session-info
-@(,,4755) libexec/ck-get-x11-display-device
-libexec/ck-get-x11-server-pid
+%%X11%%@(,,4755) libexec/ck-get-x11-display-device
+%%X11%%libexec/ck-get-x11-server-pid
libexec/ck-remove-directory
man/man1/ck-history.1.gz
man/man1/ck-launch-session.1.gz