aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-06-25 01:46:14 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-06-25 01:46:14 +0000
commitdd7dac79c3ae11ee54c9344c67794331ca3aad3f (patch)
tree694d894e3b120007eaf9d9bc0ef299a0d095135e
parent0153b50a34ec2b988dc9d21cb4cf4fb54b7fb5a0 (diff)
downloadports-dd7dac79c3ae11ee54c9344c67794331ca3aad3f.tar.gz
ports-dd7dac79c3ae11ee54c9344c67794331ca3aad3f.zip
* Added UPDATING entry
* Removed ALT_HOME option * Fixed MILTER_DESC DCCM * Changed PORTS_SENDMAIL to PORTS_MILTER * Cleaned up old code PR: 220070 Reviewed by: lifanov (mentor), matthew (mentor) Approved by: matthew (mentor), Piotr Kubaj <pkubaj@anongoth.pl> (maintainer) Differential Revision: https://reviews.freebsd.org/D11248
Notes
Notes: svn path=/head/; revision=444253
-rw-r--r--UPDATING8
-rw-r--r--mail/dcc-dccd/Makefile47
-rw-r--r--mail/dcc-dccd/pkg-plist8
3 files changed, 24 insertions, 39 deletions
diff --git a/UPDATING b/UPDATING
index 4b790cba165f..05f1bf9a5cb1 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,14 @@ You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20170624:
+ AFFECTS: users of mail/dcc-dccd
+ AUTHOR: ultima@FreeBSD.org
+
+ The ALT_HOME option was removed in 1.3.159_1. If this option is being
+ used, please be sure to move the old home directory, /var/dcc to
+ ${PREFIX}/dcc.
+
+20170624:
AFFECTS: users of net/rabbitmq
AUTHOR: olgeni@FreeBSD.org
diff --git a/mail/dcc-dccd/Makefile b/mail/dcc-dccd/Makefile
index ab37f4f9a97a..f9d4fad9f1fa 100644
--- a/mail/dcc-dccd/Makefile
+++ b/mail/dcc-dccd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dcc-dccd
PORTVERSION= 1.3.159
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.dcc-servers.net/dcc/source/old/ \
ftp://ftp.dcc-servers.net/src/dcc/old/ \
@@ -23,16 +24,15 @@ HAS_CONFIGURE= yes
USES= tar:Z
-OPTIONS_DEFINE= DCCIFD DCCD DCCGREY IPV6 ALT_HOME
+OPTIONS_DEFINE= DCCIFD DCCD DCCGREY IPV6
OPTIONS_DEFAULT= DCCIFD DCCM DCCD DCCGREY
OPTIONS_GROUP= MILTER
-OPTIONS_GROUP_MILTER= DCCM PORTS_SENDMAIL
+OPTIONS_GROUP_MILTER= DCCM PORTS_MILTER
DCCIFD_DESC= DCC interface daemon (for SpamAssassin etc)
-DCCM_DESC= DCC milter (for Sendmail only)
+DCCM_DESC= DCC milter
DCCD_DESC= DCC server
DCCGREY_DESC= DCC greylisting server
-ALT_HOME_DESC= DCC home in /var/dcc (see help)
-PORTS_SENDMAIL_DESC= Use ports Sendmail instead of base
+PORTS_MILTER_DESC= Use ports milter instead of base
OPTIONS_SUB= yes
@@ -44,6 +44,8 @@ DCCGROUP?= dcc
USERS= ${DCCUSER}
GROUPS= ${DCCGROUP}
+DCCHOME= ${PREFIX}/dcc
+
PLIST_SUB+= DCCUSER="${DCCUSER}" DCCGROUP="${DCCGROUP}"
SUB_FILES= pkg-install pkg-message
SUB_LIST+= WRKSRC=${WRKSRC} DCCHOME=${DCCHOME}
@@ -59,15 +61,17 @@ CONFIGURE_ARGS= -q \
--with-configsuffix=.sample \
--with-make-cmd=${MAKE_CMD} \
--with-install-cmd=${BSD_INSTALL_PROGRAM} \
- --enable-pkg-make
+ --enable-pkg-make \
+ --homedir=${DCCHOME} \
+ --libexecdir=${DCCHOME}/libexec \
+ --with-cgibin=${DCCHOME}/cgi-bin
CONFIGURE_ENV= ac_cv_header_histedit_h=no # disable libedit detection
-ALT_HOME_CONFIGURE_ON= --libexecdir=${PREFIX}/dcc/libexec --with-cgibin=${PREFIX}/dcc/cgi-bin
DCCM_CONFIGURE_ENABLE= dccm
DCCM_USE= rc_subr=dccm
-PORTS_SENDMAIL_BUILD_DEPENDS= ${LOCALBASE}/lib/libmilter.a:mail/libmilter
-PORTS_SENDMAIL_CONFIGURE_ON= --with-sendmail=yes
+PORTS_MILTER_BUILD_DEPENDS= ${LOCALBASE}/lib/libmilter.a:mail/libmilter
+PORTS_MILTER_CONFIGURE_ON= --with-sendmail=yes
DCCIFD_CONFIGURE_ENABLE= dccifd
DCCIFD_USE= rc_subr=dccifd
DCCD_CONFIGURE_ENABLE= server
@@ -77,33 +81,10 @@ DCCGREY_USE= rc_subr=dccgrey
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MALT_HOME}
-DCCHOME= /var/dcc
-.else
-DCCHOME= ${PREFIX}/dcc
-.endif
-
-CONFIGURE_ARGS+= --homedir=${DCCHOME}
-
## dccm milter support
#
-.if ${PORT_OPTIONS:MDCCM}
-
-.if !exists(/usr/lib/libmilter.a) && !exists(${LOCALBASE}/lib/libmilter.a)
-IGNORE= neither base system nor Ports version of Sendmail installed, cannot build milter
-.endif
-.if ! ${PORT_OPTIONS:MPORTS_SENDMAIL} && !exists(/usr/lib/libmilter.a)
-IGNORE= base system Sendmail not found or too old, rebuild with WITH_PORTS_SENDMAIL=yes or WITHOUT_DCCM=yes
-.endif
-.if ${PORT_OPTIONS:MPORTS_SENDMAIL} && !exists(${LOCALBASE}/lib/libmilter.a)
-IGNORE= ports Sendmail not found, rebuild with WITHOUT_PORTS_SENDMAIL=yes or WITHOUT_DCCM=yes
-.endif
-
-.if ! ${PORT_OPTIONS:MPORTS_SENDMAIL}
-MILTERBASE= /usr
-.else
+.if ${PORT_OPTIONS:MPORTS_MILTER}
MILTERBASE?= ${LOCALBASE}
-.endif
MILTERINC= ${MILTERBASE}/include
MILTERLIB= ${MILTERBASE}/lib
diff --git a/mail/dcc-dccd/pkg-plist b/mail/dcc-dccd/pkg-plist
index 46ede012e990..bc693952ad29 100644
--- a/mail/dcc-dccd/pkg-plist
+++ b/mail/dcc-dccd/pkg-plist
@@ -54,8 +54,6 @@ man/man8/dccifd.8.gz
man/man8/dccm.8.gz
man/man8/dccproc.8.gz
man/man8/dccsight.8.gz
-%%ALT_HOME%%@dir dcc
-%%ALT_HOME%%@cwd /var
@owner %%DCCUSER%%
@group %%DCCGROUP%%
@sample dcc/dcc_conf.sample
@@ -78,8 +76,6 @@ man/man8/dccsight.8.gz
%%DCCGREY%%@unexec [ -e %D/dcc/grey_flod.map ] && rm -f %D/dcc/grey_flod.map || true
%%DCCGREY%%@unexec [ -e %D/dcc/grey_clients ] && rm -f %D/dcc/grey_clients || true
@dir dcc/log
-%%NO_ALT_HOME%%@group wheel
-%%NO_ALT_HOME%%@owner root
+@group wheel
+@owner root
@dir dcc
-%%ALT_HOME%%@group wheel
-%%ALT_HOME%%@owner root