aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-21 00:47:27 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-21 00:47:27 +0000
commitdda8d1c60c52402e1b77e3f26c79ca776c96e56a (patch)
tree21d069bfef80a4b55a51252ca42d1d1e0448caa7
parent0d4fe976b0cf8c2802766f4d9d7aa69acd088d69 (diff)
downloadports-dda8d1c60c52402e1b77e3f26c79ca776c96e56a.tar.gz
ports-dda8d1c60c52402e1b77e3f26c79ca776c96e56a.zip
upgrade to 3.2-4
change maintainer email PR: 42634 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=66943
-rw-r--r--lang/squeak3/Makefile45
-rw-r--r--lang/squeak3/distinfo4
-rw-r--r--lang/squeak3/files/patch-openpty-h14
-rw-r--r--lang/squeak3/pkg-descr2
-rw-r--r--lang/squeak3/pkg-plist19
5 files changed, 49 insertions, 35 deletions
diff --git a/lang/squeak3/Makefile b/lang/squeak3/Makefile
index 0e84bb6b88a3..1573b21b8866 100644
--- a/lang/squeak3/Makefile
+++ b/lang/squeak3/Makefile
@@ -1,37 +1,42 @@
# New ports collection makefile for: squeak
# Date created: 12 October 2001
-# Whom: jesse@cs.uni-magdeburg.de
+# Whom: roland.jesse@gmx.net
#
# $FreeBSD$
#
PORTNAME= squeak
-PORTVERSION= 3.0
+PORTVERSION= 3.2
CATEGORIES= lang
-MASTER_SITES= ftp://ftp.cs.uni-magdeburg.de/pub/Smalltalk/Smalltalk/Squeak/3.0/unix-linux/src/ \
- ftp://ftp.cs.uni-magdeburg.de/pub/Smalltalk/Smalltalk/Squeak/3.0/platform-independent/
-DISTNAME= Squeak-${PORTVERSION}-src
+MASTER_SITES= ftp://ftp.cs.uni-magdeburg.de/pub/Smalltalk/Smalltalk/Squeak/3.2/unix-linux/ \
+ ftp://ftp.cs.uni-magdeburg.de/pub/Smalltalk/Smalltalk/Squeak/3.2/ \
+ ftp://st.cs.uiuc.edu/Smalltalk/Squeak/3.2/unix-linux/
+DISTNAME= Squeak-${SQUEAK_VERSION}.src
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${SQUEAK_SRC} ${SQUEAK_IMAGE_SRC}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER= jesse@cs.uni-magdeburg.de
+MAINTAINER= roland.jesse@gmx.net
# Don't set USE_ZIP as this breaks EXTRACT_CMD, EXTRACT_SUFX, and what not.
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+SQUEAK_VERSION= 3.2-4
+SQUEAK_PATCHNR= 4956
SQUEAK_SRC= SqueakV3.sources.gz
-SQUEAK_IMAGE_SRC= Squeak3.0-3552.zip
-SQUEAK_IMAGE= Squeak3.0.image Squeak3.0.changes
+SQUEAK_IMAGE_SRC= Squeak3.2-4956.zip
+SQUEAK_IMAGE= Squeak3.2-${SQUEAK_PATCHNR}.image \
+ Squeak3.2-${SQUEAK_PATCHNR}.changes
-WRKSRC= ${WRKDIR}/Squeak-3.0
+WRKSRC= ${WRKDIR}/Squeak-${SQUEAK_VERSION}
+MAN1= inisqueak.1 squeak.1
USE_XLIB= yes
USE_GMAKE= yes
HAS_CONFIGURE= yes
INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= ${PREFIX}/share/squeak/3.0
+LDCONFIG_DIRS= ${PREFIX}/share/squeak/${SQUEAK_VERSION}
CONFIGURE_WRKSRC= ${WRKSRC}/build
INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
-CONFIGURE_SCRIPT= ../src/unix/configure
+CONFIGURE_SCRIPT= ../platforms/unix/config/configure
CONFIGURE_ARGS+= --libdir=${PREFIX}/share
# don't pass "-s" to install to avoid trying to strip a shell script
CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE}"
@@ -53,8 +58,13 @@ post-install:
(cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${SQUEAK_SRC} ${PREFIX}/share/squeak/)
(cd ${PREFIX}/share/squeak && ${EXTRACT_CMD} -d ${SQUEAK_SRC})
(cd ${PREFIX}/share/squeak && unzip -x ${DISTDIR}/${DIST_SUBDIR}/${SQUEAK_IMAGE_SRC})
- (cd ${PREFIX}/share/squeak && ${CHMOD} 644 Squeak3.0.changes)
- strip ${PREFIX}/share/squeak/3.0/squeak
+.for file in ${SQUEAK_IMAGE}
+ (cd ${PREFIX}/share/squeak && ${GZIP_CMD} ${file})
+.endfor
+ strip ${PREFIX}/share/squeak/${SQUEAK_VERSION}/squeak
+# install inisqueak and change the build in version number on the fly
+ ${SED} -e 's|VERSION=3.2gamma-4881|VERSION=3.2-4956|' ${WRKSRC}/build/inisqueak > ${PREFIX}/bin/inisqueak
+ (cd ${PREFIX}/bin && ${CHMOD} 755 inisqueak)
@${ECHO} "--------------- Please note: ---------------"
@${ECHO} "Make sure you have ${PREFIX}/bin in your PATH"
@${ECHO} "and ${PREFIX}/lib in your LD_LIBRARY_PATH."
@@ -62,14 +72,7 @@ post-install:
@${ECHO} "In order to be able to make use of squeak you need"
@${ECHO} "to have an image and a changes file in your working"
@${ECHO} "directory as well as access to a source file."
- @${ECHO} "Execute the following:"
- @${ECHO} "cd <your_private_working_directory>"
- @${ECHO} "cp ${PREFIX}/share/squeak/Squeak3.0.image ."
- @${ECHO} "cp ${PREFIX}/share/squeak/Squeak3.0.changes ."
- @${ECHO} "ln -s ${PREFIX}/share/squeak/SqueakV3.sources ."
- @${ECHO} ""
- @${ECHO} "To finally start up the system type:"
- @${ECHO} "squeak Squeak3.0.image"
+ @${ECHO} "Please see the inisqueak(1) manpage for details."
@${ECHO} "--------------- Thanks for listening. ---------------"
.include <bsd.port.mk>
diff --git a/lang/squeak3/distinfo b/lang/squeak3/distinfo
index 5cc8dfb314cb..cb01130097bb 100644
--- a/lang/squeak3/distinfo
+++ b/lang/squeak3/distinfo
@@ -1,3 +1,3 @@
-MD5 (squeak/Squeak-3.0-src.tar.gz) = 0125f53c1e1db20639f328088c3824de
+MD5 (squeak/Squeak-3.2-4.src.tar.gz) = 14d19111d8a976cdb6e0bd76d43df7a6
MD5 (squeak/SqueakV3.sources.gz) = 7dc6b3840e6bc1e5f81e3717fb46d2c3
-MD5 (squeak/Squeak3.0-3552.zip) = 7256e4b4d568b53499f2a346930308e6
+MD5 (squeak/Squeak3.2-4956.zip) = bb87597c508b92aab832bd067c49e9c6
diff --git a/lang/squeak3/files/patch-openpty-h b/lang/squeak3/files/patch-openpty-h
new file mode 100644
index 000000000000..c63044a4b7db
--- /dev/null
+++ b/lang/squeak3/files/patch-openpty-h
@@ -0,0 +1,14 @@
+--- platforms/unix/plugins/PseudoTTYPlugin/openpty.h.orig Tue Sep 10 13:38:07 2002
++++ platforms/unix/plugins/PseudoTTYPlugin/openpty.h Tue Sep 10 13:38:52 2002
+@@ -43,7 +43,10 @@
+ # elif defined(HAVE_UTIL_H)
+ # include <util.h> /* openpty() */
+ # else
+-# error: cannot find headers for openpty()
++# include <sys/types.h>
++# include <sys/ioctl.h>
++# include <termios.h>
++# include <libutil.h>
+ # endif
+
+ #else /* !HAVE_OPENPTY */
diff --git a/lang/squeak3/pkg-descr b/lang/squeak3/pkg-descr
index edb315502dd3..4334f49f56f2 100644
--- a/lang/squeak3/pkg-descr
+++ b/lang/squeak3/pkg-descr
@@ -18,5 +18,3 @@ features:
* Sophistication (full Smalltalk-80 language, libraries, and tools).
WWW: http://www.squeak.org/
-
-Roland Jesse <jesse@cs.uni-magdeburg.de>
diff --git a/lang/squeak3/pkg-plist b/lang/squeak3/pkg-plist
index 8a259bcc60f4..f5ca1c72f9ef 100644
--- a/lang/squeak3/pkg-plist
+++ b/lang/squeak3/pkg-plist
@@ -1,14 +1,13 @@
bin/squeak
bin/inisqueak
-share/squeak/3.0/Profiler.la
-share/squeak/3.0/Profiler.so
-share/squeak/3.0/System.la
-share/squeak/3.0/System.so
-share/squeak/3.0/inisqueak
-share/squeak/3.0/squeak
-share/squeak/3.0/squeak.map
-share/squeak/Squeak3.0.changes
-share/squeak/Squeak3.0.image
+share/squeak/3.2-4/squeak
+share/squeak/3.2-4/B3DAcceleratorPlugin.la
+share/squeak/3.2-4/UnixOSProcessPlugin.la
+share/squeak/3.2-4/libB3DAcceleratorPlugin.a
+share/squeak/3.2-4/libUnixOSProcessPlugin.a
+share/squeak/ReadMe.txt
+share/squeak/Squeak3.2-4956.changes.gz
+share/squeak/Squeak3.2-4956.image.gz
share/squeak/SqueakV3.sources
-@dirrm share/squeak/3.0
+@dirrm share/squeak/3.2-4
@dirrm share/squeak