aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-05-09 08:38:12 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-05-09 08:39:26 +0000
commitddcc71ca2065fc1561b3090362e01712668c0981 (patch)
treecc54150c7a899461e10ee60b3b1ddc03ef92e609
parentb57e7c66ae360b1164b52d52b29d4e3fc1e7ea9b (diff)
downloadports-ddcc71ca2065fc1561b3090362e01712668c0981.tar.gz
ports-ddcc71ca2065fc1561b3090362e01712668c0981.zip
databases/arrow: Fix build on 14
clang-11 crashes on 14, so use clang-10 instead. Reported by: fallout
-rw-r--r--databases/arrow/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/databases/arrow/Makefile b/databases/arrow/Makefile
index 732243266ae5..2862a156f9e4 100644
--- a/databases/arrow/Makefile
+++ b/databases/arrow/Makefile
@@ -1,5 +1,6 @@
PORTNAME= arrow
DISTVERSION= 4.0.0
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= https://mirrors.advancedhosters.com/apache/${PORTNAME}/${PORTNAME}-${DISTVERSION}/ \
https://github.com/apache/orc/archive/rel/:orc
@@ -167,6 +168,16 @@ OPTIONS_DEFAULT+= ${opt}
. endif
.endfor
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == clang && ${OPSYS} == FreeBSD
+LLVM_VER= 10 # clang-11 crashes on FreeBSD 14: https://bugs.llvm.org/show_bug.cgi?id=50277
+
+BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
+CC= ${LOCALBASE}/bin/clang${LLVM_VER}
+CXX= ${LOCALBASE}/bin/clang++${LLVM_VER}
+.endif
+
pre-configure-PYTHON-on:
@${REINPLACE_CMD} -e ' \
s|arrow_python|arrow_python${PYTHON_SUFFIX}|g; \
@@ -219,4 +230,4 @@ do-test: # tests fail to compile: https://issues.apache.org/jira/browse/ARROW-12
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>